diff mbox series

[OpenWrt-Devel] build: IS_TTY is now set according to GNU Make's MAKE_TERMOUT

Message ID mailman.21997.1591781638.2542.openwrt-devel@lists.openwrt.org
State Accepted
Delegated to: Paul Spooren
Headers show
Series [OpenWrt-Devel] build: IS_TTY is now set according to GNU Make's MAKE_TERMOUT | expand

Commit Message

R. Diez June 10, 2020, 9:33 a.m. UTC
The sender domain has a DMARC Reject/Quarantine policy which disallows
sending mailing list messages using the original "From" header.

To mitigate this problem, the original message has been wrapped
automatically by the mailing list software.
Fixes: FS#2086
The logic for IS_TTY was broken, because it was testing stdin
instead of stdout.
MAKE_TERMOUT was introduced in GNU Make version 4.1 (05 Oct 2014),
so it should be available everywhere nowadays.

Signed-off-by: R. Diez <rdiezmail-openwrt@yahoo.com>
---
 include/toplevel.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/include/toplevel.mk b/include/toplevel.mk
index 5cf93ce7ef..a9c503db61 100644
--- a/include/toplevel.mk
+++ b/include/toplevel.mk
@@ -8,7 +8,7 @@ 
 
 PREP_MK= OPENWRT_BUILD= QUIET=0
 
-export IS_TTY=$(shell tty -s && echo 1 || echo 0)
+export IS_TTY=$(if $(MAKE_TERMOUT),1,0)
 
 include $(TOPDIR)/include/verbose.mk