diff mbox series

valgrind: fix config missing in menuconfig.

Message ID fcd8747f-fd04-4968-9631-77a112995163@quicinc.com
State Rejected, archived
Delegated to: Chuanhong Guo
Headers show
Series valgrind: fix config missing in menuconfig. | expand

Commit Message

Shoudi Li (Stephen) Jan. 6, 2024, 1:14 a.m. UTC
Anyone could help review this change ? the configure item is missing in 
menuconfig on QCOM MBB kuno device (32bit). we need this change to fix.

Thanks
Shouil

-------- Forwarded Message --------
Subject: [PATCH] valgrind: fix config missing in menuconfig.
Date: Tue, 7 Nov 2023 10:00:06 +0800
From: quic_shoudil@quicinc.com
To: openwrt-devel@lists.openwrt.org
CC: shoudil <quic_shoudil@quicinc.com>

From: shoudil <quic_shoudil@quicinc.com>

Enable valgrind related configs in menuconfig to support compile on
32bit arm targets.

Signed-off-by: shoudil <quic_shoudil@quicinc.com>
---
  package/devel/valgrind/Makefile | 2 +-
  1 file changed, 1 insertion(+), 1 deletion(-)

    URL:=http://www.valgrind.org
  endef
diff mbox series

Patch

diff --git a/package/devel/valgrind/Makefile 
b/package/devel/valgrind/Makefile
index f696b28c3c..694d63983c 100644
--- a/package/devel/valgrind/Makefile
+++ b/package/devel/valgrind/Makefile
@@ -33,7 +33,7 @@  include $(INCLUDE_DIR)/kernel.mk
  define Package/valgrind
    SECTION:=devel
    CATEGORY:=Development
- 
DEPENDS:=@mips||mipsel||mips64||mips64el||i386||x86_64||powerpc||arm_v7||aarch64 
+libpthread +librt
+ 
DEPENDS:=@mips||mipsel||mips64||mips64el||i386||x86_64||powerpc||arm||arm_v7||aarch64 
+libpthread +librt
    TITLE:=debugging and profiling tools for Linux