diff mbox series

Add support for Renkforce WS-WN530HP3-A

Message ID d121def7-56f1-6bb4-4dfd-dcd848efd831@birger-koblitz.de
State Changes Requested
Delegated to: Petr Štetiar
Headers show
Series Add support for Renkforce WS-WN530HP3-A | expand

Commit Message

Birger Koblitz March 4, 2022, 11:13 a.m. UTC
This adds support for the Renkforce WS-WN530HP3-A ceiling-
mountable Wireless Access Point, which is powered over PoE.
Hardware:
	- SoC: Mediatek MT7621DAT
	- RAM: 128MiB on SoC
	- Flash: 16MiB GigaDevice GD25Q128C
	- 2.4Ghz Wifi: Mediatek MT603EN
	- 5GHz Wifi: MT613BEN
	- Ethernet:
	  - 1x 1GBit WAN port, passive PoE capable
	  - 2x 1GBit LAN ports
	LEDs: 1x Power LED (red)
	Buttons: 1x Reset Button, 1x Power Button

Installation:
	Power on the access point and immediately press the reset
	button for 10 seconds. Connect web-browser to 192.168.10.1
	and upload sysupgrade image. Flash uploaded image and wait
	about 2 minutes for reboot.

Signed-off-by: Birger Koblitz <git@birger-koblitz.de>
---
  .../dts/mt7621_renkforce_ws-wn530hp3-a.dts    | 154 ++++++++++++++++++
  target/linux/ramips/image/mt7621.mk           |  11 ++
  .../mt7621/base-files/etc/board.d/02_network  |   1 +
  3 files changed, 167 insertions(+)
  create mode 100644 target/linux/ramips/dts/mt7621_renkforce_ws-wn530hp3-a.dts

Comments

Petr Štetiar March 8, 2022, 5:31 p.m. UTC | #1
Hi,

it's somehow borken:

 $ curl https://patchwork.ozlabs.org/project/openwrt/patch/d121def7-56f1-6bb4-4dfd-dcd848efd831@birger-koblitz.de/mbox/ | git am
 ...
 Applying: Add support for Renkforce WS-WN530HP3-A
 error: corrupt patch at line 168
 Patch failed at 0001 Add support for Renkforce WS-WN530HP3-A

-- ynezz
Birger Koblitz March 8, 2022, 8:30 p.m. UTC | #2
Hi Petr,

there is a v2 of this patch which I sent yesterday at 18:31 to the list.
I applied what I sent then as a patch and it works for me.
It fixes the subject by adding a ramips tag and adds a second LED, which
I did not notice initially.

Cheers,
  Birger

On 08.03.22 18:31, Petr Štetiar wrote:
> Hi,
> 
> it's somehow borken:
> 
>  $ curl https://patchwork.ozlabs.org/project/openwrt/patch/d121def7-56f1-6bb4-4dfd-dcd848efd831@birger-koblitz.de/mbox/ | git am
>  ...
>  Applying: Add support for Renkforce WS-WN530HP3-A
>  error: corrupt patch at line 168
>  Patch failed at 0001 Add support for Renkforce WS-WN530HP3-A
> 
> -- ynezz
>
diff mbox series

Patch

diff --git a/target/linux/ramips/dts/mt7621_renkforce_ws-wn530hp3-a.dts b/target/linux/ramips/dts/mt7621_renkforce_ws-wn530hp3-a.dts
new file mode 100644
index 0000000000..631cda6a2e
--- /dev/null
+++ b/target/linux/ramips/dts/mt7621_renkforce_ws-wn530hp3-a.dts
@@ -0,0 +1,155 @@ 
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "mt7621.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+	compatible = "renkforce,ws-wn530hp3-a", "mediatek,mt7621-soc";
+	model = "Renkforce WS-WN530HP3-A";
+
+	aliases {
+		label-mac-device = &gmac0;
+		led-boot = &led_power;
+		led-failsafe = &led_power;
+		led-running = &led_power;
+		led-upgrade = &led_power;
+	};
+
+	keys {
+		compatible = "gpio-keys";
+
+		reset {
+			label = "reset";
+			gpios = <&gpio 18 GPIO_ACTIVE_LOW>;
+			linux,code = <KEY_RESTART>;
+		};
+	};
+
+	leds {
+		compatible = "gpio-leds";
+
+		led_power: led_1 {
+			label = "red:led1";
+			gpios = <&gpio 17 GPIO_ACTIVE_LOW>;
+		};
+	};
+};
+
+&spi0 {
+	status = "okay";
+
+	flash@0 {
+		compatible = "jedec,spi-nor";
+		reg = <0>;
+		spi-max-frequency = <40000000>;
+
+		partitions {
+			compatible = "fixed-partitions";
+			#address-cells = <1>;
+			#size-cells = <1>;
+
+			partition@0 {
+				label = "u-boot";
+				reg = <0x0 0x30000>;
+				read-only;
+			};
+
+			partition@30000 {
+				label = "u-boot-env";
+				reg = <0x30000 0x10000>;
+				read-only;
+			};
+
+			factory: partition@40000 {
+				label = "factory";
+				reg = <0x40000 0x10000>;
+				read-only;
+			};
+
+			partition@50000 {
+				compatible = "denx,uimage";
+				label = "firmware";
+				reg = <0x50000 0xf30000>;
+			};
+		};
+	};
+};
+
+&pcie {
+	status = "okay";
+};
+
+&pcie0 {
+	wifi0: wifi@0,0 {
+		compatible = "mediatek,mt76";
+		reg = <0x0000 0 0 0 0>;
+		mediatek,mtd-eeprom = <&factory 0x0000>;
+		ieee80211-freq-limit = <2400000 2500000>;
+		nvmem-cells = <&macaddr_factory_4>;
+		nvmem-cell-names = "mac-address";
+	};
+};
+
+&pcie1 {
+	wifi1: wifi@0,0 {
+		compatible = "mediatek,mt76";
+		reg = <0x0000 0 0 0 0>;
+		mediatek,mtd-eeprom = <&factory 0x8000>;
+		ieee80211-freq-limit = <5000000 6000000>;
+		nvmem-cells = <&macaddr_factory_4>;
+		nvmem-cell-names = "mac-address";
+		mac-address-increment = <1>;
+	};
+};
+
+&gmac0 {
+	nvmem-cells = <&macaddr_factory_4>;
+	nvmem-cell-names = "mac-address";
+	mac-address-increment = <(-2)>;
+};
+
+&switch0 {
+	ports {
+		port@0 {
+			status = "okay";
+			label = "lan2";
+		};
+
+		port@1 {
+			status = "okay";
+			label = "lan1";
+		};
+
+		port@4 {
+			status = "okay";
+			label = "wan";
+			nvmem-cells = <&macaddr_factory_4>;
+			nvmem-cell-names = "mac-address";
+			mac-address-increment = <(-1)>;
+		};
+	};
+};
+
+&state_default {
+	gpio {
+		groups = "uart2", "jtag", "wdt";
+		function = "gpio";
+	};
+};
+
+&xhci {
+	status = "disabled";
+};
+
+&factory {
+	compatible = "nvmem-cells";
+	#address-cells = <1>;
+	#size-cells = <1>;
+
+	macaddr_factory_4: macaddr@4 {
+		reg = <0x4 0x6>;
+	};
+};
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 340c8eab3c..6a49321455 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -1359,6 +1359,17 @@  define Device/raisecom_msg1500-x-00
  endef
  TARGET_DEVICES += raisecom_msg1500-x-00

+define Device/renkforce_ws-wn530hp3-a
+  $(Device/dsa-migration)
+  DEVICE_VENDOR := Renkforce
+  DEVICE_MODEL := WS-WN530HP3-A
+  DEVICE_PACKAGES += kmod-mt7603 kmod-mt7615e kmod-mt7663-firmware-ap
+  IMAGE/sysupgrade.bin := append-kernel | pad-to 65536 | append-rootfs | \
+	check-size | append-metadata
+  IMAGE_SIZE := 15040k
+endef
+TARGET_DEVICES += renkforce_ws-wn530hp3-a
+
  define Device/samknows_whitebox-v8
    $(Device/dsa-migration)
    IMAGE_SIZE := 16064k
diff --git a/target/linux/ramips/mt7621/base-files/etc/board.d/02_network b/target/linux/ramips/mt7621/base-files/etc/board.d/02_network
index 374a260882..72c73c9abe 100644
--- a/target/linux/ramips/mt7621/base-files/etc/board.d/02_network
+++ b/target/linux/ramips/mt7621/base-files/etc/board.d/02_network
@@ -43,6 +43,7 @@  ramips_setup_interfaces()
  	jcg,q20|\
  	lenovo,newifi-d1|\
  	mikrotik,routerboard-m33g|\
+	renkforce,ws-wn530hp3-a|\
  	xiaomi,mi-router-3g|\
  	xiaomi,mi-router-3g-v2|\
  	xiaomi,mi-router-4|\