diff mbox

[OpenWrt-Devel] musl: fix build on sh3

Message ID alpine.DEB.2.02.1509140929531.6601@trabant.deployis.eu
State Changes Requested
Headers show

Commit Message

Zoltan HERPAI Sept. 14, 2015, 8:38 a.m. UTC
musl fails to build when compiled with gcc on sh3 (GCC target/#67260).
Work it around.

Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
---
  toolchain/musl/common.mk |    5 +++++
  1 file changed, 5 insertions(+)

         CFLAGS="$(TARGET_CFLAGS)" \
--
1.7.10.4

Comments

John Crispin Sept. 16, 2015, 7:27 a.m. UTC | #1
Hi,

On 14/09/2015 10:38, Zoltan HERPAI wrote:
> musl fails to build when compiled with gcc on sh3 (GCC target/#67260).
> Work it around.
> 
> Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
> ---
>  toolchain/musl/common.mk |    5 +++++
>  1 file changed, 5 insertions(+)
> 
> diff --git a/toolchain/musl/common.mk b/toolchain/musl/common.mk
> index 82c1543..ba467fb 100644
> --- a/toolchain/musl/common.mk
> +++ b/toolchain/musl/common.mk
> @@ -23,6 +23,11 @@
> HOST_BUILD_DIR:=$(BUILD_DIR_TOOLCHAIN)/$(PKG_NAME)-$(PKG_VERSION)
>  include $(INCLUDE_DIR)/toolchain-build.mk
>  include $(INCLUDE_DIR)/hardening.mk
> 
> +ifeq ($(CONFIG_sh3),y)
> +TARGET_CFLAGS+= \
> +       -fno-optimize-sibling-calls
> +endif
> +

i am worried that this will be added and never removed as we will forget
about it. how about making it also depend on the broken gcc version.

	John

>  MUSL_CONFIGURE:= \
>         $(TARGET_CONFIGURE_OPTS) \
>         CFLAGS="$(TARGET_CFLAGS)" \
> -- 
> 1.7.10.4
> _______________________________________________
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel
Felix Fietkau Sept. 16, 2015, 7:59 a.m. UTC | #2
On 2015-09-16 09:27, John Crispin wrote:
> Hi,
> 
> On 14/09/2015 10:38, Zoltan HERPAI wrote:
>> musl fails to build when compiled with gcc on sh3 (GCC target/#67260).
>> Work it around.
>> 
>> Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
>> ---
>>  toolchain/musl/common.mk |    5 +++++
>>  1 file changed, 5 insertions(+)
>> 
>> diff --git a/toolchain/musl/common.mk b/toolchain/musl/common.mk
>> index 82c1543..ba467fb 100644
>> --- a/toolchain/musl/common.mk
>> +++ b/toolchain/musl/common.mk
>> @@ -23,6 +23,11 @@
>> HOST_BUILD_DIR:=$(BUILD_DIR_TOOLCHAIN)/$(PKG_NAME)-$(PKG_VERSION)
>>  include $(INCLUDE_DIR)/toolchain-build.mk
>>  include $(INCLUDE_DIR)/hardening.mk
>> 
>> +ifeq ($(CONFIG_sh3),y)
>> +TARGET_CFLAGS+= \
>> +       -fno-optimize-sibling-calls
>> +endif
>> +
> 
> i am worried that this will be added and never removed as we will forget
> about it. how about making it also depend on the broken gcc version.
There is no non-broken gcc version yet. I think we should at least have
a link to the gcc bug report directly above these lines, so we don't
have to dig through the log to figure out why this was added.

- Felix
Zoltan HERPAI Sept. 19, 2015, 12:09 a.m. UTC | #3
Felix Fietkau wrote:
> On 2015-09-16 09:27, John Crispin wrote:
>   
>> Hi,
>>
>> On 14/09/2015 10:38, Zoltan HERPAI wrote:
>>     
>>> musl fails to build when compiled with gcc on sh3 (GCC target/#67260).
>>> Work it around.
>>>
>>> Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
>>> ---
>>>  toolchain/musl/common.mk |    5 +++++
>>>  1 file changed, 5 insertions(+)
>>>
>>> diff --git a/toolchain/musl/common.mk b/toolchain/musl/common.mk
>>> index 82c1543..ba467fb 100644
>>> --- a/toolchain/musl/common.mk
>>> +++ b/toolchain/musl/common.mk
>>> @@ -23,6 +23,11 @@
>>> HOST_BUILD_DIR:=$(BUILD_DIR_TOOLCHAIN)/$(PKG_NAME)-$(PKG_VERSION)
>>>  include $(INCLUDE_DIR)/toolchain-build.mk
>>>  include $(INCLUDE_DIR)/hardening.mk
>>>
>>> +ifeq ($(CONFIG_sh3),y)
>>> +TARGET_CFLAGS+= \
>>> +       -fno-optimize-sibling-calls
>>> +endif
>>> +
>>>       
>> i am worried that this will be added and never removed as we will forget
>> about it. how about making it also depend on the broken gcc version.
>>     
> There is no non-broken gcc version yet. I think we should at least have
> a link to the gcc bug report directly above these lines, so we don't
> have to dig through the log to figure out why this was added.
>   
Can't argue with the need to have a link directly to describe the issue 
- I'll create a v2.

Thanks,
-w-
diff mbox

Patch

diff --git a/toolchain/musl/common.mk b/toolchain/musl/common.mk
index 82c1543..ba467fb 100644
--- a/toolchain/musl/common.mk
+++ b/toolchain/musl/common.mk
@@ -23,6 +23,11 @@  
HOST_BUILD_DIR:=$(BUILD_DIR_TOOLCHAIN)/$(PKG_NAME)-$(PKG_VERSION)
  include $(INCLUDE_DIR)/toolchain-build.mk
  include $(INCLUDE_DIR)/hardening.mk

+ifeq ($(CONFIG_sh3),y)
+TARGET_CFLAGS+= \
+       -fno-optimize-sibling-calls
+endif
+
  MUSL_CONFIGURE:= \
         $(TARGET_CONFIGURE_OPTS) \