diff mbox series

[RFC,v1,1/8] base-files: support label-property-less in get_dt_leds

Message ID a6fdb75625b6f7fb9358f310ccaa3011d9fb42a0.1598756597.git.chunkeey@gmail.com
State RFC, archived
Delegated to: Christian Lamparter
Headers show
Series [RFC,v1,1/8] base-files: support label-property-less in get_dt_leds | expand

Commit Message

Christian Lamparter Aug. 30, 2020, 3:04 a.m. UTC
The "label" property we used and loved has been deprecated upstream by:

|commit c5d18dd6b64e09dd6984bda9bdd55160af537a8c
|Author: Jacek Anaszewski <jacek.anaszewski@gmail.com>
|Date:   Sun Jun 9 20:19:04 2019 +0200
|
|    dt-bindings: leds: Add properties for LED name construction
|
|    Introduce dedicated properties for conveying information about
|    LED function and color. Mark old "label" property as deprecated.
|
|    Additionally function-enumerator property is being provided
|    for the cases when neither function nor color can be used
|    for LED differentiation.

in order to be somewhat prepared, this patch adds a fallback
as a last resort to get a proper label based on the node-name.

Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
---
 package/base-files/Makefile                    | 2 +-
 package/base-files/files/lib/functions/leds.sh | 3 ++-
 2 files changed, 3 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 7eb3ac1868..2419849a44 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -12,7 +12,7 @@  include $(INCLUDE_DIR)/version.mk
 include $(INCLUDE_DIR)/feeds.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=227
+PKG_RELEASE:=228
 PKG_FLAGS:=nonshared
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
diff --git a/package/base-files/files/lib/functions/leds.sh b/package/base-files/files/lib/functions/leds.sh
index 43b2fe02ed..14baeb37b4 100644
--- a/package/base-files/files/lib/functions/leds.sh
+++ b/package/base-files/files/lib/functions/leds.sh
@@ -18,7 +18,8 @@  get_dt_led() {
 
 	[ -n "$ledpath" ] && \
 		label=$(cat "$ledpath/label" 2>/dev/null) || \
-		label=$(cat "$ledpath/chan-name" 2>/dev/null)
+		label=$(cat "$ledpath/chan-name" 2>/dev/null) || \
+		label=$(basename "$ledpath")
 
 	echo "$label"
 }