diff mbox series

[v2] rpcd: reload rpcd on installation of rpcd-mod-*

Message ID YXvXiOwBPoaH7I3S@makrotopia.org
State Accepted
Delegated to: Daniel Golle
Headers show
Series [v2] rpcd: reload rpcd on installation of rpcd-mod-* | expand

Commit Message

Daniel Golle Oct. 29, 2021, 11:14 a.m. UTC
When installing additional rpcd modules, a restart of rpcd is required.
This often confuses users as even after installing rpcd-mod-rpcsys the
relevant ubus objects are still missing until rpcd has been reloaded
(or the system has been rebooted, obviously).
Let rpcd-mod-* reload rpcd as post-install action.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
---
v2: use reload instead of restart to not break LuCI sessions

 package/system/rpcd/Makefile | 7 ++++++-
 1 file changed, 6 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/package/system/rpcd/Makefile b/package/system/rpcd/Makefile
index 9880ea4d66..1642c97a42 100644
--- a/package/system/rpcd/Makefile
+++ b/package/system/rpcd/Makefile
@@ -8,7 +8,7 @@ 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=rpcd
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL=$(PROJECT_GIT)/project/rpcd.git
@@ -84,6 +84,11 @@  define BuildPlugin
     $(3)
   endef
 
+  define Package/rpcd-mod-$(1)/postinst
+#!/bin/sh
+[ -n "$$$${IPKG_INSTROOT}" ] || /etc/init.d/rpcd reload
+  endef
+
   define Package/rpcd-mod-$(1)/install
 	$(INSTALL_DIR) $$(1)/usr/lib/rpcd
 	$(INSTALL_BIN) $(PKG_BUILD_DIR)/$(1).so $$(1)/usr/lib/rpcd/