diff mbox series

RES: openwrt-devel Digest, Vol 27, Issue 119

Message ID RO2P152MB302401B7685EA0F237DB8D76B7790@RO2P152MB3024.LAMP152.PROD.OUTLOOK.COM
State Not Applicable
Headers show
Series RES: openwrt-devel Digest, Vol 27, Issue 119 | expand

Commit Message

Luciano Gualberto July 22, 2020, 10:39 p.m. UTC
Senhores,
Não consigo logar no ip , erro: 92.168.1.1 recusou a conexão.
Pesquise na Web por 192 168 1 1
ERR_CONNECTION_REFUSED
Luciano Gualberto

-----Mensagem original-----
De: openwrt-devel <openwrt-devel-bounces@lists.openwrt.org> Em nome de openwrt-devel-request@lists.openwrt.org
Enviada em: quarta-feira, 22 de julho de 2020 19:34
Para: openwrt-devel@lists.openwrt.org
Assunto: openwrt-devel Digest, Vol 27, Issue 119

Send openwrt-devel mailing list submissions to
	openwrt-devel@lists.openwrt.org

To subscribe or unsubscribe via the World Wide Web, visit
	https://lists.openwrt.org/mailman/listinfo/openwrt-devel
or, via email, send a message with subject or body 'help' to
	openwrt-devel-request@lists.openwrt.org

You can reach the person managing the list at
	openwrt-devel-owner@lists.openwrt.org

When replying, please edit your Subject line so it is more specific than "Re: Contents of openwrt-devel digest..."


Today's Topics:

   1. ipq806x: support for Linksys E8350 v1 (Todor Colov)
   2. [PATCH 1/1] ipq806x: add support for Linksys e8350 v1
      (Todor Colov)
   3. [PATCH] tools: Add PKG_VERSION to flock (Paul Spooren)
   4. [PATCH] tools: Add PKG_VERSION to sstrip (Paul Spooren)
   5. [PATCH] tools: add PKG_VERSION to patch-image (Paul Spooren)
   6. [PATCH] tools: add PKG_VERSION to firmware-utils (Paul Spooren)
   7. Re: [PATCH] dropbear: allow disabling support for scp
      (Paul Spooren)


----------------------------------------------------------------------

Message: 1
Date: Wed, 22 Jul 2020 21:44:47 +0300
From: Todor Colov <todorcolov@abv.bg>
To: openwrt-devel@lists.openwrt.org
Cc: Todor Colov <todorcolov@abv.bg>
Subject: ipq806x: support for Linksys E8350 v1
Message-ID: <20200722184448.333-1-todorcolov@abv.bg>
Content-Type: text/plain; charset=UTF-8

Todor Colov (1):
  ipq806x: add support for Linksys e8350 v1

 .../ipq806x/base-files/etc/board.d/01_leds    |   3 +
 .../ipq806x/base-files/etc/board.d/02_network |   1 +
 .../base-files/lib/upgrade/platform.sh        |   5 +
 .../arm/boot/dts/qcom-ipq8064-e8350-v1.dts    | 246 ++++++++++++++++++
 target/linux/ipq806x/image/Makefile           |  29 +++
 .../0069-arm-boot-add-dts-files.patch         |   3 +-
 6 files changed, 286 insertions(+), 1 deletion(-)  create mode 100644 target/linux/ipq806x/files-5.4/arch/arm/boot/dts/qcom-ipq8064-e8350-v1.dts

--
2.27.0




------------------------------

Message: 2
Date: Wed, 22 Jul 2020 21:44:48 +0300
From: Todor Colov <todorcolov@abv.bg>
To: openwrt-devel@lists.openwrt.org
Cc: Todor Colov <todorcolov@abv.bg>
Subject: [PATCH 1/1] ipq806x: add support for Linksys e8350 v1
Message-ID: <20200722184448.333-2-todorcolov@abv.bg>
Content-Type: text/plain; charset=UTF-8

Device specifications:

Device specifications:
* SoC:  Qualcomm dual-core IPQ8064 @ 1.4 GHz
* RAM: 512MiB
* Flash: 4MiB SPI-NOR + 128 Nand
* Wireless 2.4GHz (SoC): b/g/n, Qualcomm QCA9880
* Wireless 5Ghz (QCA9886): a/n/ac, Quantenna QSR1000
* Ethernet (QCA8337): 1? 1GbE WAN + 4 x 1GbE LAN
* 1 x USB3.0 + 1 x USB2.0
* 1 eSata up to 3.0 Gbps

Flashing instructions:
* Upgrade with factory image via web interface

Debricking:
*  Get the original firmware: https://downloads.linksys.com/downloads/firmware/FW_E8350_1.0.03.003_20180929.bin
1. power off the device and disconnect the WAN port. (Only LAN port to be connected)
2. press & hold the ?Reset? button
3. power on the deiece & wait for 10 seconds with pressed ?Reset? button
- the Router will open Firmware Recovery ?http? server on IP: 192.168.1.1
4. set IP on your PC from 192.168.1.0/24 network ( Router is on IP 192.168.1.1 )
5. open in browser URL:
http://192.168.1.1/index.shtml

MAC addresses:
MAC address (as on device label) is stored in u-boot env
WLAN uses address incremented by 1.

Signed-off-by: Todor Colov <todorcolov@abv.bg>
---
 .../ipq806x/base-files/etc/board.d/01_leds    |   3 +
 .../ipq806x/base-files/etc/board.d/02_network |   1 +
 .../base-files/lib/upgrade/platform.sh        |   5 +
 .../arm/boot/dts/qcom-ipq8064-e8350-v1.dts    | 246 ++++++++++++++++++
 target/linux/ipq806x/image/Makefile           |  29 +++
 .../0069-arm-boot-add-dts-files.patch         |   3 +-
 6 files changed, 286 insertions(+), 1 deletion(-)
 create mode 100644 target/linux/ipq806x/files-5.4/arch/arm/boot/dts/qcom-ipq8064-e8350-v1.dts
diff mbox series

Patch

diff --git a/target/linux/ipq806x/base-files/etc/board.d/01_leds b/target/linux/ipq806x/base-files/etc/board.d/01_leds
index f8b6c32358..802fb41d74 100755
--- a/target/linux/ipq806x/base-files/etc/board.d/01_leds
+++ b/target/linux/ipq806x/base-files/etc/board.d/01_leds
@@ -19,6 +19,9 @@  compex,wpq864)
 	ucidef_set_led_usbport "usb" "USB" "wpq864:green:usb" "usb1-port1" "usb2-port1"
 	ucidef_set_led_usbport "pcie-usb" "PCIe USB" "wpq864:green:usb-pcie" "usb3-port1"
 	;;
+linksys,e8350-v1)
+        ucidef_set_led_wlan "wlan" "WLAN" "${boardname}:green:wifi" "phy0tpt"
+        ;;
 nec,wg2600hp)
 	ucidef_set_led_wlan "wlan2g" "WLAN2G" "${boardname}:green:wlan2g" "phy1tpt"
 	ucidef_set_led_wlan "wlan5g" "WLAN5G" "${boardname}:green:wlan5g" "phy0tpt"
diff --git a/target/linux/ipq806x/base-files/etc/board.d/02_network b/target/linux/ipq806x/base-files/etc/board.d/02_network
index 529a8d9f39..5e26fa2a8b 100755
--- a/target/linux/ipq806x/base-files/etc/board.d/02_network
+++ b/target/linux/ipq806x/base-files/etc/board.d/02_network
@@ -14,6 +14,7 @@  board=$(board_name)
 case "$board" in
 buffalo,wxr-2533dhp |\
 compex,wpq864 |\
+linksys,e8350-v1 |\
 netgear,d7800 |\
 netgear,r7500 |\
 netgear,r7500v2 |\
diff --git a/target/linux/ipq806x/base-files/lib/upgrade/platform.sh b/target/linux/ipq806x/base-files/lib/upgrade/platform.sh
index 560e64af3a..34b9da47af 100644
--- a/target/linux/ipq806x/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ipq806x/base-files/lib/upgrade/platform.sh
@@ -27,6 +27,11 @@  platform_do_upgrade() {
 	zyxel,nbg6817)
 		zyxel_do_upgrade "$1"
 		;;
+	linksys,e8350-v1)
+		# KERNEL_IN_UBI first remove metadata trailer from the UBI volume
+		/tmp/fwtool -q -t -i /dev/null "$1"
+		nand_do_upgrade "$1"
+		;;
 	linksys,ea7500-v1 |\
 	linksys,ea8500)
 		platform_do_upgrade_linksys "$1"
diff --git a/target/linux/ipq806x/files-5.4/arch/arm/boot/dts/qcom-ipq8064-e8350-v1.dts b/target/linux/ipq806x/files-5.4/arch/arm/boot/dts/qcom-ipq8064-e8350-v1.dts
new file mode 100644
index 0000000000..5b8cdd205d
--- /dev/null
+++ b/target/linux/ipq806x/files-5.4/arch/arm/boot/dts/qcom-ipq8064-e8350-v1.dts
@@ -0,0 +1,246 @@ 
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+#include "qcom-ipq8064-v2.0.dtsi"
+
+#include <dt-bindings/input/input.h>
+#include <dt-bindings/soc/qcom,tcsr.h>
+
+/ {
+	model = "Linksys EA8350 V1 WiFi Router";
+	compatible = "linksys,e8350-v1", "qcom,ipq8064";
+
+	memory@0 {
+		reg = <0x42000000 0x1e000000>;
+		device_type = "memory";
+	};
+
+	aliases {
+		serial0 = &gsbi4_serial;
+
+		led-boot = &led_power;
+		led-failsafe = &led_power;
+		led-running = &led_power;
+		led-upgrade = &led_power;
+	};
+
+	keys {
+		compatible = "gpio-keys";
+		pinctrl-0 = <&button_pins>;
+		pinctrl-names = "default";
+
+		reset {
+			label = "reset";
+			gpios = <&qcom_pinmux 68 GPIO_ACTIVE_LOW>;
+			linux,code = <KEY_RESTART>;
+		};
+
+		wps {
+			label = "wps";
+			gpios = <&qcom_pinmux 65 GPIO_ACTIVE_LOW>;
+			linux,code = <KEY_WPS_BUTTON>;
+		};
+
+		wifi {
+			label = "wifi";
+			gpios = <&qcom_pinmux 67 GPIO_ACTIVE_LOW>;
+			linux,code = <KEY_RFKILL>;
+		};
+	};
+
+	nand-controller@1ac00000 {
+		compatible = "qcom,ipq806x-nand";
+		reg = <0x1ac00000 0x800>;
+		clocks = <&gcc EBI2_CLK>,
+			<&gcc EBI2_AON_CLK>;
+		clock-names = "core", "aon";
+		dmas = <&adm_dma 3>;
+		dma-names = "rxtx";
+		qcom,cmd-crci = <15>;
+		qcom,data-crci = <3>;
+
+		nand@0 {
+			reg = <0>;
+
+			nand-ecc-strength = <4>;
+			nand-bus-width = <8>;
+
+			partitions {
+				compatible = "fixed-partitions";
+
+				partition@0 {
+					label = "ubi";
+					reg = <0 0x4000000>;
+				};
+	
+				partition@4000000 {
+					label = "extra";
+					reg = <0x4000000 0x4000000>;
+				};
+			};
+		};
+	};
+
+
+	leds {
+		compatible = "gpio-leds";
+		pinctrl-0 = <&led_pins>;
+		pinctrl-names = "default";
+
+		led_power: power {
+			label = "e8350-v1:green:power";
+			gpios = <&qcom_pinmux 26 GPIO_ACTIVE_HIGH>;
+			default-state = "keep";
+		};
+
+		wps {
+			label = "e8350-v1:green:wps";
+			gpios = <&qcom_pinmux 53 GPIO_ACTIVE_HIGH>;
+                };
+
+		wifi {
+			label = "e8350-v1:green:wifi";
+			gpios = <&qcom_pinmux 54 GPIO_ACTIVE_HIGH>;
+		};
+	};
+};
+
+&qcom_pinmux {
+	button_pins: button_pins {
+		mux {
+			pins = "gpio68","gpio65", "gpio67";
+			function = "gpio";
+			drive-strength = <2>;
+			bias-pull-up;
+		};
+	};
+
+	led_pins: led_pins {
+		mux {
+			pins = "gpio26","gpio53", "gpio54";
+			function = "gpio";
+			drive-strength = <2>;
+			bias-pull-up;
+		};
+	};
+};
+
+&gsbi4 {
+	qcom,mode = <GSBI_PROT_I2C_UART>;
+	status = "okay";
+	serial@16340000 {
+		status = "okay";
+	};
+	/*
+	* The i2c device on gsbi4 should not be enabled.
+	* On ipq806x designs gsbi4 i2c is meant for exclusive
+	* RPM usage. Turning this on in kernel manifests as
+	* i2c failure for the RPM.
+	*/
+};
+&gsbi5 {
+	qcom,mode = <GSBI_PROT_SPI>;
+	status = "okay";
+
+	spi5: spi@1a280000 {
+		status = "okay";
+
+		pinctrl-0 = <&spi_pins>;
+		pinctrl-names = "default";
+
+		cs-gpios = <&qcom_pinmux 20 GPIO_ACTIVE_HIGH>;
+
+		m25p80@0 {
+			compatible = "jedec,spi-nor";
+			spi-max-frequency = <51200000>;
+			reg = <0>;
+
+			partitions {
+				compatible = "qcom,smem";
+			};
+		};
+	};
+};
+
+&sata_phy {
+	status = "okay";
+};
+
+&sata {
+	status = "okay";
+};
+
+&usb3_0 {
+	clocks = <&gcc USB30_1_MASTER_CLK>;
+	status = "okay";
+};
+
+&usb3_1 {
+	clocks = <&gcc USB30_0_MASTER_CLK>;
+	status = "okay";
+};
+
+&pcie0 {
+	status = "okay";
+};
+
+&pcie1 {
+	status = "okay";
+};
+
+&pcie2 {
+	status = "okay";
+};
+
+&mdio0 {
+	status = "okay";
+
+	pinctrl-0 = <&mdio0_pins>;
+	pinctrl-names = "default";
+
+	phy0: ethernet-phy@0 {
+		reg = <0>;
+		qca,ar8327-initvals = <
+			0x00004 0x7600000   /* PAD0_MODE */
+			0x00008 0x1000000   /* PAD5_MODE */
+			0x0000c 0x80        /* PAD6_MODE */
+			0x00010 0x2613a0    /* PWS_REG */
+			0x000e4 0x6a545     /* MAC_POWER_SEL */
+			0x000e0 0xc74164de  /* SGMII_CTRL */
+			0x0007c 0x4e        /* PORT0_STATUS */
+			0x00094 0x4e        /* PORT6_STATUS */
+			>;
+	};
+};
+
+&gmac1 {
+	status = "okay";
+	phy-mode = "rgmii";
+	qcom,id = <1>;
+
+	pinctrl-0 = <&rgmii2_pins>;
+	pinctrl-names = "default";
+
+	fixed-link {
+		speed = <1000>;
+		full-duplex;
+	};
+};
+
+&gmac2 {
+	status = "okay";
+	phy-mode = "sgmii";
+	qcom,id = <2>;
+
+	fixed-link {
+		speed = <1000>;
+		full-duplex;
+	};
+};
+
+&tcsr {
+	qcom,usb-ctrl-select = <TCSR_USB_SELECT_USB3_DUAL>;
+	compatible = "qcom,tcsr";
+};
+
+&adm_dma {
+	status = "okay";
+};
diff --git a/target/linux/ipq806x/image/Makefile b/target/linux/ipq806x/image/Makefile
index 5cc66daa21..af428db9fd 100644
--- a/target/linux/ipq806x/image/Makefile
+++ b/target/linux/ipq806x/image/Makefile
@@ -13,6 +13,17 @@  define Build/buffalo-rootfs-cksum
 	) >> $@
 endef
 
+# tune addpattern for Linksys E8350-V1 fw pattern generation
+define Build/linksys-bin
+        $(STAGING_DIR_HOST)/bin/addpattern -p $(FW_DEVICE_ID) -v $(FW_VERSION) $(if $(SERIAL),-s $(SERIAL)) -i $@ -o $@.new
+        mv $@.new $@
+endef
+# Use Linksys fw header generator to upgrade openwrt factory image over the native Linksys WEB interface
+define Build/linksys-addfwhdr
+        -$(STAGING_DIR_HOST)/bin/linksys/addfwhdr -i $@ -o $@.new \
+       	;mv "$@.new" "$@"
+endef
+
 define Device/Default
 	PROFILES := Default
 	KERNEL_DEPENDS = $$(wildcard $(DTS_DIR)/$$(DEVICE_DTS).dts)
@@ -109,6 +120,24 @@  define Device/compex_wpq864
 endef
 TARGET_DEVICES += compex_wpq864
 
+define Device/linksys_e8350-v1
+        $(call Device/LegacyImage)
+        DEVICE_VENDOR := Linksys
+        DEVICE_MODEL := E8350
+        DEVICE_VARIANT := v1
+        SOC := qcom-ipq8064
+        FW_VERSION := v1.0.03.003
+        FW_DEVICE_ID := 8350
+        PAGESIZE := 2048
+        BLOCKSIZE := 128k
+        KERNEL_IN_UBI := 1
+        IMAGES = factory.bin sysupgrade.ubi
+        IMAGE/sysupgrade.ubi := append-ubi | check-size 0x04000000 | append-metadata
+        IMAGE/factory.bin := append-ubi | check-size 0x04000000 | linksys-addfwhdr | linksys-bin
+        DEVICE_PACKAGES := ath10k-firmware-qca988x-ct
+endef
+TARGET_DEVICES += linksys_e8350-v1
+
 define Device/linksys_ea7500-v1
 	$(call Device/LegacyImage)
 	DEVICE_VENDOR := Linksys
diff --git a/target/linux/ipq806x/patches-5.4/0069-arm-boot-add-dts-files.patch b/target/linux/ipq806x/patches-5.4/0069-arm-boot-add-dts-files.patch
index 8cdd198c29..f88252d8a6 100644
--- a/target/linux/ipq806x/patches-5.4/0069-arm-boot-add-dts-files.patch
+++ b/target/linux/ipq806x/patches-5.4/0069-arm-boot-add-dts-files.patch
@@ -10,7 +10,7 @@  Signed-off-by: John Crispin <john@phrozen.org>
 
 --- a/arch/arm/boot/dts/Makefile
 +++ b/arch/arm/boot/dts/Makefile
-@@ -843,6 +843,19 @@ dtb-$(CONFIG_ARCH_QCOM) += \
+@@ -843,6 +843,20 @@ dtb-$(CONFIG_ARCH_QCOM) += \
  	qcom-ipq4019-ap.dk07.1-c1.dtb \
  	qcom-ipq4019-ap.dk07.1-c2.dtb \
  	qcom-ipq8064-ap148.dtb \
@@ -18,6 +18,7 @@  Signed-off-by: John Crispin <john@phrozen.org>
 +	qcom-ipq8064-d7800.dtb \
 +	qcom-ipq8064-db149.dtb \
 +	qcom-ipq8064-ap161.dtb \
++	qcom-ipq8064-e8350-v1.dtb \
 +	qcom-ipq8064-ea7500-v1.dtb \
 +	qcom-ipq8064-ea8500.dtb \
 +	qcom-ipq8064-r7500.dtb \
-- 
2.27.0




------------------------------

Message: 3
Date: Wed, 22 Jul 2020 11:32:00 -1000
From: Paul Spooren <mail@aparcar.org>
To: openwrt-devel@lists.openwrt.org
Cc: Paul Spooren <mail@aparcar.org>
Subject: [PATCH] tools: Add PKG_VERSION to flock
Message-ID: <20200722213200.784784-1-mail@aparcar.org>

The stored source code of flock contains the version string of version
2.18, reflect that in the Makefile.

Motivation is the tracking of changes in the buildsystem, which requires
versioning of packages.

Signed-off-by: Paul Spooren <mail@aparcar.org>
---
 tools/flock/Makefile | 1 +
 1 file changed, 1 insertion(+)

diff --git a/tools/flock/Makefile b/tools/flock/Makefile
index 9939d12116..83922a79aa 100644
--- a/tools/flock/Makefile
+++ b/tools/flock/Makefile
@@ -7,6 +7,7 @@ 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME := flock
+PKG_VERSION := 2.18
 
 include $(INCLUDE_DIR)/host-build.mk
 
-- 
2.25.1




------------------------------

Message: 4
Date: Wed, 22 Jul 2020 12:15:23 -1000
From: Paul Spooren <mail@aparcar.org>
To: openwrt-devel@lists.openwrt.org
Cc: Paul Spooren <mail@aparcar.org>
Subject: [PATCH] tools: Add PKG_VERSION to sstrip
Message-ID: <20200722221523.1253708-1-mail@aparcar.org>

Comparing the in tree stored source file of sstrip suggests it's version
2.0[0], reflect that in the Makefile.

Motivation is the tracking of changes in the buildsystem, which requires
versioning of packages.

[0]: https://github.com/BR903/ELFkickers/commit/df4426a0f0ada861064d75c08cbebaac7c16b3ae#diff-d3ba694d91432a068d5d3b36abf8cd0f

Signed-off-by: Paul Spooren <mail@aparcar.org>
---
 tools/sstrip/Makefile | 1 +
 1 file changed, 1 insertion(+)

diff --git a/tools/sstrip/Makefile b/tools/sstrip/Makefile
index 180bd1743e..99be063f4c 100644
--- a/tools/sstrip/Makefile
+++ b/tools/sstrip/Makefile
@@ -7,6 +7,7 @@ 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=sstrip
+PKG_VERSION:=2.0
 
 include $(INCLUDE_DIR)/host-build.mk
 
-- 
2.25.1




------------------------------

Message: 5
Date: Wed, 22 Jul 2020 12:21:03 -1000
From: Paul Spooren <mail@aparcar.org>
To: openwrt-devel@lists.openwrt.org
Cc: Paul Spooren <mail@aparcar.org>
Subject: [PATCH] tools: add PKG_VERSION to patch-image
Message-ID: <20200722222103.1254388-1-mail@aparcar.org>

Based on no modifications for 5 years I'm assuming it's safe to call it
a version 1.0.0, reflect that in the Makefile.

Motivation is the tracking of changes in the buildsystem, which requires
versioning of packages.

Also update copyright.

Signed-off-by: Paul Spooren <mail@aparcar.org>
---
 tools/patch-image/Makefile | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/tools/patch-image/Makefile b/tools/patch-image/Makefile
index 6f2900b96c..7accd59597 100644
--- a/tools/patch-image/Makefile
+++ b/tools/patch-image/Makefile
@@ -1,5 +1,5 @@ 
 # 
-# Copyright (C) 2007-2012 OpenWrt.org
+# Copyright (C) 2007-2020 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,6 +7,7 @@ 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=patch-image
+PKG_VERSION:=1.0.0
 
 include $(INCLUDE_DIR)/host-build.mk
 
-- 
2.25.1




------------------------------

Message: 6
Date: Wed, 22 Jul 2020 12:24:14 -1000
From: Paul Spooren <mail@aparcar.org>
To: openwrt-devel@lists.openwrt.org
Cc: Paul Spooren <mail@aparcar.org>
Subject: [PATCH] tools: add PKG_VERSION to firmware-utils
Message-ID: <20200722222414.1255001-1-mail@aparcar.org>

There is no versioning information in the firmware-utils code nor the
Makefile. Due to the infrequent changes to the file I'm assuming a
version 1.0.0, reflected in the Makefile.

Motivation is the tracking of changes in the buildsystem, which requires
versioning of packages.

Also update copyright.

Signed-off-by: Paul Spooren <mail@aparcar.org>
---
 tools/firmware-utils/Makefile | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/tools/firmware-utils/Makefile b/tools/firmware-utils/Makefile
index 3dd9ac5c2c..4ea3f773b9 100644
--- a/tools/firmware-utils/Makefile
+++ b/tools/firmware-utils/Makefile
@@ -1,5 +1,5 @@ 
 #
-# Copyright (C) 2006-2012 OpenWrt.org
+# Copyright (C) 2006-2020 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,6 +7,7 @@ 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME := firmware-utils
+PKG_VERSION := 1.0.0
 
 include $(INCLUDE_DIR)/host-build.mk
 include $(INCLUDE_DIR)/kernel.mk