diff mbox series

x86 64: Add new device Cordoba Edge Platform

Message ID DU0PR04MB9660FACCB93620F1441E5ABBBDDFA@DU0PR04MB9660.eurprd04.prod.outlook.com
State New
Headers show
Series x86 64: Add new device Cordoba Edge Platform | expand

Commit Message

Xiaojun Liu Oct. 24, 2023, 3:52 a.m. UTC
Add new device Cordoba Edge Platform
Device name:Cordoba Edge Platform
hardware specifications: CPU - Intel Atom C3000
                         WiFi - mt7915e
    
Signed-off-by: Xiaojun Liu mailto:xiaojun.liu@silicom.co.il
---

target/linux/x86/base-files/etc/board.d/02_network | 11 +++++++++++
target/linux/x86/image/64.mk                       | 10 ++++++++++
2 files changed, 21 insertions(+)

Comments

Philip Prindeville Oct. 28, 2023, 3:08 a.m. UTC | #1
LGTM


> On Oct 23, 2023, at 8:52 PM, Xiaojun Liu <xiaojun.liu@silicom.co.il> wrote:
> 
> Add new device Cordoba Edge Platform
> Device name:Cordoba Edge Platform
> hardware specifications: CPU - Intel Atom C3000
>                          WiFi - mt7915e
>     
> Signed-off-by: Xiaojun Liu mailto:xiaojun.liu@silicom.co.il
> ---
> 
> target/linux/x86/base-files/etc/board.d/02_network | 11 +++++++++++
> target/linux/x86/image/64.mk                       | 10 ++++++++++
> 2 files changed, 21 insertions(+)
> 
> 
> diff --git a/target/linux/x86/base-files/etc/board.d/02_network b/target/linux/x86/base-files/etc/board.d/02_network
> index e00e8c04dd..be56153695 100644
> --- a/target/linux/x86/base-files/etc/board.d/02_network
> +++ b/target/linux/x86/base-files/etc/board.d/02_network
> @@ -75,6 +75,17 @@ traverse-technologies-geos)
>         macaddr="$(cat /sys/class/net/eth0/address)" 2>/dev/null
>         [ -n "$macaddr" ] && ucidef_set_interface_macaddr "wan" "$macaddr"
>         ;;
> +silicom-80500-0214-e53)
> +        ucidef_set_network_device_path "wan0" "pci0000:00/0000:00:16.0/0000:03:00.0"
> +        ucidef_set_network_device_path "wan1" "pci0000:00/0000:00:16.0/0000:03:00.1"
> +        ucidef_set_network_device_path "media0" "pci0000:00/0000:00:17.0/0000:02:00.0"
> +        ucidef_set_network_device_path "media1" "pci0000:00/0000:00:17.0/0000:02:00.1"
> +        ucidef_set_network_device_path "eth0" "pci0000:00/0000:00:0c.0/0000:04:00.0"
> +        ucidef_set_network_device_path "eth1" "pci0000:00/0000:00:0e.0/0000:05:00.0"
> +        ucidef_set_network_device_path "eth2" "pci0000:00/0000:00:0f.0/0000:06:00.0"
> +        ucidef_set_network_device_path "eth3" "pci0000:00/0000:00:10.0/0000:07:00.0"
> +        ucidef_set_interfaces_lan_wan "eth0 eth1 eth2 eth3" "wan0"
> +        ;;
> esac
> board_config_flush
> 
> diff --git a/target/linux/x86/image/64.mk b/target/linux/x86/image/64.mk
> index 5ec9978b66..4addddeb98 100644
> --- a/target/linux/x86/image/64.mk
> +++ b/target/linux/x86/image/64.mk
> @@ -8,3 +8,13 @@ define Device/generic
>    GRUB2_VARIANT := generic
> endef
> TARGET_DEVICES += generic
> +
> +define Device/cordoba
> +  DEVICE_VENDOR := Cordoba
> +  DEVICE_MODEL := x86/64
> +  DEVICE_PACKAGES += \
> +        kmod-igc kmod-ixgbe \
> +        kmod-mt7915-firmware
> +  GRUB2_VARIANT := generic
> +endef
> +TARGET_DEVICES += cordoba
> 
> <x86 64 Add new device Cordoba Edge Platform.patch>_______________________________________________
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://lists.openwrt.org/mailman/listinfo/openwrt-devel
Xiaojun Liu Oct. 30, 2023, 4:29 a.m. UTC | #2
Hi Philip,

Thank you! Do you know when it will be merged to Openwrt main thread ?

-----Original Message-----
From: Philip Prindeville <philipp_subx@redfish-solutions.com> 
Sent: Saturday, October 28, 2023 11:09 AM
To: Xiaojun Liu <xiaojun.liu@silicom.co.il>
Cc: openwrt-devel@lists.openwrt.org
Subject: Re: [PATCH] x86 64: Add new device Cordoba Edge Platform

LGTM


> On Oct 23, 2023, at 8:52 PM, Xiaojun Liu <xiaojun.liu@silicom.co.il> wrote:
> 
> Add new device Cordoba Edge Platform
> Device name:Cordoba Edge Platform
> hardware specifications: CPU - Intel Atom C3000
>                          WiFi - mt7915e
>     
> Signed-off-by: Xiaojun Liu mailto:xiaojun.liu@silicom.co.il
> ---
> 
> target/linux/x86/base-files/etc/board.d/02_network | 11 +++++++++++
> target/linux/x86/image/64.mk                       | 10 ++++++++++
> 2 files changed, 21 insertions(+)
> 
> 
> diff --git a/target/linux/x86/base-files/etc/board.d/02_network 
> b/target/linux/x86/base-files/etc/board.d/02_network
> index e00e8c04dd..be56153695 100644
> --- a/target/linux/x86/base-files/etc/board.d/02_network
> +++ b/target/linux/x86/base-files/etc/board.d/02_network
> @@ -75,6 +75,17 @@ traverse-technologies-geos)
>         macaddr="$(cat /sys/class/net/eth0/address)" 2>/dev/null
>         [ -n "$macaddr" ] && ucidef_set_interface_macaddr "wan" "$macaddr"
>         ;;
> +silicom-80500-0214-e53)
> +        ucidef_set_network_device_path "wan0" "pci0000:00/0000:00:16.0/0000:03:00.0"
> +        ucidef_set_network_device_path "wan1" "pci0000:00/0000:00:16.0/0000:03:00.1"
> +        ucidef_set_network_device_path "media0" "pci0000:00/0000:00:17.0/0000:02:00.0"
> +        ucidef_set_network_device_path "media1" "pci0000:00/0000:00:17.0/0000:02:00.1"
> +        ucidef_set_network_device_path "eth0" "pci0000:00/0000:00:0c.0/0000:04:00.0"
> +        ucidef_set_network_device_path "eth1" "pci0000:00/0000:00:0e.0/0000:05:00.0"
> +        ucidef_set_network_device_path "eth2" "pci0000:00/0000:00:0f.0/0000:06:00.0"
> +        ucidef_set_network_device_path "eth3" "pci0000:00/0000:00:10.0/0000:07:00.0"
> +        ucidef_set_interfaces_lan_wan "eth0 eth1 eth2 eth3" "wan0"
> +        ;;
> esac
> board_config_flush
> 
> diff --git a/target/linux/x86/image/64.mk 
> b/target/linux/x86/image/64.mk index 5ec9978b66..4addddeb98 100644
> --- a/target/linux/x86/image/64.mk
> +++ b/target/linux/x86/image/64.mk
> @@ -8,3 +8,13 @@ define Device/generic
>    GRUB2_VARIANT := generic
> endef
> TARGET_DEVICES += generic
> +
> +define Device/cordoba
> +  DEVICE_VENDOR := Cordoba
> +  DEVICE_MODEL := x86/64
> +  DEVICE_PACKAGES += \
> +        kmod-igc kmod-ixgbe \
> +        kmod-mt7915-firmware
> +  GRUB2_VARIANT := generic
> +endef
> +TARGET_DEVICES += cordoba
> 
> <x86 64 Add new device Cordoba Edge 
> Platform.patch>_______________________________________________
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Flist
> s.openwrt.org%2Fmailman%2Flistinfo%2Fopenwrt-devel&data=05%7C01%7Cxiao
> jun.liu%40silicom.co.il%7C72c892dafba644e13de108dbd76352b5%7Cc9e326d8c
> e4749308612cc99d3c87ad1%7C0%7C0%7C638340593816809713%7CUnknown%7CTWFpb
> GZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0
> %3D%7C3000%7C%7C%7C&sdata=iJGXzXkBnJaAuGcu3OrZSPxVeE1WvC2h7w4%2F3t2bLj
> Q%3D&reserved=0
Paul Spooren Oct. 30, 2023, 5:17 p.m. UTC | #3
Hi,

We kind of don’t add image just to contain extra drivers. Extra UCI defaults for eth ordering are fine but please don’t add an extra image if it just contains 1-2 extra packages, installable via the ImageBuilder or OPKG.

> 
>> On Oct 23, 2023, at 8:52 PM, Xiaojun Liu <xiaojun.liu@silicom.co.il> wrote:
>> 
>> Add new device Cordoba Edge Platform
>> Device name:Cordoba Edge Platform
>> hardware specifications: CPU - Intel Atom C3000
>>                         WiFi - mt7915e
>> 
>> Signed-off-by: Xiaojun Liu mailto:xiaojun.liu@silicom.co.il
>> ---
>> 
>> target/linux/x86/base-files/etc/board.d/02_network | 11 +++++++++++
>> target/linux/x86/image/64.mk                       | 10 ++++++++++
>> 2 files changed, 21 insertions(+)
>> 
>> 
>> diff --git a/target/linux/x86/base-files/etc/board.d/02_network 
>> b/target/linux/x86/base-files/etc/board.d/02_network
>> index e00e8c04dd..be56153695 100644
>> --- a/target/linux/x86/base-files/etc/board.d/02_network
>> +++ b/target/linux/x86/base-files/etc/board.d/02_network
>> @@ -75,6 +75,17 @@ traverse-technologies-geos)
>>        macaddr="$(cat /sys/class/net/eth0/address)" 2>/dev/null
>>        [ -n "$macaddr" ] && ucidef_set_interface_macaddr "wan" "$macaddr"
>>        ;;
>> +silicom-80500-0214-e53)
>> +        ucidef_set_network_device_path "wan0" "pci0000:00/0000:00:16.0/0000:03:00.0"
>> +        ucidef_set_network_device_path "wan1" "pci0000:00/0000:00:16.0/0000:03:00.1"
>> +        ucidef_set_network_device_path "media0" "pci0000:00/0000:00:17.0/0000:02:00.0"
>> +        ucidef_set_network_device_path "media1" "pci0000:00/0000:00:17.0/0000:02:00.1"
>> +        ucidef_set_network_device_path "eth0" "pci0000:00/0000:00:0c.0/0000:04:00.0"
>> +        ucidef_set_network_device_path "eth1" "pci0000:00/0000:00:0e.0/0000:05:00.0"
>> +        ucidef_set_network_device_path "eth2" "pci0000:00/0000:00:0f.0/0000:06:00.0"
>> +        ucidef_set_network_device_path "eth3" "pci0000:00/0000:00:10.0/0000:07:00.0"
>> +        ucidef_set_interfaces_lan_wan "eth0 eth1 eth2 eth3" "wan0"
>> +        ;;
>> esac
>> board_config_flush
>> 
>> diff --git a/target/linux/x86/image/64.mk 
>> b/target/linux/x86/image/64.mk index 5ec9978b66..4addddeb98 100644
>> --- a/target/linux/x86/image/64.mk
>> +++ b/target/linux/x86/image/64.mk
>> @@ -8,3 +8,13 @@ define Device/generic
>>   GRUB2_VARIANT := generic
>> endef
>> TARGET_DEVICES += generic
>> +
>> +define Device/cordoba
>> +  DEVICE_VENDOR := Cordoba
>> +  DEVICE_MODEL := x86/64
>> +  DEVICE_PACKAGES += \
>> +        kmod-igc kmod-ixgbe \
>> +        kmod-mt7915-firmware
>> +  GRUB2_VARIANT := generic
>> +endef
>> +TARGET_DEVICES += cordoba

Please remove those lines in 64.mk.

Thanks for you work and interest in OpenWrt support for your device.

Best,
Paul
Xiaojun Liu Oct. 31, 2023, 7:52 a.m. UTC | #4
Hi,

Thank you for your guide!
I will resubmit it. 

-----Original Message-----
From: Paul Spooren <mail@aparcar.org> 
Sent: Tuesday, October 31, 2023 1:18 AM
To: Xiaojun Liu <xiaojun.liu@silicom.co.il>
Cc: Philip Prindeville <philipp_subx@redfish-solutions.com>; openwrt-devel <openwrt-devel@lists.openwrt.org>
Subject: Re: [PATCH] x86 64: Add new device Cordoba Edge Platform

Hi,

We kind of don’t add image just to contain extra drivers. Extra UCI defaults for eth ordering are fine but please don’t add an extra image if it just contains 1-2 extra packages, installable via the ImageBuilder or OPKG.

> 
>> On Oct 23, 2023, at 8:52 PM, Xiaojun Liu <xiaojun.liu@silicom.co.il> wrote:
>> 
>> Add new device Cordoba Edge Platform
>> Device name:Cordoba Edge Platform
>> hardware specifications: CPU - Intel Atom C3000
>>                         WiFi - mt7915e
>> 
>> Signed-off-by: Xiaojun Liu mailto:xiaojun.liu@silicom.co.il
>> ---
>> 
>> target/linux/x86/base-files/etc/board.d/02_network | 11 +++++++++++
>> target/linux/x86/image/64.mk                       | 10 ++++++++++
>> 2 files changed, 21 insertions(+)
>> 
>> 
>> diff --git a/target/linux/x86/base-files/etc/board.d/02_network
>> b/target/linux/x86/base-files/etc/board.d/02_network
>> index e00e8c04dd..be56153695 100644
>> --- a/target/linux/x86/base-files/etc/board.d/02_network
>> +++ b/target/linux/x86/base-files/etc/board.d/02_network
>> @@ -75,6 +75,17 @@ traverse-technologies-geos)
>>        macaddr="$(cat /sys/class/net/eth0/address)" 2>/dev/null
>>        [ -n "$macaddr" ] && ucidef_set_interface_macaddr "wan" "$macaddr"
>>        ;;
>> +silicom-80500-0214-e53)
>> +        ucidef_set_network_device_path "wan0" "pci0000:00/0000:00:16.0/0000:03:00.0"
>> +        ucidef_set_network_device_path "wan1" "pci0000:00/0000:00:16.0/0000:03:00.1"
>> +        ucidef_set_network_device_path "media0" "pci0000:00/0000:00:17.0/0000:02:00.0"
>> +        ucidef_set_network_device_path "media1" "pci0000:00/0000:00:17.0/0000:02:00.1"
>> +        ucidef_set_network_device_path "eth0" "pci0000:00/0000:00:0c.0/0000:04:00.0"
>> +        ucidef_set_network_device_path "eth1" "pci0000:00/0000:00:0e.0/0000:05:00.0"
>> +        ucidef_set_network_device_path "eth2" "pci0000:00/0000:00:0f.0/0000:06:00.0"
>> +        ucidef_set_network_device_path "eth3" "pci0000:00/0000:00:10.0/0000:07:00.0"
>> +        ucidef_set_interfaces_lan_wan "eth0 eth1 eth2 eth3" "wan0"
>> +        ;;
>> esac
>> board_config_flush
>> 
>> diff --git a/target/linux/x86/image/64.mk 
>> b/target/linux/x86/image/64.mk index 5ec9978b66..4addddeb98 100644
>> --- a/target/linux/x86/image/64.mk
>> +++ b/target/linux/x86/image/64.mk
>> @@ -8,3 +8,13 @@ define Device/generic
>>   GRUB2_VARIANT := generic
>> endef
>> TARGET_DEVICES += generic
>> +
>> +define Device/cordoba
>> +  DEVICE_VENDOR := Cordoba
>> +  DEVICE_MODEL := x86/64
>> +  DEVICE_PACKAGES += \
>> +        kmod-igc kmod-ixgbe \
>> +        kmod-mt7915-firmware
>> +  GRUB2_VARIANT := generic
>> +endef
>> +TARGET_DEVICES += cordoba

Please remove those lines in 64.mk.

Thanks for you work and interest in OpenWrt support for your device.

Best,
Paul
Philip Prindeville Nov. 4, 2023, 6:48 p.m. UTC | #5
> On Oct 30, 2023, at 11:17 AM, Paul Spooren <mail@aparcar.org> wrote:
> 
> Hi,
> 
> We kind of don’t add image just to contain extra drivers. Extra UCI defaults for eth ordering are fine but please don’t add an extra image if it just contains 1-2 extra packages, installable via the ImageBuilder or OPKG.
> 
>> 
>>> On Oct 23, 2023, at 8:52 PM, Xiaojun Liu <xiaojun.liu@silicom.co.il> wrote:
>>> 
>>> Add new device Cordoba Edge Platform
>>> Device name:Cordoba Edge Platform
>>> hardware specifications: CPU - Intel Atom C3000
>>>                        WiFi - mt7915e
>>> 
>>> Signed-off-by: Xiaojun Liu mailto:xiaojun.liu@silicom.co.il
>>> ---
>>> 
>>> target/linux/x86/base-files/etc/board.d/02_network | 11 +++++++++++
>>> target/linux/x86/image/64.mk                       | 10 ++++++++++
>>> 2 files changed, 21 insertions(+)
>>> 
>>> 
>>> diff --git a/target/linux/x86/base-files/etc/board.d/02_network 
>>> b/target/linux/x86/base-files/etc/board.d/02_network
>>> index e00e8c04dd..be56153695 100644
>>> --- a/target/linux/x86/base-files/etc/board.d/02_network
>>> +++ b/target/linux/x86/base-files/etc/board.d/02_network
>>> @@ -75,6 +75,17 @@ traverse-technologies-geos)
>>>       macaddr="$(cat /sys/class/net/eth0/address)" 2>/dev/null
>>>       [ -n "$macaddr" ] && ucidef_set_interface_macaddr "wan" "$macaddr"
>>>       ;;
>>> +silicom-80500-0214-e53)
>>> +        ucidef_set_network_device_path "wan0" "pci0000:00/0000:00:16.0/0000:03:00.0"
>>> +        ucidef_set_network_device_path "wan1" "pci0000:00/0000:00:16.0/0000:03:00.1"
>>> +        ucidef_set_network_device_path "media0" "pci0000:00/0000:00:17.0/0000:02:00.0"
>>> +        ucidef_set_network_device_path "media1" "pci0000:00/0000:00:17.0/0000:02:00.1"
>>> +        ucidef_set_network_device_path "eth0" "pci0000:00/0000:00:0c.0/0000:04:00.0"
>>> +        ucidef_set_network_device_path "eth1" "pci0000:00/0000:00:0e.0/0000:05:00.0"
>>> +        ucidef_set_network_device_path "eth2" "pci0000:00/0000:00:0f.0/0000:06:00.0"
>>> +        ucidef_set_network_device_path "eth3" "pci0000:00/0000:00:10.0/0000:07:00.0"
>>> +        ucidef_set_interfaces_lan_wan "eth0 eth1 eth2 eth3" "wan0"
>>> +        ;;
>>> esac
>>> board_config_flush
>>> 
>>> diff --git a/target/linux/x86/image/64.mk 
>>> b/target/linux/x86/image/64.mk index 5ec9978b66..4addddeb98 100644
>>> --- a/target/linux/x86/image/64.mk
>>> +++ b/target/linux/x86/image/64.mk
>>> @@ -8,3 +8,13 @@ define Device/generic
>>>  GRUB2_VARIANT := generic
>>> endef
>>> TARGET_DEVICES += generic
>>> +
>>> +define Device/cordoba
>>> +  DEVICE_VENDOR := Cordoba
>>> +  DEVICE_MODEL := x86/64
>>> +  DEVICE_PACKAGES += \
>>> +        kmod-igc kmod-ixgbe \
>>> +        kmod-mt7915-firmware
>>> +  GRUB2_VARIANT := generic
>>> +endef
>>> +TARGET_DEVICES += cordoba
> 
> Please remove those lines in 64.mk.
> 
> Thanks for you work and interest in OpenWrt support for your device.
> 
> Best,
> Paul


I’m not sure I understand why.  Would you want someone to build the image and leave out the necessary drivers?  They’re more than just “extra packages”, they’re *essential* packages.

We have hundreds of profiles for other architectures, even different profiles for different versions of the same base design (like Archer C7).

Why are we so miserly when it comes to x86_64?

-Philip
Philip Prindeville Nov. 4, 2023, 6:49 p.m. UTC | #6
That’s a question for a core maintainer.  I’m just a lowly package maintainer.


> On Oct 29, 2023, at 10:29 PM, Xiaojun Liu <xiaojun.liu@silicom.co.il> wrote:
> 
> Hi Philip,
> 
> Thank you! Do you know when it will be merged to Openwrt main thread ?
> 
> -----Original Message-----
> From: Philip Prindeville <philipp_subx@redfish-solutions.com> 
> Sent: Saturday, October 28, 2023 11:09 AM
> To: Xiaojun Liu <xiaojun.liu@silicom.co.il>
> Cc: openwrt-devel@lists.openwrt.org
> Subject: Re: [PATCH] x86 64: Add new device Cordoba Edge Platform
> 
> LGTM
> 
> 
>> On Oct 23, 2023, at 8:52 PM, Xiaojun Liu <xiaojun.liu@silicom.co.il> wrote:
>> 
>> Add new device Cordoba Edge Platform
>> Device name:Cordoba Edge Platform
>> hardware specifications: CPU - Intel Atom C3000
>>                         WiFi - mt7915e
>> 
>> Signed-off-by: Xiaojun Liu mailto:xiaojun.liu@silicom.co.il
>> ---
>> 
>> target/linux/x86/base-files/etc/board.d/02_network | 11 +++++++++++
>> target/linux/x86/image/64.mk                       | 10 ++++++++++
>> 2 files changed, 21 insertions(+)
>> 
>> 
>> diff --git a/target/linux/x86/base-files/etc/board.d/02_network 
>> b/target/linux/x86/base-files/etc/board.d/02_network
>> index e00e8c04dd..be56153695 100644
>> --- a/target/linux/x86/base-files/etc/board.d/02_network
>> +++ b/target/linux/x86/base-files/etc/board.d/02_network
>> @@ -75,6 +75,17 @@ traverse-technologies-geos)
>>        macaddr="$(cat /sys/class/net/eth0/address)" 2>/dev/null
>>        [ -n "$macaddr" ] && ucidef_set_interface_macaddr "wan" "$macaddr"
>>        ;;
>> +silicom-80500-0214-e53)
>> +        ucidef_set_network_device_path "wan0" "pci0000:00/0000:00:16.0/0000:03:00.0"
>> +        ucidef_set_network_device_path "wan1" "pci0000:00/0000:00:16.0/0000:03:00.1"
>> +        ucidef_set_network_device_path "media0" "pci0000:00/0000:00:17.0/0000:02:00.0"
>> +        ucidef_set_network_device_path "media1" "pci0000:00/0000:00:17.0/0000:02:00.1"
>> +        ucidef_set_network_device_path "eth0" "pci0000:00/0000:00:0c.0/0000:04:00.0"
>> +        ucidef_set_network_device_path "eth1" "pci0000:00/0000:00:0e.0/0000:05:00.0"
>> +        ucidef_set_network_device_path "eth2" "pci0000:00/0000:00:0f.0/0000:06:00.0"
>> +        ucidef_set_network_device_path "eth3" "pci0000:00/0000:00:10.0/0000:07:00.0"
>> +        ucidef_set_interfaces_lan_wan "eth0 eth1 eth2 eth3" "wan0"
>> +        ;;
>> esac
>> board_config_flush
>> 
>> diff --git a/target/linux/x86/image/64.mk 
>> b/target/linux/x86/image/64.mk index 5ec9978b66..4addddeb98 100644
>> --- a/target/linux/x86/image/64.mk
>> +++ b/target/linux/x86/image/64.mk
>> @@ -8,3 +8,13 @@ define Device/generic
>>   GRUB2_VARIANT := generic
>> endef
>> TARGET_DEVICES += generic
>> +
>> +define Device/cordoba
>> +  DEVICE_VENDOR := Cordoba
>> +  DEVICE_MODEL := x86/64
>> +  DEVICE_PACKAGES += \
>> +        kmod-igc kmod-ixgbe \
>> +        kmod-mt7915-firmware
>> +  GRUB2_VARIANT := generic
>> +endef
>> +TARGET_DEVICES += cordoba
>> 
>> <x86 64 Add new device Cordoba Edge 
>> Platform.patch>_______________________________________________
>> openwrt-devel mailing list
>> openwrt-devel@lists.openwrt.org
>> https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Flist
>> s.openwrt.org%2Fmailman%2Flistinfo%2Fopenwrt-devel&data=05%7C01%7Cxiao
>> jun.liu%40silicom.co.il%7C72c892dafba644e13de108dbd76352b5%7Cc9e326d8c
>> e4749308612cc99d3c87ad1%7C0%7C0%7C638340593816809713%7CUnknown%7CTWFpb
>> GZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0
>> %3D%7C3000%7C%7C%7C&sdata=iJGXzXkBnJaAuGcu3OrZSPxVeE1WvC2h7w4%2F3t2bLj
>> Q%3D&reserved=0
> 
> 
> _______________________________________________
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://lists.openwrt.org/mailman/listinfo/openwrt-devel
diff mbox series

Patch

diff --git a/target/linux/x86/base-files/etc/board.d/02_network b/target/linux/x86/base-files/etc/board.d/02_network
index e00e8c04dd..be56153695 100644
--- a/target/linux/x86/base-files/etc/board.d/02_network
+++ b/target/linux/x86/base-files/etc/board.d/02_network
@@ -75,6 +75,17 @@  traverse-technologies-geos)
        macaddr="$(cat /sys/class/net/eth0/address)" 2>/dev/null
        [ -n "$macaddr" ] && ucidef_set_interface_macaddr "wan" "$macaddr"
        ;;
+silicom-80500-0214-e53)
+        ucidef_set_network_device_path "wan0" "pci0000:00/0000:00:16.0/0000:03:00.0"
+        ucidef_set_network_device_path "wan1" "pci0000:00/0000:00:16.0/0000:03:00.1"
+        ucidef_set_network_device_path "media0" "pci0000:00/0000:00:17.0/0000:02:00.0"
+        ucidef_set_network_device_path "media1" "pci0000:00/0000:00:17.0/0000:02:00.1"
+        ucidef_set_network_device_path "eth0" "pci0000:00/0000:00:0c.0/0000:04:00.0"
+        ucidef_set_network_device_path "eth1" "pci0000:00/0000:00:0e.0/0000:05:00.0"
+        ucidef_set_network_device_path "eth2" "pci0000:00/0000:00:0f.0/0000:06:00.0"
+        ucidef_set_network_device_path "eth3" "pci0000:00/0000:00:10.0/0000:07:00.0"
+        ucidef_set_interfaces_lan_wan "eth0 eth1 eth2 eth3" "wan0"
+        ;;
esac
board_config_flush

diff --git a/target/linux/x86/image/64.mk b/target/linux/x86/image/64.mk
index 5ec9978b66..4addddeb98 100644
--- a/target/linux/x86/image/64.mk
+++ b/target/linux/x86/image/64.mk
@@ -8,3 +8,13 @@  define Device/generic
   GRUB2_VARIANT := generic
endef
TARGET_DEVICES += generic
+
+define Device/cordoba
+  DEVICE_VENDOR := Cordoba
+  DEVICE_MODEL := x86/64
+  DEVICE_PACKAGES += \
+        kmod-igc kmod-ixgbe \
+        kmod-mt7915-firmware
+  GRUB2_VARIANT := generic
+endef
+TARGET_DEVICES += cordoba