diff mbox

[OpenWrt-Devel,1/2] Add package django-sslserver

Message ID CAJYP-=AWAwiJVJHFCz0jakN7FhFc2Lp49Z3GY+w6t_JVfy2nBg@mail.gmail.com
State Not Applicable
Headers show

Commit Message

philby john Oct. 10, 2015, 2:06 p.m. UTC
From 023d680abc55699e439a643111c733088d07a55b Mon Sep 17 00:00:00 2001
From: Philby John <philby@celestialsys.com>
Date: Sat, 10 Oct 2015 18:53:46 +0530
Subject: [PATCH 1/2] Add package django-sslserver

Add django-sslserver ver 0.15 which is an SSL-enabled
development server for Django.

Signed-off-by: Philby John <philby@celestialsys.com>
Tested-by: Ashok <ashok@celestialsys.com>
---
 lang/django-sslserver/Makefile | 50 ++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 50 insertions(+)
 create mode 100644 lang/django-sslserver/Makefile

+$(eval $(call BuildPackage,django-sslserver))

Comments

philby john Oct. 10, 2015, 2:36 p.m. UTC | #1
> +
> +define Package/django-sslserver/description
> + Django SSL Server ships "batteries included" with a self-signed
> server certificate.


Sorry! Patch mangled. Resending.

~Philby


> +endef
> +
> +define Build/Compile
> +    $(call Build/Compile/PyMod,., \
> +        install --prefix="/usr" --root="$(PKG_INSTALL_DIR)" \
> +    )
> +endef
> +
> +define Package/django-sslserver/install
> +    $(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR)
> +    $(CP) \
> +        $(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/* \
> +        $(1)$(PYTHON_PKG_DIR)/
> +endef
> +
> +$(eval $(call BuildPackage,django-sslserver))
> --
> 1.8.1.4
Steven Barth Oct. 11, 2015, 7:52 a.m. UTC | #2
Please read our package submission guidelines here
https://github.com/openwrt/packages/blob/master/CONTRIBUTING.md
and once your submission complies, create a pull
request at: https://github.com/openwrt/packages


Cheers,

Steven
diff mbox

Patch

diff --git a/lang/django-sslserver/Makefile b/lang/django-sslserver/Makefile
new file mode 100644
index 0000000..7aaf2a0
--- /dev/null
+++ b/lang/django-sslserver/Makefile
@@ -0,0 +1,50 @@ 
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=django-sslserver
+PKG_VERSION:=0.15
+PKG_RELEASE:=1
+
+PKG_SOURCE:=django-sslserver-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://pypi.python.org/packages/source/d/django-sslserver/
+PKG_MD5SUM:=dd83049f0c50f94a1cf3acb6bc7dd6bd
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/django-sslserver-$(PKG_VERSION)
+PKG_BUILD_DEPENDS:=python python-setuptools
+
+include $(INCLUDE_DIR)/package.mk
+$(call include_mk, python-package.mk)
+
+define Package/django-sslserver
+  SECTION:=language-python
+  CATEGORY:=Languages
+  SUBMENU:=Python
+  TITLE:=An SSL-enabled development server for Django
+  URL:=https://www.djangoproject.com/
+  DEPENDS:=+python +python-setuptools
+endef
+
+define Package/django-sslserver/description
+ Django SSL Server ships "batteries included" with a self-signed
server certificate.
+endef
+
+define Build/Compile
+    $(call Build/Compile/PyMod,., \
+        install --prefix="/usr" --root="$(PKG_INSTALL_DIR)" \
+    )
+endef
+
+define Package/django-sslserver/install
+    $(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR)
+    $(CP) \
+        $(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/* \
+        $(1)$(PYTHON_PKG_DIR)/
+endef
+