diff mbox

[OpenWrt-Devel,packages] add mt-st package to write to tape devices

Message ID CAGRVrQj=PgEEmtaf72v0oy0-_SQQ_mJ70u2F-Zbj=1uMyxycYA@mail.gmail.com
State Rejected
Headers show

Commit Message

Giuseppe Magnotta Nov. 10, 2015, 11:44 a.m. UTC
Add mt-st package in order to write to tape devices

Signed-off-by: Giuseppe Magnotta <giuseppe.magnotta@gmail.com>

+$(eval $(call BuildPackage,mt-st))

Comments

John Crispin Nov. 21, 2015, 6:20 p.m. UTC | #1
Hi

this really belongs into the feed. please submit a PR via github.

	John

On 10/11/2015 12:44, Giuseppe Magnotta wrote:
> Add mt-st package in order to write to tape devices
> 
> Signed-off-by: Giuseppe Magnotta <giuseppe.magnotta@gmail.com
> <mailto:giuseppe.magnotta@gmail.com>>
> 
> diff --git a/package/utils/mt-st/Makefile b/package/utils/mt-st/Makefile
> new file mode 100644
> index 0000000..ad93f23
> --- /dev/null
> +++ b/package/utils/mt-st/Makefile
> @@ -0,0 +1,49 @@
> +#
> +# Copyright (C) 2015 OpenWrt.org
> +#
> +# This is free software, licensed under the GNU General Public License v2.
> +# See /LICENSE for more information.
> +#
> +
> +include $(TOPDIR)/rules.mk <http://rules.mk>
> +
> +PKG_NAME:=mt-st
> +PKG_VERSION:=1.1
> +PKG_RELEASE:=1
> +
> +PKG_SOURCE_SUBDIR:=$(PKG_NAME)
> +PKG_SOURCE_VERSION:=$(PKG_VERSION)
> +PKG_SOURCE:=$(PKG_NAME)-$(PKG_SOURCE_VERSION).tar.gz
> +PKG_SOURCE_URL:=http://ftp.ibiblio.org/pub/Linux/system/backup/
> +PKG_MD5SUM:=fdd5f5ec673c9f630a102ceff7612774
> +
> +include $(INCLUDE_DIR)/package.mk <http://package.mk>
> +
> +define Package/mt-st
> +  SECTION:=utils
> +  CATEGORY:=Utilities
> +  TITLE:=Magnetic tape control tools for Linux SCSI tapes
> +  URL:=http://ftp.ibiblio.org/pub/Linux/system/backup/
> +  MAINTAINER:=Giuseppe Magnotta <giuseppe.magnotta@gmail.com
> <mailto:giuseppe.magnotta@gmail.com>>
> +endef
> +
> +define Package/mt-st/description
> +    Includes a mt-like program supporting additional commands using ioctls
> +    specific to  the Linux SCSI tape driver (up to kernel 2.6.26), and
> the program
> +    stinit to define the SCSI tape devices in system startup scripts.
> +endef
> +
> +define Build/Compile
> +    $(MAKE) -C $(PKG_BUILD_DIR) \
> +        LDFLAGS="$(TARGET_LDFLAGS)" \
> +        CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
> +        CC="$(TARGET_CC)"
> +endef
> +
> +define Package/mt-st/install
> +    $(INSTALL_DIR) $(1)/usr/bin
> +    $(INSTALL_BIN) $(PKG_BUILD_DIR)/mt $(1)/usr/bin/
> +    $(INSTALL_BIN) $(PKG_BUILD_DIR)/stinit $(1)/usr/bin/
> +endef
> +
> +$(eval $(call BuildPackage,mt-st))
> 
> 
> _______________________________________________
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel
>
diff mbox

Patch

diff --git a/package/utils/mt-st/Makefile b/package/utils/mt-st/Makefile
new file mode 100644
index 0000000..ad93f23
--- /dev/null
+++ b/package/utils/mt-st/Makefile
@@ -0,0 +1,49 @@ 
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=mt-st
+PKG_VERSION:=1.1
+PKG_RELEASE:=1
+
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)
+PKG_SOURCE_VERSION:=$(PKG_VERSION)
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_SOURCE_VERSION).tar.gz
+PKG_SOURCE_URL:=http://ftp.ibiblio.org/pub/Linux/system/backup/
+PKG_MD5SUM:=fdd5f5ec673c9f630a102ceff7612774
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/mt-st
+  SECTION:=utils
+  CATEGORY:=Utilities
+  TITLE:=Magnetic tape control tools for Linux SCSI tapes
+  URL:=http://ftp.ibiblio.org/pub/Linux/system/backup/
+  MAINTAINER:=Giuseppe Magnotta <giuseppe.magnotta@gmail.com>
+endef
+
+define Package/mt-st/description
+    Includes a mt-like program supporting additional commands using ioctls
+    specific to  the Linux SCSI tape driver (up to kernel 2.6.26), and the
program
+    stinit to define the SCSI tape devices in system startup scripts.
+endef
+
+define Build/Compile
+    $(MAKE) -C $(PKG_BUILD_DIR) \
+        LDFLAGS="$(TARGET_LDFLAGS)" \
+        CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
+        CC="$(TARGET_CC)"
+endef
+
+define Package/mt-st/install
+    $(INSTALL_DIR) $(1)/usr/bin
+    $(INSTALL_BIN) $(PKG_BUILD_DIR)/mt $(1)/usr/bin/
+    $(INSTALL_BIN) $(PKG_BUILD_DIR)/stinit $(1)/usr/bin/
+endef
+