diff mbox

[OpenWrt-Devel] add scsi tape to kernel modules

Message ID CAGRVrQh57vZUjxUoDL0mDBYjki-Oq8wHPvy4FJsJYEkTBpOm1A@mail.gmail.com
State Superseded
Delegated to: Hauke Mehrtens
Headers show

Commit Message

Giuseppe Magnotta Nov. 10, 2015, 10:51 a.m. UTC
Hi,

I would like to submit a patch to add the scsi tape to the kernel modules.

For me it's useful because my openwrt device will manage also backup.

This is against trunk (main devel tree) repository

Comments

Rafał Miłecki Nov. 10, 2015, 10:55 a.m. UTC | #1
On 10 November 2015 at 11:51, Giuseppe Magnotta
<giuseppe.magnotta@gmail.com> wrote:
> Hi,
>
> I would like to submit a patch to add the scsi tape to the kernel modules.
>
> For me it's useful because my openwrt device will manage also backup.
>
> This is against trunk (main devel tree) repository

Replace this description with a proper commit message, sign off your
patch & resend.
diff mbox

Patch

diff --git a/package/kernel/linux/modules/other.mk
b/package/kernel/linux/modules/other.mk
index 55fb6f1..e26390d 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -969,3 +969,17 @@  define KernelPackage/echo/description
 endef

 $(eval $(call KernelPackage,echo))
+
+
+define KernelPackage/scsi-tape
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=Kernel support for scsi tape drives
+  DEPENDS:=+kmod-scsi-core
+  KCONFIG:= \
+    CONFIG_CHR_DEV_ST
+  FILES:= \
+    $(LINUX_DIR)/drivers/scsi/st.ko
+  AUTOLOAD:=$(call AutoLoad,45,st)
+endef
+
+$(eval $(call KernelPackage,scsi-tape))