diff mbox

[OpenWrt-Devel] luci-proto-wwan minimal support

Message ID CAC-0c8d=2Q1_OzhpXhehr48FE0fwwWrhsUGhL0Jvqce5odNtVw@mail.gmail.com
State Not Applicable
Headers show

Commit Message

Aleksandr Kolesnik April 22, 2015, 12:59 p.m. UTC
Signed-off-by: Aleksandr Kolesnik <neryba@gmail.com>

Comments

Cezary Jackiewicz May 21, 2015, 5:41 a.m. UTC | #1
Dnia 2015-04-22, o godz. 15:59:37
Aleksandr Kolesnik <neryba@gmail.com> napisał(a):

> Signed-off-by: Aleksandr Kolesnik <neryba@gmail.com>

Hi,
there is chance to to include this into 15.05?
Adam Kuklycz May 21, 2015, 9:35 a.m. UTC | #2
Or at least let us know how to apply the patch manually and I will add 
it into my unofficial builds that I make with the ar71xx platform.

I'd love to see proper or even some sort of wwan support in the luci 
side of things.



On 21/05/15 15:41, Cezary Jackiewicz wrote:
> Dnia 2015-04-22, o godz. 15:59:37
> Aleksandr Kolesnik <neryba@gmail.com> napisał(a):
>
>> Signed-off-by: Aleksandr Kolesnik <neryba@gmail.com>
> Hi,
> there is chance to to include this into 15.05?
>
Aleksandr Kolesnik May 22, 2015, 8:42 p.m. UTC | #3
I don't have enough time to test it on CC, but here is link
http://goo.gl/zVP3yZ  to try it. Just unzip and copy that files to your
router, I little bit modified them to use on Luci-15.05, I think it should
work.

To Cezary: all depends on Jow.

2015-05-21 12:35 GMT+03:00 Adam Kuklycz <adamk@mcservices.com.au>:

> Or at least let us know how to apply the patch manually and I will add it
> into my unofficial builds that I make with the ar71xx platform.
>
> I'd love to see proper or even some sort of wwan support in the luci side
> of things.
>
>
>
> On 21/05/15 15:41, Cezary Jackiewicz wrote:
>
>> Dnia 2015-04-22, o godz. 15:59:37
>> Aleksandr Kolesnik <neryba@gmail.com> napisał(a):
>>
>>  Signed-off-by: Aleksandr Kolesnik <neryba@gmail.com>
>>>
>> Hi,
>> there is chance to to include this into 15.05?
>>
>>  _______________________________________________
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel
>
diff mbox

Patch

--- a/contrib/package/luci/Makefile
+++ b/contrib/package/luci/Makefile
@@ -194,6 +194,7 @@  $(eval $(call protocol,ipv6,Support for
 $(eval $(call protocol,3g,Support for 3G,+PACKAGE_luci-proto-3g:comgt))
 $(eval $(call protocol,hso,Support for HSO,+PACKAGE_luci-proto-hso:comgt
+PACKAGE_luci-proto-hso:kmod-usb-net
+PACKAGE_luci-proto-hso:kmod-usb-net-hso))
 $(eval $(call protocol,relay,Support for relayd pseudo
bridges,+PACKAGE_luci-proto-relay:relayd))
+$(eval $(call protocol,wwan,Support for 3G/4g
wwan,+PACKAGE_luci-proto-wwan:wwan))


 ### Modules ###
--- a/modules/base/luasrc/model/network.lua
+++ b/modules/base/luasrc/model/network.lua
@@ -756,7 +756,11 @@  function protocol.ifname(self)
 end

 function protocol.proto(self)
- return "none"
+ local p = self:_ubus("proto")
+ if not p then
+ p = "none"
+ end
+ return p
 end

 function protocol.get_i18n(self)
@@ -934,7 +938,16 @@  function protocol.del_interface(self, if
 end

 function protocol.get_interface(self)
- if self:is_virtual() then
+ if self:is_virtual() and self:proto() == "wwan" then
+ local ldev = self:_ubus("l3_device")
+ if ldev then
+ _tunnel[ldev] = true
+ return interface(ldev, self)
+ else
+ _tunnel[self:proto() .. "-" .. self.sid] = true
+ return interface(self:proto() .. "-" .. self.sid, self)
+ end
+ elseif self:is_virtual() then
  _tunnel[self:proto() .. "-" .. self.sid] = true
  return interface(self:proto() .. "-" .. self.sid, self)
  elseif self:is_bridge() then
--- /dev/null
+++ b/protocols/wwan/Makefile
@@ -0,0 +1,2 @@ 
+include ../../build/config.mk
+include ../../build/module.mk
--- /dev/null
+++ b/protocols/wwan/luasrc/model/cbi/admin_network/proto_wwan.lua
@@ -0,0 +1,130 @@ 
+--[[
+LuCI - Lua Configuration Interface
+
+Copyright 2015 Aleksandr Kolesnik <neryba@gmail.com>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+]]--
+
+local map, section, net = ...
+
+local apn, service, pincode, username, password
+local ipv6, maxwait, defaultroute, metric, peerdns, dns,
+      keepalive_failure, keepalive_interval, demand
+
+apn = section:taboption("general", Value, "apn", translate("APN"))
+
+
+pincode = section:taboption("general", Value, "pincode", translate("PIN"))
+
+
+username = section:taboption("general", Value, "username",
translate("PAP/CHAP username"))
+
+
+password = section:taboption("general", Value, "password",
translate("PAP/CHAP password"))
+password.password = true
+
+
+if luci.model.network:has_ipv6() then
+
+ ipv6 = section:taboption("advanced", Flag, "ipv6",
+ translate("Enable IPv6 negotiation on the PPP link"))
+
+ ipv6.default = ipv6.disabled
+
+end
+
+
+maxwait = section:taboption("advanced", Value, "maxwait",
+ translate("Modem init timeout"),
+ translate("Maximum amount of seconds to wait for the modem to become
ready"))
+
+maxwait.placeholder = "20"
+maxwait.datatype    = "min(1)"
+
+
+defaultroute = section:taboption("advanced", Flag, "defaultroute",
+ translate("Use default gateway"),
+ translate("If unchecked, no default route is configured"))
+
+defaultroute.default = defaultroute.enabled
+
+
+metric = section:taboption("advanced", Value, "metric",
+ translate("Use gateway metric"))
+
+metric.placeholder = "0"
+metric.datatype    = "uinteger"
+metric:depends("defaultroute", defaultroute.enabled)
+
+
+peerdns = section:taboption("advanced", Flag, "peerdns",
+ translate("Use DNS servers advertised by peer"),
+ translate("If unchecked, the advertised DNS server addresses are
ignored"))
+
+peerdns.default = peerdns.enabled
+
+
+dns = section:taboption("advanced", DynamicList, "dns",
+ translate("Use custom DNS servers"))
+
+dns:depends("peerdns", "")
+dns.datatype = "ipaddr"
+dns.cast     = "string"
+
+
+keepalive_failure = section:taboption("advanced", Value,
"_keepalive_failure",
+ translate("LCP echo failure threshold"),
+ translate("Presume peer to be dead after given amount of LCP echo
failures, use 0 to ignore failures"))
+
+function keepalive_failure.cfgvalue(self, section)
+ local v = m:get(section, "keepalive")
+ if v and #v > 0 then
+ return tonumber(v:match("^(%d+)[ ,]+%d+") or v)
+ end
+end
+
+function keepalive_failure.write() end
+function keepalive_failure.remove() end
+
+keepalive_failure.placeholder = "0"
+keepalive_failure.datatype    = "uinteger"
+
+
+keepalive_interval = section:taboption("advanced", Value,
"_keepalive_interval",
+ translate("LCP echo interval"),
+ translate("Send LCP echo requests at the given interval in seconds, only
effective in conjunction with failure threshold"))
+
+function keepalive_interval.cfgvalue(self, section)
+ local v = m:get(section, "keepalive")
+ if v and #v > 0 then
+ return tonumber(v:match("^%d+[ ,]+(%d+)"))
+ end
+end
+
+function keepalive_interval.write(self, section, value)
+ local f = tonumber(keepalive_failure:formvalue(section)) or 0
+ local i = tonumber(value) or 5
+ if i < 1 then i = 1 end
+ if f > 0 then
+ m:set(section, "keepalive", "%d %d" %{ f, i })
+ else
+ m:del(section, "keepalive")
+ end
+end
+
+keepalive_interval.remove      = keepalive_interval.write
+keepalive_interval.placeholder = "5"
+keepalive_interval.datatype    = "min(1)"
+
+
+demand = section:taboption("advanced", Value, "demand",
+ translate("Inactivity timeout"),
+ translate("Close inactive connection after the given amount of seconds,
use 0 to persist connection"))
+
+demand.placeholder = "0"
+demand.datatype    = "uinteger"
--- /dev/null
+++ b/protocols/wwan/luasrc/model/network/proto_wwan.lua
@@ -0,0 +1,57 @@ 
+--[[
+LuCI - Network model - WWAN protocol extension
+
+Copyright 2015 Aleksandr Kolesnik <neryba@gmail.com>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+Unless required by applicable law or agreed to in writing, software
+distributed under the License is distributed on an "AS IS" BASIS,
+WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+See the License for the specific language governing permissions and
+limitations under the License.
+
+]]--
+
+local netmod = luci.model.network
+
+local proto = netmod:register_protocol("wwan")
+
+function proto.ifname(self)
+ return "wwan-" .. self.sid
+end
+
+function proto.get_i18n(self)
+ return luci.i18n.translate("WWAN")
+end
+
+function proto.opkg_package(self)
+ return "wwan"
+end
+
+function proto.is_installed(self)
+ return nixio.fs.access("/lib/netifd/proto/wwan.sh")
+end
+
+function proto.is_floating(self)
+ return true
+end
+
+function proto.is_virtual(self)
+ return true
+end
+
+function proto.get_interfaces(self)
+ return nil
+end
+
+function proto.contains_interface(self,ifc)
+ return (netmod:ifnameof(ifc) == self:ifname())
+end
+
+netmod:register_pattern_virtual("^wwan-%%w")
+