diff mbox

[OpenWrt-Devel,v4] export KERNEL_INITRAMFS_IMAGE

Message ID BLU436-SMTP20198EE122DBEB25FB05C7AD0F20@phx.gbl
State Changes Requested
Headers show

Commit Message

YounJaeRho Jan. 4, 2016, 3:22 a.m. UTC
`Build/ubnt-erx-factory-kernel` in `target\linux\ramips\image\Makefile`
references `$(KERNEL_INITRAMFS_IMAGE)`
which is not exported

Signed-off-by: YounJae Rho <luxflow@live.com>
---
 tested with git am in trunk commit 57693a7c8
 include/image.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

--
2.5.0

Comments

Felix Fietkau Jan. 4, 2016, 9:59 a.m. UTC | #1
On 2016-01-04 04:22, YounJae Rho wrote:
> `Build/ubnt-erx-factory-kernel` in `target\linux\ramips\image\Makefile`
> references `$(KERNEL_INITRAMFS_IMAGE)`
> which is not exported
> 
> Signed-off-by: YounJae Rho <luxflow@live.com>
> ---
>  tested with git am in trunk commit 57693a7c8
>  include/image.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/include/image.mk b/include/image.mk
> index 5ef8002..62ea0e7 100644
> --- a/include/image.mk
> +++ b/include/image.mk
> @@ -454,7 +454,7 @@ define Device/ExportVar
> 
>  endef
>  define Device/Export
> -  $(foreach var,$(DEVICE_VARS) DEVICE_NAME KERNEL KERNEL_INITRAMFS,$(call Device/ExportVar,$(1),$(var)))
> +  $(foreach var,$(DEVICE_VARS) DEVICE_NAME KERNEL KERNEL_INITRAMFS KERNEL_INITR AMFS_IMAGE,$(call Device/ExportVar,$(1),$(var)))
There's a whitespace here that doesn't belong. "KERNEL_INITR AMFS_IMAGE"
diff mbox

Patch

diff --git a/include/image.mk b/include/image.mk
index 5ef8002..62ea0e7 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -454,7 +454,7 @@  define Device/ExportVar

 endef
 define Device/Export
-  $(foreach var,$(DEVICE_VARS) DEVICE_NAME KERNEL KERNEL_INITRAMFS,$(call Device/ExportVar,$(1),$(var)))
+  $(foreach var,$(DEVICE_VARS) DEVICE_NAME KERNEL KERNEL_INITRAMFS KERNEL_INITR AMFS_IMAGE,$(call Device/ExportVar,$(1),$(var)))
   $(1) : FILESYSTEM:=$(2)
 endef