diff mbox series

[v2] ath79: add Embedded Wireless Balin Platform

Message ID AM0PR03MB41009049D9816BF371E9AC3CEF699@AM0PR03MB4100.eurprd03.prod.outlook.com
State Accepted, archived
Delegated to: Christian Lamparter
Headers show
Series [v2] ath79: add Embedded Wireless Balin Platform | expand

Commit Message

Catrinel Catrinescu Dec. 2, 2021, 10:07 a.m. UTC
Add the Embedded Wireless "Balin" platform, it is in ar71xx too
 SoC: QCA AR9344 or AR9350
 RAM: DDR2-RAM 64MBytes
 Flash: SPI-NOR 16MBytes
 WLAN: 2 x 2 MIMO 2.4 & 5 GHz IEEE802.11 a/b/g/n
 Ethernet: 3 x 10/100 Mb/s
 USB: 1 x USB2.0 Host/Device bootstrap-pin at power-up
 UART: 1 x Normal, 1 x High-Speed
 JTAG: 1 x EJTAG
 GPIO: 10 x Input/Output multiplexed

The module comes already with the current vanilla OpenWrt firmware.
To update, use "sysupgrade -n --force <image>" image directly in vendor firmware.

Signed-off-by: Catrinel Catrinescu <cc@80211.de>
---
 .../dts/ar9344_embeddedwireless_balin.dts     | 125 ++++++++++++++++++
 .../generic/base-files/etc/board.d/02_network |   4 +
 target/linux/ath79/image/generic.mk           |   9 ++
 3 files changed, 138 insertions(+)
 create mode 100644 target/linux/ath79/dts/ar9344_embeddedwireless_balin.dts

Comments

Christian Lamparter Dec. 3, 2021, 12:13 p.m. UTC | #1
Hi,

On 02/12/2021 11:07, Catrinel Catrinescu wrote:
> 
> Add the Embedded Wireless "Balin" platform, it is in ar71xx too
>   SoC: QCA AR9344 or AR9350
>   RAM: DDR2-RAM 64MBytes
>   Flash: SPI-NOR 16MBytes
>   WLAN: 2 x 2 MIMO 2.4 & 5 GHz IEEE802.11 a/b/g/n
>   Ethernet: 3 x 10/100 Mb/s
>   USB: 1 x USB2.0 Host/Device bootstrap-pin at power-up
>   UART: 1 x Normal, 1 x High-Speed
>   JTAG: 1 x EJTAG
>   GPIO: 10 x Input/Output multiplexed
> 

I'm curious, is there a problem with the mini-pcie that should be looked into?
The  19.07's ar71xx mach file did jusu enable the pcie port, we can do this too.
(The 19.07 also had a "WPS" Button, which is now RESET. But yes, I think this
is fine/better.)

In the mean time, I found a few more things (indent, unit-address of partitions)
and changed some stuff here and there.
https://git.openwrt.org/?p=openwrt/staging/chunkeey.git;a=commit;h=24d455d1d0adf64de844b25800c23992aa3eeda5

Cheers,
Christian
diff mbox series

Patch

diff --git a/target/linux/ath79/dts/ar9344_embeddedwireless_balin.dts b/target/linux/ath79/dts/ar9344_embeddedwireless_balin.dts
new file mode 100644
index 0000000000..19fba08708
--- /dev/null
+++ b/target/linux/ath79/dts/ar9344_embeddedwireless_balin.dts
@@ -0,0 +1,125 @@ 
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "ar9344.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+	model = "Embedded Wireless Balin";
+	compatible = "embeddedwireless,balin", "qca,ar9344";
+
+
+	chosen {
+		bootargs = "console=ttyS0,115200n8";
+	};
+
+	aliases {
+		led-boot = &led_system;
+		led-failsafe = &led_system;
+		led-running = &led_system;
+		led-upgrade = &led_system;
+	};
+
+	leds {
+		compatible = "gpio-leds";
+
+		led_system: system {
+			label = "green:system";
+			gpios = <&gpio 14 GPIO_ACTIVE_LOW>;
+			default-state = "on";
+		};
+	};
+
+	keys {
+		compatible = "gpio-keys";
+
+		reset {
+			linux,code = <KEY_RESTART>;
+			gpios = <&gpio 18 GPIO_ACTIVE_HIGH>;
+			debounce-interval = <60>;
+		};
+	};
+};
+
+&ref {
+	clock-frequency = <40000000>;
+};
+
+&spi {
+	status = "okay";
+
+	flash@0 {
+		compatible = "jedec,spi-nor";
+		reg = <0>;
+		spi-max-frequency = <50000000>;
+
+		partitions {
+			compatible = "fixed-partitions";
+			#address-cells = <1>;
+			#size-cells = <1>;
+
+			partition@0 {
+				label = "u-boot";
+				reg = <0x000000 0x040000>;
+				read-only;
+			};
+
+			partition@1 {
+				label = "u-boot-env";
+				reg = <0x040000 0x010000>;
+			};
+
+			partition@2 {
+				compatible = "denx,uimage";
+				label = "firmware";
+				reg = <0x050000 0xfa0000>;
+			};
+
+			partition@3 {
+				label = "art";
+				reg = <0xff0000 0x010000>;
+				read-only;
+
+	            compatible = "nvmem-cells";
+            	#address-cells = <1>;
+	            #size-cells = <1>;
+
+	            macaddr_art_1002: macaddr@1002 {
+		        reg = <0x1002 0x6>;
+	            };
+
+		        calibration_art_1000: calibration_data@1000 {
+    			reg = <0x1000 0x440>;
+	        	};
+			};
+		};
+	};
+};
+
+&builtin_switch {
+
+	/delete-property/qca,phy4-mii-enable;
+};
+
+&eth1 {
+	status = "okay";
+
+	nvmem-cells = <&macaddr_art_1002>;
+	nvmem-cell-names = "mac-address";
+	mac-address-increment-byte = <3>;
+	mac-address-increment = <0x40>;
+
+	gmac-config {
+		device = <&gmac>;
+		switch-phy-swap = <0>;
+		switch-only-mode = <1>;
+	};
+};
+
+&wmac {
+	status = "okay";
+
+	nvmem-cells = <&macaddr_art_1002>, <&calibration_art_1000>;
+	nvmem-cell-names = "mac-address", "calibration";
+};
diff --git a/target/linux/ath79/generic/base-files/etc/board.d/02_network b/target/linux/ath79/generic/base-files/etc/board.d/02_network
index 01e364a8fe..8c09932bd7 100644
--- a/target/linux/ath79/generic/base-files/etc/board.d/02_network
+++ b/target/linux/ath79/generic/base-files/etc/board.d/02_network
@@ -265,6 +265,10 @@  ath79_setup_interfaces()
 		ucidef_add_switch "switch0" \
 			"0@eth0" "2:lan:4" "3:lan:3" "4:lan:2" "5:lan:1" "1:wan"
 		;;
+	embeddedwireless,balin)
+		ucidef_add_switch "switch0" \
+			"0@eth0" "5:lan:1" "4:lan:2" "3:wan"
+		;;
 	embeddedwireless,dorin)
 		ucidef_add_switch "switch0" \
 			"0@eth0" "1:wan" "2:lan:3" "3:lan:2"
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 39f616b010..c259db94af 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -1028,6 +1028,15 @@  define Device/elecom_wrc-300ghbk2-i
 endef
 TARGET_DEVICES += elecom_wrc-300ghbk2-i
 
+define Device/embeddedwireless_balin
+  SOC := ar9344
+  DEVICE_VENDOR := Embedded Wireless
+  DEVICE_MODEL := Balin
+  DEVICE_PACKAGES := kmod-usb-chipidea2
+  IMAGE_SIZE := 16000k
+endef
+TARGET_DEVICES += embeddedwireless_balin
+
 define Device/embeddedwireless_dorin
   SOC := ar9331
   DEVICE_VENDOR := Embedded Wireless