diff mbox series

Patching backported WiFi driver

Message ID 8ac32117-ab18-a266-da91-3f73bda68d0a@yl-verkot.com
State Not Applicable
Delegated to: Petr Štetiar
Headers show
Series Patching backported WiFi driver | expand

Commit Message

Alexander Pyattaev Dec. 2, 2020, 10:59 a.m. UTC
Hi,

I hope someone could help me figure something out about quilt usage in 
kernel build. I need to patch a file in a WiFi driver. WiFi drivers 
appear to be pulled in from backports, i.e. all relevant sources are in 
something like

./build_dir/target-mipsel_24kc_musl/linux-ramips_mt7621/backports-5.8-1

while kernel itself is in

./build_dir/target-mipsel_24kc_musl/linux-ramips_mt7621/linux-5.4.75

However, I can not seem to find any package actually defining how that 
stuff is built. It looks like it should something defined in 
./package/kernel/mac80211/intel.mk

So based on that I dropped my patch into 
./package/kernel/mac80211/patches, but it does not have ANY effect. It 
does not crash, it does not apply, it is as if it did not exist. Please 
help! If it ends up working out in clean build that should allow AX200 
to work under openWRT, also in AP mode=)

Thank you,

Alex

For reference, the actual patch is below (I have formatted it based on 
what Atheros patches look like)

         if (iwl_mvm_has_new_rx_api(mvm)) {
                 ret = iwl_send_rss_cfg_cmd(mvm);
diff mbox series

Patch

--- a/drivers/net/wireless/intel/iwlwifi/mvm/fw.c
+++ b/drivers/net/wireless/intel/iwlwifi/mvm/fw.c
@@ -1241,14 +1241,14 @@ 
         }

         /* Init RSS configuration */
-       if (mvm->trans->trans_cfg->device_family >= 
IWL_DEVICE_FAMILY_22000) {
+       /*if (mvm->trans->trans_cfg->device_family >= 
IWL_DEVICE_FAMILY_22000) {
                 ret = iwl_configure_rxq(mvm);
                 if (ret) {
                         IWL_ERR(mvm, "Failed to configure RX queues: %d\n",
                                 ret);
                         goto error;
                 }
-       }
+       }*/