diff mbox

[OpenWrt-Devel,2/2] ar71xx: use Image/BuildLoaderPatched for TPLINK-SAFELOADER images

Message ID 823997d2d465c1a4003594d61f699fd113c246a0.1430343508.git.mschiffer@universe-factory.net
State Accepted
Headers show

Commit Message

Matthias Schiffer April 29, 2015, 9:38 p.m. UTC
Building the loader in Image/Build/TPLINK-SAFELOADER would break the image
builder as no target compiler is available in that stage.

Fixes #19580

Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
---
 target/linux/ar71xx/image/Makefile | 8 ++------
 1 file changed, 2 insertions(+), 6 deletions(-)

Comments

Matthias Schiffer May 30, 2015, 10:09 p.m. UTC | #1
Ping?

On 04/29/2015 11:38 PM, Matthias Schiffer wrote:
> Building the loader in Image/Build/TPLINK-SAFELOADER would break the image
> builder as no target compiler is available in that stage.
> 
> Fixes #19580
> 
> Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
> ---
>  target/linux/ar71xx/image/Makefile | 8 ++------
>  1 file changed, 2 insertions(+), 6 deletions(-)
> 
> diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
> index 06e2c0d..8db278d 100644
> --- a/target/linux/ar71xx/image/Makefile
> +++ b/target/linux/ar71xx/image/Makefile
> @@ -1078,14 +1078,10 @@ define Image/Build/TPLINK-LZMA/initramfs
>  endef
>  
>  
> -Image/Build/TPLINK-SAFELOADER/buildkernel=$(call PatchKernelLzma,$(2),$(3) $(4))
> +Image/Build/TPLINK-SAFELOADER/loader = $(call Image/BuildLoaderPatched,$(1),elf,$(2) $(3))
>  
>  define Image/Build/TPLINK-SAFELOADER
> -	-rm -rf $(KDIR)/lzma-loader
> -	$(LOADER_MAKE) LOADER=loader-$(2).elf\
> -		LZMA_TEXT_START=0x80a00000 LOADADDR=0x80060000 \
> -		LOADER_DATA="$(KDIR_TMP)/vmlinux-$(2).bin.lzma" BOARD="$(2)" \
> -		compile loader.elf
> +	[ -e "$(KDIR)/loader-$(2).elf" ]
>  
>  	-$(STAGING_DIR_HOST)/bin/tplink-safeloader \
>  		-B $(5) \
>
Felix Fietkau May 30, 2015, 10:58 p.m. UTC | #2
On 2015-05-31 00:09, Matthias Schiffer wrote:
> Ping?
> 
> On 04/29/2015 11:38 PM, Matthias Schiffer wrote:
>> Building the loader in Image/Build/TPLINK-SAFELOADER would break the image
>> builder as no target compiler is available in that stage.
>> 
>> Fixes #19580
>> 
>> Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
Applied now, thanks and sorry for the delay.

- Felix
diff mbox

Patch

diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 06e2c0d..8db278d 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -1078,14 +1078,10 @@  define Image/Build/TPLINK-LZMA/initramfs
 endef
 
 
-Image/Build/TPLINK-SAFELOADER/buildkernel=$(call PatchKernelLzma,$(2),$(3) $(4))
+Image/Build/TPLINK-SAFELOADER/loader = $(call Image/BuildLoaderPatched,$(1),elf,$(2) $(3))
 
 define Image/Build/TPLINK-SAFELOADER
-	-rm -rf $(KDIR)/lzma-loader
-	$(LOADER_MAKE) LOADER=loader-$(2).elf\
-		LZMA_TEXT_START=0x80a00000 LOADADDR=0x80060000 \
-		LOADER_DATA="$(KDIR_TMP)/vmlinux-$(2).bin.lzma" BOARD="$(2)" \
-		compile loader.elf
+	[ -e "$(KDIR)/loader-$(2).elf" ]
 
 	-$(STAGING_DIR_HOST)/bin/tplink-safeloader \
 		-B $(5) \