diff mbox

[OpenWrt-Devel,package] OpenSSL: Added source/old to PKG_SOURCE_URL

Message ID 5665E7B6.6010602@no-dkim.starletp9.de
State Accepted
Headers show

Commit Message

Kevin Kirsch Dec. 7, 2015, 8:10 p.m. UTC
OpenSSL moves old versions of the library from
http://www.openssl.org/source/ to
http://www.openssl.org/source/old/$version/ breaking the old links.
That behavior breaks the OpenWRT-build every time OpenSSL releases
a new version.

This patch adds http://www.openssl.org/source/old/$version/ to the
PKG_SOURCE_URL of OpenSSL to avoid breaking the build whenever
OpenSSL releases a new version.

Signed-off-by: Kevin Kirsch <ranlvor@starletp9.de>
---
@Alexander: Great idea, I updated my patch for master.
@OpenWRT-Maintainers: Should I somehow mention Alexanders work in the
commit-message?


 package/libs/openssl/Makefile | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)

Comments

Alexander Dahl Dec. 7, 2015, 10:08 p.m. UTC | #1
> Signed-off-by: Kevin Kirsch <ranlvor@starletp9.de>

Reviewed-by: Alexander Dahl <post@lespocky.de>

---

> ---
> @Alexander: Great idea, I updated my patch for master.
> @OpenWRT-Maintainers: Should I somehow mention Alexanders work in the
> commit-message?

For me the reviewed by would be sufficient, but thanks for asking.

Greets
Alex
John Crispin Dec. 11, 2015, 9:53 a.m. UTC | #2
Hi,

technically correct but you make 2 changes int he patch.

1) add a new url
2) split the variable into 2 variables for no apparent reason.

i would sugegst you drop 2) and we just merge 1)

	John

On 07/12/2015 21:10, Kevin Kirsch wrote:
> OpenSSL moves old versions of the library from
> http://www.openssl.org/source/ to
> http://www.openssl.org/source/old/$version/ breaking the old links.
> That behavior breaks the OpenWRT-build every time OpenSSL releases
> a new version.
> 
> This patch adds http://www.openssl.org/source/old/$version/ to the
> PKG_SOURCE_URL of OpenSSL to avoid breaking the build whenever
> OpenSSL releases a new version.
> 
> Signed-off-by: Kevin Kirsch <ranlvor@starletp9.de>
> ---
> @Alexander: Great idea, I updated my patch for master.
> @OpenWRT-Maintainers: Should I somehow mention Alexanders work in the
> commit-message?
> 
> 
>  package/libs/openssl/Makefile | 5 ++++-
>  1 file changed, 4 insertions(+), 1 deletion(-)
> 
> diff --git a/package/libs/openssl/Makefile b/package/libs/openssl/Makefile
> index faf6816..24acfc8 100644
> --- a/package/libs/openssl/Makefile
> +++ b/package/libs/openssl/Makefile
> @@ -8,7 +8,9 @@
>  include $(TOPDIR)/rules.mk
> 
>  PKG_NAME:=openssl
> -PKG_VERSION:=1.0.2e
> +PKG_BASE:=1.0.2
> +PKG_BUGFIX:=e
> +PKG_VERSION:=$(PKG_BASE)$(PKG_BUGFIX)
>  PKG_RELEASE:=1
>  PKG_USE_MIPS16:=0
> 
> @@ -17,6 +19,7 @@ PKG_BUILD_PARALLEL:=0
>  PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
>  PKG_SOURCE_URL:=http://www.openssl.org/source/ \
>  	ftp://ftp.openssl.org/source/ \
> +	http://www.openssl.org/source/old/$(PKG_BASE)/ \
>  	ftp://ftp.funet.fi/pub/crypt/mirrors/ftp.openssl.org/source \
>  	ftp://ftp.sunet.se/pub/security/tools/net/openssl/source/
>  PKG_MD5SUM:=5262bfa25b60ed9de9f28d5d52d77fc5
> 
> 
> 
> _______________________________________________
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel
>
Kevin Kirsch Dec. 11, 2015, 9:59 a.m. UTC | #3
Hi,

Am 11.12.2015 um 10:53 schrieb John Crispin:
> technically correct but you make 2 changes int he patch.
>
> 1) add a new url
> 2) split the variable into 2 variables for no apparent reason.

I do the split to avoid hardcoding the PKG_BASE in the URI. Should I
split the patch in 2 patches (first split, than add new url)?

> i would sugegst you drop 2) and we just merge 1)

That would be equivalent to the first version of the patch but needs
paying closer attention when increasing the PKG_BASE.

Kevin
John Crispin Dec. 11, 2015, 10:01 a.m. UTC | #4
On 11/12/2015 10:59, Kevin Kirsch wrote:
> Hi,
> 
> Am 11.12.2015 um 10:53 schrieb John Crispin:
>> technically correct but you make 2 changes int he patch.
>>
>> 1) add a new url
>> 2) split the variable into 2 variables for no apparent reason.
> 
> I do the split to avoid hardcoding the PKG_BASE in the URI. Should I
> split the patch in 2 patches (first split, than add new url)?
> 
>> i would sugegst you drop 2) and we just merge 1)
> 
> That would be equivalent to the first version of the patch but needs
> paying closer attention when increasing the PKG_BASE.
> 
> Kevin
> 

Hi,

i dont understand what issue splitting the variables fixes. if it fixes
an issue then fine. otherwise it is imho just over engineering.

	John


> 
> 
> _______________________________________________
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel
>
Kevin Kirsch Dec. 11, 2015, 10:07 a.m. UTC | #5
Hi,

Am 11.12.2015 um 11:01 schrieb John Crispin:
> On 11/12/2015 10:59, Kevin Kirsch wrote:
>> Am 11.12.2015 um 10:53 schrieb John Crispin:
>>> technically correct but you make 2 changes int he patch.
>>>
>>> 1) add a new url
>>> 2) split the variable into 2 variables for no apparent reason.

> i dont understand what issue splitting the variables fixes. if it fixes
> an issue then fine. otherwise it is imho just over engineering.

The URL I added is http://www.openssl.org/source/old/1.0.2/. The 1.0.2
has to be changed whenever the PKG_BASE is increased. If this is an
issue it should be fixed. If this is not an issue the first version of
the patch is sufficient.

Kevin
Alexander Dahl Dec. 11, 2015, 10:11 a.m. UTC | #6
Hei hei, 

Am 2015-12-11 10:53, schrieb John Crispin:
> 2) split the variable into 2 variables for no apparent reason.

There is a reason, see:

>> +	http://www.openssl.org/source/old/$(PKG_BASE)/ \

You could use a fix URL here like:

http://www.openssl.org/source/old/1.0.2/

But what if OpenSSL goes to 1.0.3, 1.0.4 and so on? Each time you would
not only have to edit the version number above but check through the
URLs.

You could also add another one like
http://www.openssl.org/source/old/1.0.3/ then, leaving the old one
useless.

However you can not use the previously used full version variable in the
URL, because a path like http://www.openssl.org/source/old/1.0.2e/ is
simply not the actual path.

The reason for the split is to use the base version in the URL. You
won't have to change the URL again, just the versions above. Quite
obvious for me. ;-)

Greets
Alex
John Crispin Dec. 11, 2015, 10:13 a.m. UTC | #7
On 11/12/2015 11:07, Kevin Kirsch wrote:
> Hi,
> 
> Am 11.12.2015 um 11:01 schrieb John Crispin:
>> On 11/12/2015 10:59, Kevin Kirsch wrote:
>>> Am 11.12.2015 um 10:53 schrieb John Crispin:
>>>> technically correct but you make 2 changes int he patch.
>>>>
>>>> 1) add a new url
>>>> 2) split the variable into 2 variables for no apparent reason.
> 
>> i dont understand what issue splitting the variables fixes. if it fixes
>> an issue then fine. otherwise it is imho just over engineering.
> 
> The URL I added is http://www.openssl.org/source/old/1.0.2/. The 1.0.2
> has to be changed whenever the PKG_BASE is increased. If this is an
> issue it should be fixed. If this is not an issue the first version of
> the patch is sufficient.
> 
> Kevin
> 

my bad i missed the PKG_BASE usage further down in the patch. i just
merged this into my local tree

	John

> 
> 
> _______________________________________________
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel
>
John Crispin Dec. 11, 2015, 10:15 a.m. UTC | #8
On 11/12/2015 11:11, Alexander Dahl wrote:
> Hei hei, 
> 
> Am 2015-12-11 10:53, schrieb John Crispin:
>> 2) split the variable into 2 variables for no apparent reason.
> 
> There is a reason, see:
> 
>>> +	http://www.openssl.org/source/old/$(PKG_BASE)/ \
> 

yep i had just noticed. sorry my bad missed that part earlier today.
patch makes sense in this case i have pulled it into my tree already.
	
	John

> You could use a fix URL here like:
> 
> http://www.openssl.org/source/old/1.0.2/
> 
> But what if OpenSSL goes to 1.0.3, 1.0.4 and so on? Each time you would
> not only have to edit the version number above but check through the
> URLs.
> 
> You could also add another one like
> http://www.openssl.org/source/old/1.0.3/ then, leaving the old one
> useless.
> 
> However you can not use the previously used full version variable in the
> URL, because a path like http://www.openssl.org/source/old/1.0.2e/ is
> simply not the actual path.
> 
> The reason for the split is to use the base version in the URL. You
> won't have to change the URL again, just the versions above. Quite
> obvious for me. ;-)
> 
> Greets
> Alex
>
diff mbox

Patch

diff --git a/package/libs/openssl/Makefile b/package/libs/openssl/Makefile
index faf6816..24acfc8 100644
--- a/package/libs/openssl/Makefile
+++ b/package/libs/openssl/Makefile
@@ -8,7 +8,9 @@ 
 include $(TOPDIR)/rules.mk

 PKG_NAME:=openssl
-PKG_VERSION:=1.0.2e
+PKG_BASE:=1.0.2
+PKG_BUGFIX:=e
+PKG_VERSION:=$(PKG_BASE)$(PKG_BUGFIX)
 PKG_RELEASE:=1
 PKG_USE_MIPS16:=0

@@ -17,6 +19,7 @@  PKG_BUILD_PARALLEL:=0
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.openssl.org/source/ \
 	ftp://ftp.openssl.org/source/ \
+	http://www.openssl.org/source/old/$(PKG_BASE)/ \
 	ftp://ftp.funet.fi/pub/crypt/mirrors/ftp.openssl.org/source \
 	ftp://ftp.sunet.se/pub/security/tools/net/openssl/source/
 PKG_MD5SUM:=5262bfa25b60ed9de9f28d5d52d77fc5