diff mbox

[OpenWrt-Devel] Linux 4.x

Message ID 5577E291.1050408@gmail.com
State Superseded
Headers show

Commit Message

Varka Bhadram June 10, 2015, 7:09 a.m. UTC
On 06/10/2015 12:35 PM, Baptiste Clenet wrote:

> 2015-06-09 6:05 GMT+02:00 Varka Bhadram <varkabhadram@gmail.com>:
>> On 06/08/2015 07:32 PM, Baptiste Clenet wrote:
>>
>>> 2015-06-08 15:23 GMT+02:00 Varka Bhadram <varkabhadram@gmail.com>:
>>>>
>> (...)
>>
>>> Thanks Varka for your help!
>>>
>>> It compiles now without those module:
>>> - kmod-bluetooth
>>> - kmod-bluetooth_6lowpan
>>> - kmod-6lowpan
>>> - kmod-ieee802154
>>> - kmod-ieee802154-6lowpan
>>> - kmod-ieee802154-drivers
>>> - kmod-mac802154
>>> - kmod-wpan-at86rf230
>>> - wpan-tools
>>>
>>> It's basically the same conf as yours.
>>>
>>> I don't get why those module would make an error since they worked
>>> well with Linux 3.18.
>>>
>>> Here are my tries:
>>> - kmod-6lowpan
>>> - kmod-ieee802154
>>> - kmod-ieee802154-6lowpan
>>> - kmod-ieee802154-drivers
>>
>> Have you added this ?
>>
>>> - kmod-mac802154
>>> - kmod-wpan-at86rf230
> Yes this packages weren't in OPENWRT Tree. I removed them and use the
> right ones now.
> - kmod-wpan-at86rf230 doesn't exist either, perhaps you meant
> kmod-at86rf230 under Wireless?

Yes..  :-)

> I added:
> - kmod-at86rf230
> - kmod-ieee802154
> - kmod-mac802154
> - kmod-ipv6
>
> I got the following error:
> Package kmod-at86rf230 is missing dependencies for the following libraries:
> regmap-core.ko
> regmap-spi.ko

Try this patch:

Comments

Baptiste Clenet June 10, 2015, 7:34 a.m. UTC | #1
2015-06-10 9:09 GMT+02:00 Varka Bhadram <varkabhadram@gmail.com>:
> On 06/10/2015 12:35 PM, Baptiste Clenet wrote:
>
>> 2015-06-09 6:05 GMT+02:00 Varka Bhadram <varkabhadram@gmail.com>:
>>>
>>> On 06/08/2015 07:32 PM, Baptiste Clenet wrote:
>>>
>>>> 2015-06-08 15:23 GMT+02:00 Varka Bhadram <varkabhadram@gmail.com>:
>>>>>
>>>>>
>>> (...)
>>>
>>>> Thanks Varka for your help!
>>>>
>>>> It compiles now without those module:
>>>> - kmod-bluetooth
>>>> - kmod-bluetooth_6lowpan
>>>> - kmod-6lowpan
>>>> - kmod-ieee802154
>>>> - kmod-ieee802154-6lowpan
>>>> - kmod-ieee802154-drivers
>>>> - kmod-mac802154
>>>> - kmod-wpan-at86rf230
>>>> - wpan-tools
>>>>
>>>> It's basically the same conf as yours.
>>>>
>>>> I don't get why those module would make an error since they worked
>>>> well with Linux 3.18.
>>>>
>>>> Here are my tries:
>>>> - kmod-6lowpan
>>>> - kmod-ieee802154
>>>> - kmod-ieee802154-6lowpan
>>>> - kmod-ieee802154-drivers
>>>
>>>
>>> Have you added this ?
>>>
>>>> - kmod-mac802154
>>>> - kmod-wpan-at86rf230
>>
>> Yes this packages weren't in OPENWRT Tree. I removed them and use the
>> right ones now.
>> - kmod-wpan-at86rf230 doesn't exist either, perhaps you meant
>> kmod-at86rf230 under Wireless?
>
>
> Yes..  :-)
>
>> I added:
>> - kmod-at86rf230
>> - kmod-ieee802154
>> - kmod-mac802154
>> - kmod-ipv6
>>
>> I got the following error:
>> Package kmod-at86rf230 is missing dependencies for the following
>> libraries:
>> regmap-core.ko
>> regmap-spi.ko
>
>
> Try this patch:
>
> diff --git a/package/kernel/linux/modules/wpan.mk
> b/package/kernel/linux/modules/wpan.mk
> index 6b07809..412d70e 100644
> --- a/package/kernel/linux/modules/wpan.mk
> +++ b/package/kernel/linux/modules/wpan.mk
> @@ -71,7 +71,7 @@ $(eval $(call KernelPackage,fakelb))
>  define KernelPackage/at86rf230
>    SUBMENU:=$(WPAN_MENU)
>    TITLE:=AT86RF230 transceiver driver
> -  DEPENDS:=+kmod-mac802154
> +  DEPENDS:=+kmod-mac802154 +kmod-regmap
>    KCONFIG:=CONFIG_IEEE802154_AT86RF230 \
>         CONFIG_SPI=y \
>         CONFIG_SPI_MASTER=y
> @@ -107,7 +107,7 @@ $(eval $(call KernelPackage,cc2520))
>  define KernelPackage/ieee802154_6lowpan
>    SUBMENU:=$(WPAN_MENU)
>    TITLE:= 6LoWPAN support over IEEE-802.15.4
> -  DEPENDS:=@LINUX_4_0 +kmod-6lowpan
> +  DEPENDS:=@LINUX_4_0 +kmod-6lowpan +kmod-ieee802154
>    KCONFIG:=CONFIG_IEEE802154_6LOWPAN
>    FILES:= \
>         $(LINUX_DIR)/net/ieee802154/6lowpan/ieee802154_6lowpan.ko@ge4.0 \
> --
> 1.7.9.5
>
> --
> Varka Bhadram
>

Thanks Varka, works well now!
Next step is making at86rf230 work seamlessly.
Cheers,

Baptiste
diff mbox

Patch

diff --git a/package/kernel/linux/modules/wpan.mk b/package/kernel/linux/modules/wpan.mk
index 6b07809..412d70e 100644
--- a/package/kernel/linux/modules/wpan.mk
+++ b/package/kernel/linux/modules/wpan.mk
@@ -71,7 +71,7 @@  $(eval $(call KernelPackage,fakelb))
  define KernelPackage/at86rf230
    SUBMENU:=$(WPAN_MENU)
    TITLE:=AT86RF230 transceiver driver
-  DEPENDS:=+kmod-mac802154
+  DEPENDS:=+kmod-mac802154 +kmod-regmap
    KCONFIG:=CONFIG_IEEE802154_AT86RF230 \
         CONFIG_SPI=y \
         CONFIG_SPI_MASTER=y
@@ -107,7 +107,7 @@  $(eval $(call KernelPackage,cc2520))
  define KernelPackage/ieee802154_6lowpan
    SUBMENU:=$(WPAN_MENU)
    TITLE:= 6LoWPAN support over IEEE-802.15.4
-  DEPENDS:=@LINUX_4_0 +kmod-6lowpan
+  DEPENDS:=@LINUX_4_0 +kmod-6lowpan +kmod-ieee802154
    KCONFIG:=CONFIG_IEEE802154_6LOWPAN
    FILES:= \
         $(LINUX_DIR)/net/ieee802154/6lowpan/ieee802154_6lowpan.ko@ge4.0 \