diff mbox

[OpenWrt-Devel] wpan: rework bluetooth / wpan and 6lowpan dependencies

Message ID 5527FBEC.6080303@web.de
State Changes Requested
Headers show

Commit Message

Dirk Neukirchen April 10, 2015, 4:35 p.m. UTC
Is there a reason for  Kernel 4.0 as
all the modules already exist in 3.18 

- fix: lines are doubled
- fix: 6lowpan symbol integrated into a bluetooth module
6lowpan is for 802.15.4 and bluetooth so separate it

Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de>
---
 package/kernel/linux/modules/other.mk | 27 +++++++++++++++++++--------
 package/kernel/linux/modules/wpan.mk  |  3 +--
 2 files changed, 20 insertions(+), 10 deletions(-)

Comments

John Crispin April 14, 2015, 3:56 p.m. UTC | #1
Hi Dirk,

patch does not apply anymore, could you send a rebased version please

	John

On 10/04/2015 18:35, Dirk Neukirchen wrote:
> Is there a reason for  Kernel 4.0 as
> all the modules already exist in 3.18 
> 
> - fix: lines are doubled
> - fix: 6lowpan symbol integrated into a bluetooth module
> 6lowpan is for 802.15.4 and bluetooth so separate it
> 
> Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de>
> ---
>  package/kernel/linux/modules/other.mk | 27 +++++++++++++++++++--------
>  package/kernel/linux/modules/wpan.mk  |  3 +--
>  2 files changed, 20 insertions(+), 10 deletions(-)
> 
> diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
> index 4696f2d..985e985 100644
> --- a/package/kernel/linux/modules/other.mk
> +++ b/package/kernel/linux/modules/other.mk
> @@ -10,6 +10,21 @@ OTHER_MENU:=Other modules
>  WATCHDOG_DIR:=watchdog
>  
>  
> +define KernelPackage/6lowpan
> +  SUBMENU:=$(OTHER_MENU)
> +  TITLE:=Bluetooth & 802.15.4 6LoWPAN support
> +  DEPENDS:=@!LINUX_3_14
> +  KCONFIG:=CONFIG_6LOWPAN
> +  FILES:=$(LINUX_DIR)/net/6lowpan/6lowpan.ko
> +  AUTOLOAD:=$(call AutoProbe,6lowpan)
> +endef
> +
> +define KernelPackage/6lowpan/description
> + Kernel support for 6LoWPAN for Bluetooth Low Energy or 802.15.4 devices
> +endef
> +
> +$(eval $(call KernelPackage,6lowpan))
> +
>  define KernelPackage/6lowpan-iphc
>    USBMENU:=$(OTHER_MENU)
>    TITLE:=6lowpan shared code
> @@ -70,14 +85,10 @@ $(eval $(call KernelPackage,bluetooth))
>  define KernelPackage/bluetooth_6lowpan
>    SUBMENU:=$(OTHER_MENU)
>    TITLE:=Bluetooth 6LoWPAN support
> -  DEPENDS:=+kmod-bluetooth @!LINUX_3_14
> -  KCONFIG:= \
> -  CONFIG_6LOWPAN=m \
> -  CONFIG_BT_6LOWPAN=m
> -  FILES:= \
> -       $(LINUX_DIR)/net/bluetooth/bluetooth_6lowpan.ko \
> -       $(LINUX_DIR)/net/6lowpan/6lowpan.ko
> -       AUTOLOAD:=$(call AutoProbe,bluetooth)
> +  DEPENDS:=+kmod-bluetooth +kmod-6lowpan @!LINUX_3_14
> +  KCONFIG:=CONFIG_BT_6LOWPAN
> +  FILES:=$(LINUX_DIR)/net/bluetooth/bluetooth_6lowpan.ko
> +  AUTOLOAD:=$(call AutoProbe,bluetooth)
>  endef
>  
>  define KernelPackage/bluetooth_6lowpan/description
> diff --git a/package/kernel/linux/modules/wpan.mk b/package/kernel/linux/modules/wpan.mk
> index 8b25377..263cf60 100644
> --- a/package/kernel/linux/modules/wpan.mk
> +++ b/package/kernel/linux/modules/wpan.mk
> @@ -108,9 +108,8 @@ $(eval $(call KernelPackage,cc2520))
>  define KernelPackage/ieee802154_6lowpan
>    SUBMENU:=$(WPAN_MENU)
>    TITLE:= 6LoWPAN support over IEEE-802.15.4
> -  DEPENDS:=@LINUX_4_0
>    KCONFIG:=CONFIG_IEEE802154_6LOWPAN
> -  DEPENDS:=@LINUX_4_0
> +  DEPENDS:=@LINUX_4_0 +kmod-6lowpan
>    FILES:=$(LINUX_DIR)/net/ieee802154/6lowpan/ieee802154_6lowpan.ko
>    AUTOLOAD:=$(call AutoLoad,91,ieee802154_6lowpan)
>  endef
>
diff mbox

Patch

diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 4696f2d..985e985 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -10,6 +10,21 @@  OTHER_MENU:=Other modules
 WATCHDOG_DIR:=watchdog
 
 
+define KernelPackage/6lowpan
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=Bluetooth & 802.15.4 6LoWPAN support
+  DEPENDS:=@!LINUX_3_14
+  KCONFIG:=CONFIG_6LOWPAN
+  FILES:=$(LINUX_DIR)/net/6lowpan/6lowpan.ko
+  AUTOLOAD:=$(call AutoProbe,6lowpan)
+endef
+
+define KernelPackage/6lowpan/description
+ Kernel support for 6LoWPAN for Bluetooth Low Energy or 802.15.4 devices
+endef
+
+$(eval $(call KernelPackage,6lowpan))
+
 define KernelPackage/6lowpan-iphc
   USBMENU:=$(OTHER_MENU)
   TITLE:=6lowpan shared code
@@ -70,14 +85,10 @@  $(eval $(call KernelPackage,bluetooth))
 define KernelPackage/bluetooth_6lowpan
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Bluetooth 6LoWPAN support
-  DEPENDS:=+kmod-bluetooth @!LINUX_3_14
-  KCONFIG:= \
-  CONFIG_6LOWPAN=m \
-  CONFIG_BT_6LOWPAN=m
-  FILES:= \
-       $(LINUX_DIR)/net/bluetooth/bluetooth_6lowpan.ko \
-       $(LINUX_DIR)/net/6lowpan/6lowpan.ko
-       AUTOLOAD:=$(call AutoProbe,bluetooth)
+  DEPENDS:=+kmod-bluetooth +kmod-6lowpan @!LINUX_3_14
+  KCONFIG:=CONFIG_BT_6LOWPAN
+  FILES:=$(LINUX_DIR)/net/bluetooth/bluetooth_6lowpan.ko
+  AUTOLOAD:=$(call AutoProbe,bluetooth)
 endef
 
 define KernelPackage/bluetooth_6lowpan/description
diff --git a/package/kernel/linux/modules/wpan.mk b/package/kernel/linux/modules/wpan.mk
index 8b25377..263cf60 100644
--- a/package/kernel/linux/modules/wpan.mk
+++ b/package/kernel/linux/modules/wpan.mk
@@ -108,9 +108,8 @@  $(eval $(call KernelPackage,cc2520))
 define KernelPackage/ieee802154_6lowpan
   SUBMENU:=$(WPAN_MENU)
   TITLE:= 6LoWPAN support over IEEE-802.15.4
-  DEPENDS:=@LINUX_4_0
   KCONFIG:=CONFIG_IEEE802154_6LOWPAN
-  DEPENDS:=@LINUX_4_0
+  DEPENDS:=@LINUX_4_0 +kmod-6lowpan
   FILES:=$(LINUX_DIR)/net/ieee802154/6lowpan/ieee802154_6lowpan.ko
   AUTOLOAD:=$(call AutoLoad,91,ieee802154_6lowpan)
 endef