diff mbox

[OpenWrt-Devel] oxnas: fix itb generation

Message ID 54E19312.5040507@web.de
State Accepted
Headers show

Commit Message

Dirk Neukirchen Feb. 16, 2015, 6:49 a.m. UTC
- according to imx6 Makefile and u-Boot documentation is itb 
  and probably should not be changed
- this fixes build error if CONFIG_TARGET_ROOTFS_INCLUDE_FIT is set
  (missing .itb file)
- use DTS_DIR (like in imx6 Makefile)

only compile tested

Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de>
---
 target/linux/oxnas/image/Makefile | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Daniel Golle Feb. 16, 2015, 1:56 p.m. UTC | #1
On Mon, Feb 16, 2015 at 07:49:54AM +0100, Dirk Neukirchen wrote:
> - according to imx6 Makefile and u-Boot documentation is itb 
>   and probably should not be changed
> - this fixes build error if CONFIG_TARGET_ROOTFS_INCLUDE_FIT is set
>   (missing .itb file)
> - use DTS_DIR (like in imx6 Makefile)
> 
> only compile tested
> 
> Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de>
Acked-by: Daniel Golle <daniel@makrotopia.org>
diff mbox

Patch

diff --git a/target/linux/oxnas/image/Makefile b/target/linux/oxnas/image/Makefile
index b09c67e..2660a9b 100644
--- a/target/linux/oxnas/image/Makefile
+++ b/target/linux/oxnas/image/Makefile
@@ -28,10 +28,10 @@  $(shell echo $(PROFILE) | tr '[:upper:]' '[:lower:]' | sed 's/_/-/g')
 endef
 
 define Image/BuildKernel/Template
-	$(CP) $(LINUX_DIR)/arch/arm/boot/dts/ox820-$(1).dtb $(BIN_DIR)/$(IMG_PREFIX)-$(1).dtb
+	$(CP) $(DTS_DIR)/ox820-$(1).dtb $(BIN_DIR)/$(IMG_PREFIX)-$(1).dtb
 
 	$(call Image/BuildKernel/MkFIT,$(1),$(KDIR)/zImage,$(BIN_DIR)/$(IMG_PREFIX)-$(1).dtb,none,0x60008000,0x60008000)
-	$(CP) $(KDIR)/fit-$(1).itb $(BIN_DIR)/$(IMG_PREFIX)-$(1)-fit-uImage.bin
+	$(CP) $(KDIR)/fit-$(1).itb $(BIN_DIR)/$(IMG_PREFIX)-$(1)-fit-uImage.itb
 
  ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
 	$(call Image/BuildKernel/MkFIT,$(1),$(KDIR)/zImage-initramfs,$(BIN_DIR)/$(IMG_PREFIX)-$(1).dtb,none,0x60008000,0x60008000,-initramfs)