diff mbox

[OpenWrt-Devel] enable vlan filtering.

Message ID 5489F095.5040100@navigue.com
State Changes Requested
Headers show

Commit Message

Jonathan Thibault Dec. 11, 2014, 7:29 p.m. UTC
This is quite useful when you want to encapsulate l2 into a vpn and
other things of that nature.

I've called the package containing the 'bridge' command bridge2 (from
iproute2) to avoid conflicting with old package 'bridge' which should
really be called 'bridge-utils' and which provides 'brctl'.

It could be called 'iproute2-bridge' or something else, I'll let
maintainers decide what is best.

Maybe since brctl is now provided by busybox, there's no real need for
the original 'bridge' package.

Comments

Felix Fietkau Dec. 12, 2014, 4:24 p.m. UTC | #1
On 2014-12-11 20:29, Jonathan Thibault wrote:
> This is quite useful when you want to encapsulate l2 into a vpn and
> other things of that nature.
> 
> I've called the package containing the 'bridge' command bridge2 (from
> iproute2) to avoid conflicting with old package 'bridge' which should
> really be called 'bridge-utils' and which provides 'brctl'.
> 
> It could be called 'iproute2-bridge' or something else, I'll let
> maintainers decide what is best.
Yes, I think it should be called iproute2-bridge.

> Maybe since brctl is now provided by busybox, there's no real need for
> the original 'bridge' package.
> 
> diff --git a/package/kernel/linux/modules/netsupport.mk
> b/package/kernel/linux/modules/netsupport.mk
> index fc85e22..542462b 100644
> --- a/package/kernel/linux/modules/netsupport.mk
> +++ b/package/kernel/linux/modules/netsupport.mk
> @@ -86,7 +86,8 @@ define KernelPackage/bridge
>    DEPENDS:=+kmod-stp
>    KCONFIG:= \
>         CONFIG_BRIDGE \
> -       CONFIG_BRIDGE_IGMP_SNOOPING=y
> +       CONFIG_BRIDGE_IGMP_SNOOPING=y \
> +       CONFIG_BRIDGE_VLAN_FILTERING=y
>    FILES:=$(LINUX_DIR)/net/bridge/bridge.ko
>    AUTOLOAD:=$(call AutoLoad,11,bridge)
>  endef
This needs to be done in the generic kernel config instead, since most
targets build bridge support into the kernel.

- Felix
diff mbox

Patch

diff --git a/package/kernel/linux/modules/netsupport.mk
b/package/kernel/linux/modules/netsupport.mk
index fc85e22..542462b 100644
--- a/package/kernel/linux/modules/netsupport.mk
+++ b/package/kernel/linux/modules/netsupport.mk
@@ -86,7 +86,8 @@  define KernelPackage/bridge
   DEPENDS:=+kmod-stp
   KCONFIG:= \
        CONFIG_BRIDGE \
-       CONFIG_BRIDGE_IGMP_SNOOPING=y
+       CONFIG_BRIDGE_IGMP_SNOOPING=y \
+       CONFIG_BRIDGE_VLAN_FILTERING=y
   FILES:=$(LINUX_DIR)/net/bridge/bridge.ko
   AUTOLOAD:=$(call AutoLoad,11,bridge)
 endef
diff --git a/package/network/utils/iproute2/Makefile
b/package/network/utils/iproute2/Makefile
index fc47159..98cc8fd 100644
--- a/package/network/utils/iproute2/Makefile
+++ b/package/network/utils/iproute2/Makefile
@@ -53,6 +53,11 @@  $(call Package/iproute2/Default)
   TITLE:=General netlink utility frontend
 endef
 
+define Package/bridge2
+$(call Package/iproute2/Default)
+  TITLE:=Bridge configuration utility
+endef
+
 define Package/ss
 $(call Package/iproute2/Default)
   TITLE:=Socket statistics utility
@@ -122,6 +127,11 @@  define Package/genl/install
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/genl/genl $(1)/usr/sbin/
 endef
 
+define Package/bridge2/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/bridge/bridge $(1)/usr/sbin/
+endef
+
 define Package/ss/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/misc/ss $(1)/usr/sbin/
@@ -131,4 +141,5 @@  $(eval $(call BuildPackage,ip))
 $(eval $(call BuildPackage,ip-full))
 $(eval $(call BuildPackage,tc))
 $(eval $(call BuildPackage,genl))
+$(eval $(call BuildPackage,bridge2))
 $(eval $(call BuildPackage,ss))