diff mbox

[OpenWrt-Devel,ar71xx] Add support for Onion Omega

Message ID 44C29C43-84B7-4D50-AD59-CB7FAA0C6F18@onion.io
State Changes Requested
Headers show

Commit Message

Boken Lin July 9, 2015, 5:47 a.m. UTC
From: Boken Lin <bl@onion.io>

Add support for Onion Omega.
Signed-off-by: Boken Lin <bl@onion.io>

---
target/linux/ar71xx/base-files/etc/diag.sh         |  3 +
.../ar71xx/base-files/etc/uci-defaults/02_network  |  1 +
target/linux/ar71xx/base-files/lib/ar71xx.sh       |  3 +
.../ar71xx/base-files/lib/upgrade/platform.sh      |  1 +
target/linux/ar71xx/config-3.18                    |  1 +
.../files/arch/mips/ath79/mach-onion-omega.c       | 85 ++++++++++++++++++++++
target/linux/ar71xx/generic/profiles/onion.mk      | 16 ++++
target/linux/ar71xx/image/Makefile                 |  9 +++
.../610-MIPS-ath79-openwrt-machines.patch          | 24 ++++--
tools/firmware-utils/src/mktplinkfw.c              |  8 +-
10 files changed, 144 insertions(+), 7 deletions(-)
create mode 100644 target/linux/ar71xx/files/arch/mips/ath79/mach-onion-omega.c
create mode 100644 target/linux/ar71xx/generic/profiles/onion.mk

Comments

John Crispin July 9, 2015, 5:49 a.m. UTC | #1
Hi,

your mail client chewed the tabs and replaced them with spaces. please
check your ail clients settings or use git to send the patch

	John

On 09/07/2015 07:47, Boken Lin wrote:
> From: Boken Lin <bl@onion.io>
> 
> Add support for Onion Omega.
> Signed-off-by: Boken Lin <bl@onion.io>
> 
> ---
> target/linux/ar71xx/base-files/etc/diag.sh         |  3 +
> .../ar71xx/base-files/etc/uci-defaults/02_network  |  1 +
> target/linux/ar71xx/base-files/lib/ar71xx.sh       |  3 +
> .../ar71xx/base-files/lib/upgrade/platform.sh      |  1 +
> target/linux/ar71xx/config-3.18                    |  1 +
> .../files/arch/mips/ath79/mach-onion-omega.c       | 85 ++++++++++++++++++++++
> target/linux/ar71xx/generic/profiles/onion.mk      | 16 ++++
> target/linux/ar71xx/image/Makefile                 |  9 +++
> .../610-MIPS-ath79-openwrt-machines.patch          | 24 ++++--
> tools/firmware-utils/src/mktplinkfw.c              |  8 +-
> 10 files changed, 144 insertions(+), 7 deletions(-)
> create mode 100644 target/linux/ar71xx/files/arch/mips/ath79/mach-onion-omega.c
> create mode 100644 target/linux/ar71xx/generic/profiles/onion.mk
> 
> diff --git a/target/linux/ar71xx/base-files/etc/diag.sh b/target/linux/ar71xx/base-files/etc/diag.sh
> index ce2b9ba..0015d4c 100644
> --- a/target/linux/ar71xx/base-files/etc/diag.sh
> +++ b/target/linux/ar71xx/base-files/etc/diag.sh
> @@ -167,6 +167,9 @@ get_status_led() {
> 	om5p-an)
> 		status_led="om5p:blue:power"
> 		;;
> +    onion-omega)
> +        status_led="onion:amber:system"
> +        ;;
> 	pb44)
> 		status_led="pb44:amber:jump1"
> 		;;
> diff --git a/target/linux/ar71xx/base-files/etc/uci-defaults/02_network b/target/linux/ar71xx/base-files/etc/uci-defaults/02_network
> index ec709a0..6e9185c 100755
> --- a/target/linux/ar71xx/base-files/etc/uci-defaults/02_network
> +++ b/target/linux/ar71xx/base-files/etc/uci-defaults/02_network
> @@ -313,6 +313,7 @@ mr600 |\
> mr600v2 |\
> mr900 |\
> mr900v2 |\
> +onion-omega |\
> rb-411 |\
> rb-911g-2hpnd |\
> rb-911g-5hpacd |\
> diff --git a/target/linux/ar71xx/base-files/lib/ar71xx.sh b/target/linux/ar71xx/base-files/lib/ar71xx.sh
> index dd13948..e23ed74 100755
> --- a/target/linux/ar71xx/base-files/lib/ar71xx.sh
> +++ b/target/linux/ar71xx/base-files/lib/ar71xx.sh
> @@ -550,6 +550,9 @@ ar71xx_board_detect() {
> 	*"OM5P AN")
> 		name="om5p-an"
> 		;;
> +    *"Onion Omega")
> +        name="onion-omega"
> +        ;;
> 	*PB42)
> 		name="pb42"
> 		;;
> diff --git a/target/linux/ar71xx/base-files/lib/upgrade/platform.sh b/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
> index 73d8b0d..b045a33 100755
> --- a/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
> +++ b/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
> @@ -312,6 +312,7 @@ platform_check_image() {
> 	gl-inet | \
> 	mc-mac1200r | \
> 	oolite | \
> +    onion-omega | \
> 	smart-300 | \
> 	tl-mr10u | \
> 	tl-mr11u | \
> diff --git a/target/linux/ar71xx/config-3.18 b/target/linux/ar71xx/config-3.18
> index 02857d5..388cb2b 100644
> --- a/target/linux/ar71xx/config-3.18
> +++ b/target/linux/ar71xx/config-3.18
> @@ -86,6 +86,7 @@ CONFIG_ATH79_MACH_NBG460N=y
> CONFIG_ATH79_MACH_NBG6716=y
> CONFIG_ATH79_MACH_OM2P=y
> CONFIG_ATH79_MACH_OM5P=y
> +CONFIG_ATH79_MACH_ONION_OMEGA=y
> CONFIG_ATH79_MACH_PB42=y
> CONFIG_ATH79_MACH_PB44=y
> CONFIG_ATH79_MACH_PB92=y
> diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-onion-omega.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-onion-omega.c
> new file mode 100644
> index 0000000..177e76f
> --- /dev/null
> +++ b/target/linux/ar71xx/files/arch/mips/ath79/mach-onion-omega.c
> @@ -0,0 +1,85 @@
> +/*
> + *  Onion Omega board support
> + *
> + *  Copyright (C) 2015 Boken Lin <bl@onion.io>
> + *
> + *  This program is free software; you can redistribute it and/or modify it
> + *  under the terms of the GNU General Public License version 2 as published
> + *  by the Free Software Foundation.
> + */
> +
> +#include <linux/gpio.h>
> +
> +#include <asm/mach-ath79/ath79.h>
> +
> +#include "dev-eth.h"
> +#include "dev-gpio-buttons.h"
> +#include "dev-leds-gpio.h"
> +#include "dev-m25p80.h"
> +#include "dev-usb.h"
> +#include "dev-wmac.h"
> +#include "machtypes.h"
> +
> +#define OMEGA_GPIO_LED_SYSTEM   27
> +#define OMEGA_GPIO_BTN_RESET    11
> +
> +#define OMEGA_GPIO_USB_POWER    8
> +
> +#define OMEGA_KEYS_POLL_INTERVAL    20  /* msecs */
> +#define OMEGA_KEYS_DEBOUNCE_INTERVAL    (3 * OMEGA_KEYS_POLL_INTERVAL)
> +
> +static const char *omega_part_probes[] = {
> +    "tp-link",
> +    NULL,
> +};
> +
> +static struct flash_platform_data omega_flash_data = {
> +    .part_probes    = omega_part_probes,
> +};
> +
> +static struct gpio_led omega_leds_gpio[] __initdata = {
> +    {
> +        .name       = "onion:amber:system",
> +        .gpio       = OMEGA_GPIO_LED_SYSTEM,
> +        .active_low = 1,
> +    },
> +};
> +
> +static struct gpio_keys_button omega_gpio_keys[] __initdata = {
> +    {
> +        .desc       = "reset",
> +        .type       = EV_KEY,
> +        .code       = KEY_RESTART,
> +        .debounce_interval = OMEGA_KEYS_DEBOUNCE_INTERVAL,
> +        .gpio       = OMEGA_GPIO_BTN_RESET,
> +        .active_low = 0,
> +    }
> +};
> +
> +static void __init onion_omega_setup(void)
> +{
> +    u8 *mac = (u8 *) KSEG1ADDR(0x1f01fc00);
> +    u8 *ee = (u8 *) KSEG1ADDR(0x1fff1000);
> +
> +    ath79_register_m25p80(&omega_flash_data);
> +    ath79_register_leds_gpio(-1, ARRAY_SIZE(omega_leds_gpio),
> +                 omega_leds_gpio);
> +    ath79_register_gpio_keys_polled(-1, OMEGA_KEYS_POLL_INTERVAL,
> +                    ARRAY_SIZE(omega_gpio_keys),
> +                    omega_gpio_keys);
> +
> +    gpio_request_one(OMEGA_GPIO_USB_POWER,
> +             GPIOF_OUT_INIT_HIGH | GPIOF_EXPORT_DIR_FIXED,
> +             "USB power");
> +    ath79_register_usb();
> +
> +    ath79_init_mac(ath79_eth0_data.mac_addr, mac, -1);
> +
> +    ath79_register_mdio(0, 0x0);
> +    ath79_register_eth(0);
> +
> +    ath79_register_wmac(ee, mac);
> +}
> +
> +MIPS_MACHINE(ATH79_MACH_ONION_OMEGA, "ONION-OMEGA", "Onion Omega",
> +         onion_omega_setup);
> diff --git a/target/linux/ar71xx/generic/profiles/onion.mk b/target/linux/ar71xx/generic/profiles/onion.mk
> new file mode 100644
> index 0000000..b8db577
> --- /dev/null
> +++ b/target/linux/ar71xx/generic/profiles/onion.mk
> @@ -0,0 +1,16 @@
> +#
> +# Copyright (C) 2014 OpenWrt.org
> +#
> +# This is free software, licensed under the GNU General Public License v2.
> +# See /LICENSE for more information.
> +#
> +
> +define Profile/OMEGA
> +	NAME:=Onion Omega
> +	PACKAGES:=kmod-usb-core kmod-usb2 kmod-usb-storage kmod-i2c-core kmod-i2c-gpio-custom kmod-spi-bitbang kmod-spi-dev kmod-spi-gpio kmod-spi-gpio-custom kmod-usb-serial
> +endef
> +
> +define Profile/OMEGA/Description
> +	Package set optimized for the Onion Omega Development Platform.
> +endef
> +$(eval $(call Profile,OMEGA))
> diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
> index 0351310..2b59a24 100644
> --- a/target/linux/ar71xx/image/Makefile
> +++ b/target/linux/ar71xx/image/Makefile
> @@ -388,6 +388,15 @@ define Device/mc-mac1200r
> endef
> TARGET_DEVICES += mc-mac1200r
> 
> +define Device/onion-omega
> +    $(Device/tplink-16mlzma)
> +    BOARDNAME := ONION-OMEGA
> +    DEVICE_PROFILE := OMEGA
> +    TPLINK_HWID := 0x04700001
> +    CONSOLE := ttyATH0,115200
> +endef
> +TARGET_DEVICES += onion-omega
> +
> define Device/tl-mr10u-v1
>     $(Device/tplink-4mlzma)
>     BOARDNAME := TL-MR10U
> diff --git a/target/linux/ar71xx/patches-3.18/610-MIPS-ath79-openwrt-machines.patch b/target/linux/ar71xx/patches-3.18/610-MIPS-ath79-openwrt-machines.patch
> index 3f22a37..8c12034 100644
> --- a/target/linux/ar71xx/patches-3.18/610-MIPS-ath79-openwrt-machines.patch
> +++ b/target/linux/ar71xx/patches-3.18/610-MIPS-ath79-openwrt-machines.patch
> @@ -1,6 +1,6 @@
> --- a/arch/mips/ath79/machtypes.h
> +++ b/arch/mips/ath79/machtypes.h
> -@@ -16,22 +16,193 @@
> +@@ -16,22 +16,194 @@
> 
>  enum ath79_mach_type {
>  	ATH79_MACH_GENERIC = 0,
> @@ -73,6 +73,7 @@
> +	ATH79_MACH_OM2Pv2,		/* OpenMesh OM2Pv2 */
> +	ATH79_MACH_OM2P,		/* OpenMesh OM2P */
> +	ATH79_MACH_OM5P,		/* OpenMesh OM5P */
> ++   ATH79_MACH_ONION_OMEGA,     /* ONION OMEGA */
> +	ATH79_MACH_PB42,		/* Atheros PB42 */
> +	ATH79_MACH_PB92,		/* Atheros PB92 */
> +	ATH79_MACH_QIHOO_C301,		/* Qihoo 360 C301 */
> @@ -267,7 +268,7 @@
>  config ATH79_MACH_AP121
>  	bool "Atheros AP121 reference board"
>  	select SOC_AR933X
> -@@ -11,62 +75,1007 @@ config ATH79_MACH_AP121
> +@@ -11,62 +75,1017 @@ config ATH79_MACH_AP121
>  	select ATH79_DEV_M25P80
>  	select ATH79_DEV_USB
>  	select ATH79_DEV_WMAC
> @@ -903,6 +904,16 @@
> +	select ATH79_DEV_M25P80
> +	select ATH79_DEV_WMAC
> +
> ++config ATH79_MACH_ONION_OMEGA
> ++   bool "ONION OMEGA support"
> ++   select SOC_AR933X
> ++   select ATH79_DEV_ETH
> ++   select ATH79_DEV_GPIO_BUTTONS
> ++   select ATH79_DEV_LEDS_GPIO
> ++   select ATH79_DEV_M25P80
> ++   select ATH79_DEV_USB
> ++   select ATH79_DEV_WMAC
> ++
> +config ATH79_MACH_MR600
> +	bool "OpenMesh MR600 board support"
> +	select SOC_AR934X
> @@ -1303,7 +1314,7 @@
> 
>  config ATH79_MACH_UBNT_XM
>  	bool "Ubiquiti Networks XM/UniFi boards"
> -@@ -83,6 +1092,97 @@ config ATH79_MACH_UBNT_XM
> +@@ -83,6 +1102,97 @@ config ATH79_MACH_UBNT_XM
>  	  Say 'Y' here if you want your kernel to support the
>  	  Ubiquiti Networks XM (rev 1.0) board.
> 
> @@ -1401,7 +1412,7 @@
>  endmenu
> 
>  config SOC_AR71XX
> -@@ -124,7 +1224,10 @@ config ATH79_DEV_DSA
> +@@ -124,7 +1234,10 @@ config ATH79_DEV_DSA
>  config ATH79_DEV_ETH
>  	def_bool n
> 
> @@ -1413,7 +1424,7 @@
>  	def_bool n
> 
>  config ATH79_DEV_GPIO_BUTTONS
> -@@ -154,6 +1257,11 @@ config ATH79_PCI_ATH9K_FIXUP
> +@@ -154,6 +1267,11 @@ config ATH79_PCI_ATH9K_FIXUP
>  	def_bool n
> 
>  config ATH79_ROUTERBOOT
> @@ -1427,7 +1438,7 @@
>  endif
> --- a/arch/mips/ath79/Makefile
> +++ b/arch/mips/ath79/Makefile
> -@@ -38,9 +38,122 @@ obj-$(CONFIG_ATH79_ROUTERBOOT)		+= route
> +@@ -38,9 +38,123 @@ obj-$(CONFIG_ATH79_ROUTERBOOT)		+= route
>  #
>  # Machines
>  #
> @@ -1481,6 +1492,7 @@
> +obj-$(CONFIG_ATH79_MACH_NBG460N)	+= mach-nbg460n.o
> +obj-$(CONFIG_ATH79_MACH_OM2P)		+= mach-om2p.o
> +obj-$(CONFIG_ATH79_MACH_OM5P)		+= mach-om5p.o
> ++obj-$(CONFIG_ATH79_MACH_ONION_OMEGA)   += mach-onion-omega.o
> +obj-$(CONFIG_ATH79_MACH_PB42)		+= mach-pb42.o
>  obj-$(CONFIG_ATH79_MACH_PB44)		+= mach-pb44.o
> +obj-$(CONFIG_ATH79_MACH_PB92)		+= mach-pb92.o
> diff --git a/tools/firmware-utils/src/mktplinkfw.c b/tools/firmware-utils/src/mktplinkfw.c
> index 8c543eb..ba5f14d 100644
> --- a/tools/firmware-utils/src/mktplinkfw.c
> +++ b/tools/firmware-utils/src/mktplinkfw.c
> @@ -34,6 +34,7 @@
> #define HWID_ANTMINER_S3	0x04440003
> #define HWID_GL_INET_V1		0x08000001
> #define HWID_GS_OOLITE_V1	0x3C000101
> +#define HWID_ONION_OMEGA    0x04700001
> #define HWID_TL_MR10U_V1	0x00100101
> #define HWID_TL_MR13U_V1	0x00130101
> #define HWID_TL_MR3020_V1	0x30200001
> @@ -425,6 +426,11 @@ static struct board_info boards[] = {
> 		.hw_rev		= 1,
> 		.layout_id	= "8Mlzma",
> 	}, {
> +        .id     = "ONION-OMEGA",
> +        .hw_id      = HWID_ONION_OMEGA,
> +        .hw_rev     = 1,
> +        .layout_id  = "16Mlzma",
> +	}, {
> 		/* terminating entry */
> 	}
> };
>
Karl Palsson July 9, 2015, 1:51 p.m. UTC | #2
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Please consider renaming your "board".  If I understand your website
properly, the module is the Omega, and this boardfile is for the omega
_with_ one of it's "docks"

This "Omega" boardfile would not be usable for someone with a different
dock, with leds/pins in different places.

Further, you've included things like all the usb modules, when the
"Omega Onion" itself doesn't have a usb port, your "dock" does.

Minor: Also, you've got oolite/onion in the wrong order.

Cheers,
Karl P



Boken Lin <bl@onion.io> wrote:
> From: Boken Lin <bl@onion.io>
> 
> Add support for Onion Omega.
> Signed-off-by: Boken Lin <bl@onion.io>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)

iQIcBAEBAgAGBQJVnnxaAAoJEBmotQ/U1cr2OpoQAJow5szL482WILaBiy1DwoXr
gs8T74Q78hmA7Q4hsWZEw3JWsE2W+jbiXXsNhtTqPqDpK+OkvnOfvjK8+BnR+ofu
1oXJvMRuvKg3htpn0+uuTDBxE1ei60MzbOTC7J4cTDw/Hx8TD7jxdiYRlE1l78Tk
yX1GthWCUmzQa5J+QdMQjWWaAQPlHClpDJGUxIHVl5g4Kol9dC6+rb/fkJ1l5qkO
8GKfh3ALuHyDYRhOHz/IOyj1l2bLEriEis343VfA9rl1Xlw6mKfp5gCpa+KcxAlU
89wsf/xKHAgAipE34p0YlvmOAWPVWrRMvWjOi/mJh9tGjuEicyKY5HYQHToxY7J3
y+ZXBgTSvm/64PRIKY2u/0yzDflqUi/N6zU+DQ6/kQ0HLAKfAsNPwOg/sPuf7bFH
C2kUz98LJ0nrbCk+wlb8CywLoMH7MFbzKziwsimPLITfyavw1LFmfFCqQ/uICIpL
C4g14loo828uo/60RtHxBxL14kDn07GCihXUF+hhbooEkE6KxVAApjnrM1zuOkBb
p0YakVT5QT3kl5WCBxBADY1N8PZmNq2nscoYj96oN2nZEHS4TrfbK+K0KjZJGqTT
ilucYTP1ZBqSjASojpbYbcu9EO+MPKODF2GFlXdwIMUiwb0PJA5gSmrABLIId/XD
Ek+9skaJ09Qt0afD7GxM
=VY1p
-----END PGP SIGNATURE-----
diff mbox

Patch

diff --git a/target/linux/ar71xx/base-files/etc/diag.sh b/target/linux/ar71xx/base-files/etc/diag.sh
index ce2b9ba..0015d4c 100644
--- a/target/linux/ar71xx/base-files/etc/diag.sh
+++ b/target/linux/ar71xx/base-files/etc/diag.sh
@@ -167,6 +167,9 @@  get_status_led() {
	om5p-an)
		status_led="om5p:blue:power"
		;;
+    onion-omega)
+        status_led="onion:amber:system"
+        ;;
	pb44)
		status_led="pb44:amber:jump1"
		;;
diff --git a/target/linux/ar71xx/base-files/etc/uci-defaults/02_network b/target/linux/ar71xx/base-files/etc/uci-defaults/02_network
index ec709a0..6e9185c 100755
--- a/target/linux/ar71xx/base-files/etc/uci-defaults/02_network
+++ b/target/linux/ar71xx/base-files/etc/uci-defaults/02_network
@@ -313,6 +313,7 @@  mr600 |\
mr600v2 |\
mr900 |\
mr900v2 |\
+onion-omega |\
rb-411 |\
rb-911g-2hpnd |\
rb-911g-5hpacd |\
diff --git a/target/linux/ar71xx/base-files/lib/ar71xx.sh b/target/linux/ar71xx/base-files/lib/ar71xx.sh
index dd13948..e23ed74 100755
--- a/target/linux/ar71xx/base-files/lib/ar71xx.sh
+++ b/target/linux/ar71xx/base-files/lib/ar71xx.sh
@@ -550,6 +550,9 @@  ar71xx_board_detect() {
	*"OM5P AN")
		name="om5p-an"
		;;
+    *"Onion Omega")
+        name="onion-omega"
+        ;;
	*PB42)
		name="pb42"
		;;
diff --git a/target/linux/ar71xx/base-files/lib/upgrade/platform.sh b/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
index 73d8b0d..b045a33 100755
--- a/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
@@ -312,6 +312,7 @@  platform_check_image() {
	gl-inet | \
	mc-mac1200r | \
	oolite | \
+    onion-omega | \
	smart-300 | \
	tl-mr10u | \
	tl-mr11u | \
diff --git a/target/linux/ar71xx/config-3.18 b/target/linux/ar71xx/config-3.18
index 02857d5..388cb2b 100644
--- a/target/linux/ar71xx/config-3.18
+++ b/target/linux/ar71xx/config-3.18
@@ -86,6 +86,7 @@  CONFIG_ATH79_MACH_NBG460N=y
CONFIG_ATH79_MACH_NBG6716=y
CONFIG_ATH79_MACH_OM2P=y
CONFIG_ATH79_MACH_OM5P=y
+CONFIG_ATH79_MACH_ONION_OMEGA=y
CONFIG_ATH79_MACH_PB42=y
CONFIG_ATH79_MACH_PB44=y
CONFIG_ATH79_MACH_PB92=y
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-onion-omega.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-onion-omega.c
new file mode 100644
index 0000000..177e76f
--- /dev/null
+++ b/target/linux/ar71xx/files/arch/mips/ath79/mach-onion-omega.c
@@ -0,0 +1,85 @@ 
+/*
+ *  Onion Omega board support
+ *
+ *  Copyright (C) 2015 Boken Lin <bl@onion.io>
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+
+#include <linux/gpio.h>
+
+#include <asm/mach-ath79/ath79.h>
+
+#include "dev-eth.h"
+#include "dev-gpio-buttons.h"
+#include "dev-leds-gpio.h"
+#include "dev-m25p80.h"
+#include "dev-usb.h"
+#include "dev-wmac.h"
+#include "machtypes.h"
+
+#define OMEGA_GPIO_LED_SYSTEM   27
+#define OMEGA_GPIO_BTN_RESET    11
+
+#define OMEGA_GPIO_USB_POWER    8
+
+#define OMEGA_KEYS_POLL_INTERVAL    20  /* msecs */
+#define OMEGA_KEYS_DEBOUNCE_INTERVAL    (3 * OMEGA_KEYS_POLL_INTERVAL)
+
+static const char *omega_part_probes[] = {
+    "tp-link",
+    NULL,
+};
+
+static struct flash_platform_data omega_flash_data = {
+    .part_probes    = omega_part_probes,
+};
+
+static struct gpio_led omega_leds_gpio[] __initdata = {
+    {
+        .name       = "onion:amber:system",
+        .gpio       = OMEGA_GPIO_LED_SYSTEM,
+        .active_low = 1,
+    },
+};
+
+static struct gpio_keys_button omega_gpio_keys[] __initdata = {
+    {
+        .desc       = "reset",
+        .type       = EV_KEY,
+        .code       = KEY_RESTART,
+        .debounce_interval = OMEGA_KEYS_DEBOUNCE_INTERVAL,
+        .gpio       = OMEGA_GPIO_BTN_RESET,
+        .active_low = 0,
+    }
+};
+
+static void __init onion_omega_setup(void)
+{
+    u8 *mac = (u8 *) KSEG1ADDR(0x1f01fc00);
+    u8 *ee = (u8 *) KSEG1ADDR(0x1fff1000);
+
+    ath79_register_m25p80(&omega_flash_data);
+    ath79_register_leds_gpio(-1, ARRAY_SIZE(omega_leds_gpio),
+                 omega_leds_gpio);
+    ath79_register_gpio_keys_polled(-1, OMEGA_KEYS_POLL_INTERVAL,
+                    ARRAY_SIZE(omega_gpio_keys),
+                    omega_gpio_keys);
+
+    gpio_request_one(OMEGA_GPIO_USB_POWER,
+             GPIOF_OUT_INIT_HIGH | GPIOF_EXPORT_DIR_FIXED,
+             "USB power");
+    ath79_register_usb();
+
+    ath79_init_mac(ath79_eth0_data.mac_addr, mac, -1);
+
+    ath79_register_mdio(0, 0x0);
+    ath79_register_eth(0);
+
+    ath79_register_wmac(ee, mac);
+}
+
+MIPS_MACHINE(ATH79_MACH_ONION_OMEGA, "ONION-OMEGA", "Onion Omega",
+         onion_omega_setup);
diff --git a/target/linux/ar71xx/generic/profiles/onion.mk b/target/linux/ar71xx/generic/profiles/onion.mk
new file mode 100644
index 0000000..b8db577
--- /dev/null
+++ b/target/linux/ar71xx/generic/profiles/onion.mk
@@ -0,0 +1,16 @@ 
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/OMEGA
+	NAME:=Onion Omega
+	PACKAGES:=kmod-usb-core kmod-usb2 kmod-usb-storage kmod-i2c-core kmod-i2c-gpio-custom kmod-spi-bitbang kmod-spi-dev kmod-spi-gpio kmod-spi-gpio-custom kmod-usb-serial
+endef
+
+define Profile/OMEGA/Description
+	Package set optimized for the Onion Omega Development Platform.
+endef
+$(eval $(call Profile,OMEGA))
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 0351310..2b59a24 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -388,6 +388,15 @@  define Device/mc-mac1200r
endef
TARGET_DEVICES += mc-mac1200r

+define Device/onion-omega
+    $(Device/tplink-16mlzma)
+    BOARDNAME := ONION-OMEGA
+    DEVICE_PROFILE := OMEGA
+    TPLINK_HWID := 0x04700001
+    CONSOLE := ttyATH0,115200
+endef
+TARGET_DEVICES += onion-omega
+
define Device/tl-mr10u-v1
    $(Device/tplink-4mlzma)
    BOARDNAME := TL-MR10U
diff --git a/target/linux/ar71xx/patches-3.18/610-MIPS-ath79-openwrt-machines.patch b/target/linux/ar71xx/patches-3.18/610-MIPS-ath79-openwrt-machines.patch
index 3f22a37..8c12034 100644
--- a/target/linux/ar71xx/patches-3.18/610-MIPS-ath79-openwrt-machines.patch
+++ b/target/linux/ar71xx/patches-3.18/610-MIPS-ath79-openwrt-machines.patch
@@ -1,6 +1,6 @@ 
--- a/arch/mips/ath79/machtypes.h
+++ b/arch/mips/ath79/machtypes.h
-@@ -16,22 +16,193 @@
+@@ -16,22 +16,194 @@

 enum ath79_mach_type {
 	ATH79_MACH_GENERIC = 0,
@@ -73,6 +73,7 @@ 
+	ATH79_MACH_OM2Pv2,		/* OpenMesh OM2Pv2 */
+	ATH79_MACH_OM2P,		/* OpenMesh OM2P */
+	ATH79_MACH_OM5P,		/* OpenMesh OM5P */
++   ATH79_MACH_ONION_OMEGA,     /* ONION OMEGA */
+	ATH79_MACH_PB42,		/* Atheros PB42 */
+	ATH79_MACH_PB92,		/* Atheros PB92 */
+	ATH79_MACH_QIHOO_C301,		/* Qihoo 360 C301 */
@@ -267,7 +268,7 @@ 
 config ATH79_MACH_AP121
 	bool "Atheros AP121 reference board"
 	select SOC_AR933X
-@@ -11,62 +75,1007 @@ config ATH79_MACH_AP121
+@@ -11,62 +75,1017 @@ config ATH79_MACH_AP121
 	select ATH79_DEV_M25P80
 	select ATH79_DEV_USB
 	select ATH79_DEV_WMAC
@@ -903,6 +904,16 @@ 
+	select ATH79_DEV_M25P80
+	select ATH79_DEV_WMAC
+
++config ATH79_MACH_ONION_OMEGA
++   bool "ONION OMEGA support"
++   select SOC_AR933X
++   select ATH79_DEV_ETH
++   select ATH79_DEV_GPIO_BUTTONS
++   select ATH79_DEV_LEDS_GPIO
++   select ATH79_DEV_M25P80
++   select ATH79_DEV_USB
++   select ATH79_DEV_WMAC
++
+config ATH79_MACH_MR600
+	bool "OpenMesh MR600 board support"
+	select SOC_AR934X
@@ -1303,7 +1314,7 @@ 

 config ATH79_MACH_UBNT_XM
 	bool "Ubiquiti Networks XM/UniFi boards"
-@@ -83,6 +1092,97 @@ config ATH79_MACH_UBNT_XM
+@@ -83,6 +1102,97 @@ config ATH79_MACH_UBNT_XM
 	  Say 'Y' here if you want your kernel to support the
 	  Ubiquiti Networks XM (rev 1.0) board.

@@ -1401,7 +1412,7 @@ 
 endmenu

 config SOC_AR71XX
-@@ -124,7 +1224,10 @@ config ATH79_DEV_DSA
+@@ -124,7 +1234,10 @@ config ATH79_DEV_DSA
 config ATH79_DEV_ETH
 	def_bool n

@@ -1413,7 +1424,7 @@ 
 	def_bool n

 config ATH79_DEV_GPIO_BUTTONS
-@@ -154,6 +1257,11 @@ config ATH79_PCI_ATH9K_FIXUP
+@@ -154,6 +1267,11 @@ config ATH79_PCI_ATH9K_FIXUP
 	def_bool n

 config ATH79_ROUTERBOOT
@@ -1427,7 +1438,7 @@ 
 endif
--- a/arch/mips/ath79/Makefile
+++ b/arch/mips/ath79/Makefile
-@@ -38,9 +38,122 @@ obj-$(CONFIG_ATH79_ROUTERBOOT)		+= route
+@@ -38,9 +38,123 @@ obj-$(CONFIG_ATH79_ROUTERBOOT)		+= route
 #
 # Machines
 #
@@ -1481,6 +1492,7 @@ 
+obj-$(CONFIG_ATH79_MACH_NBG460N)	+= mach-nbg460n.o
+obj-$(CONFIG_ATH79_MACH_OM2P)		+= mach-om2p.o
+obj-$(CONFIG_ATH79_MACH_OM5P)		+= mach-om5p.o
++obj-$(CONFIG_ATH79_MACH_ONION_OMEGA)   += mach-onion-omega.o
+obj-$(CONFIG_ATH79_MACH_PB42)		+= mach-pb42.o
 obj-$(CONFIG_ATH79_MACH_PB44)		+= mach-pb44.o
+obj-$(CONFIG_ATH79_MACH_PB92)		+= mach-pb92.o
diff --git a/tools/firmware-utils/src/mktplinkfw.c b/tools/firmware-utils/src/mktplinkfw.c
index 8c543eb..ba5f14d 100644
--- a/tools/firmware-utils/src/mktplinkfw.c
+++ b/tools/firmware-utils/src/mktplinkfw.c
@@ -34,6 +34,7 @@ 
#define HWID_ANTMINER_S3	0x04440003
#define HWID_GL_INET_V1		0x08000001
#define HWID_GS_OOLITE_V1	0x3C000101
+#define HWID_ONION_OMEGA    0x04700001
#define HWID_TL_MR10U_V1	0x00100101
#define HWID_TL_MR13U_V1	0x00130101
#define HWID_TL_MR3020_V1	0x30200001
@@ -425,6 +426,11 @@  static struct board_info boards[] = {
		.hw_rev		= 1,
		.layout_id	= "8Mlzma",
	}, {
+        .id     = "ONION-OMEGA",
+        .hw_id      = HWID_ONION_OMEGA,
+        .hw_rev     = 1,
+        .layout_id  = "16Mlzma",
+	}, {
		/* terminating entry */
	}
};