diff mbox series

[OpenWrt-Devel,4/5] apm821xx: split MBL's rootfs.img.gz into a sysupgrade and factory image

Message ID 4013444f44411f65ecbb30e9c0fdd161057ce994.1532858046.git.chunkeey@gmail.com
State Accepted
Delegated to: John Crispin
Headers show
Series [OpenWrt-Devel,1/5] ipq-wifi: add a note / reminder about upstreaming new board files | expand

Commit Message

Christian Lamparter July 29, 2018, 9:55 a.m. UTC
@vahid-dan reported a issue with extracting the rpi images with
Gnome's Archive Manager:
"Ubuntu Archive Manager cannot extract the file and it just
throws a general error message: "An error occurred while
extracting files".
<https://forum.lede-project.org/t/corrupted-pre-built-v18-06-0-rc2-image-for-rpi>

The MBL's rootfs.img.gz image is generated in much the same way.
Hence this patch preemptively splits the rootfs.img.gz image into
a sysupgrade and a factory image.

Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
---
 target/linux/apm821xx/image/Makefile | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/target/linux/apm821xx/image/Makefile b/target/linux/apm821xx/image/Makefile
index bfc6562431..00ab19602d 100644
--- a/target/linux/apm821xx/image/Makefile
+++ b/target/linux/apm821xx/image/Makefile
@@ -224,11 +224,12 @@  define Device/wd_mybooklive
   KERNEL := kernel-bin | dtb | gzip | uImage gzip
   KERNEL_INITRAMFS := kernel-bin | dtb | gzip | uImage gzip
   BOOT_SIZE := 8
-  IMAGES := rootfs.img.gz kernel.dtb
+  IMAGES := factory.img.gz kernel.dtb sysupgrade.img.gz
   DEVICE_DTB := apollo3g.dtb
   FILESYSTEMS := ext4 squashfs
+  IMAGE/factory.img.gz := boot-script | boot-img | hdd-img | gzip
   IMAGE/kernel.dtb := export-dtb
-  IMAGE/rootfs.img.gz := boot-script | boot-img | hdd-img | gzip | append-metadata
+  IMAGE/sysupgrade.img.gz := boot-script | boot-img | hdd-img | gzip | append-metadata
 endef
 
 TARGET_DEVICES += wd_mybooklive