diff mbox series

[OpenWrt-Devel,3/4,v2] bcm63xx: image: allow to pass the addr to the NAND kernel header

Message ID 3928196.Luy1bn5URE@tool
State Superseded, archived
Headers show
Series [OpenWrt-Devel,1/4,v2] bcm63xx: kernel: add BCM63167 cpuid variant | expand

Commit Message

Daniel González Cabanelas June 4, 2020, 5:46 p.m. UTC
Not all CFEs will need to relocate the kernel (i.e H500-s), thererefore
we'll need to pass a different address and not the LOADER_ENTRY.

Let to pass the addr to the image creation when neccessary.

Signed-off-by: Daniel González Cabanelas <dgcbueu@gmail.com>
---
Changes in v2: refresh

 target/linux/bcm63xx/image/Makefile | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/target/linux/bcm63xx/image/Makefile b/target/linux/bcm63xx/image/Makefile
index c962e531a9..0593dacb44 100644
--- a/target/linux/bcm63xx/image/Makefile
+++ b/target/linux/bcm63xx/image/Makefile
@@ -172,8 +172,8 @@  define Build/cfe-jffs2-kernel
 	$(TOPDIR)/scripts/cfe-bin-header.py \
 		--input-file $@ \
 		--output-file $@-kernel/vmlinux.lz \
-		--load-addr $(LOADER_ENTRY) \
-		--entry-addr $(LOADER_ENTRY)
+		--load-addr $(if $(1),$(1),$(LOADER_ENTRY)) \
+		--entry-addr $(if $(1),$(1),$(LOADER_ENTRY))
 
 	# The JFFS2 partition creation should result in the following
 	# layout: