diff mbox series

[1/3] ltq-adsl: align config more closely to VDSL variants

Message ID 20241019174041.1281093-2-jan@3e8.eu
State Accepted
Delegated to: Hauke Mehrtens
Headers show
Series ltq-adsl: add dsl_cpe_pipe.sh | expand

Commit Message

Jan Hoffmann Oct. 19, 2024, 5:38 p.m. UTC
This is a preparation for adding support for dsl_cpe_pipe.sh with a
similar set of commands compared to the VDSL variant.

The configuration is simplified by using the "--enable-model" option.
Other options are chosen to match the VDSL variant, while also making
sure that previously enabled options stay like that. However, ReTx
options stay disabled, because of incompatibility with the ubus code.

Signed-off-by: Jan Hoffmann <jan@3e8.eu>
---
 package/kernel/lantiq/ltq-adsl/Makefile | 19 ++++++-------------
 1 file changed, 6 insertions(+), 13 deletions(-)
diff mbox series

Patch

diff --git a/package/kernel/lantiq/ltq-adsl/Makefile b/package/kernel/lantiq/ltq-adsl/Makefile
index ac9667493386..992fc09305ff 100644
--- a/package/kernel/lantiq/ltq-adsl/Makefile
+++ b/package/kernel/lantiq/ltq-adsl/Makefile
@@ -10,7 +10,7 @@  include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=ltq-adsl
 PKG_VERSION:=3.24.4.4
-PKG_RELEASE:=4
+PKG_RELEASE:=5
 PKG_SOURCE:=drv_dsl_cpe_api_danube-$(PKG_VERSION).tar.gz
 PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/ltq-dsl-$(BUILD_VARIANT)/drv_dsl_cpe_api-$(PKG_VERSION)
 PKG_SOURCE_URL:=@OPENWRT
@@ -53,20 +53,13 @@  CONFIGURE_ARGS += --enable-kernel-include="$(LINUX_DIR)/include" \
 	--with-max-device="$(IFX_DSL_MAX_DEVICE)" \
 	--with-lines-per-device="$(IFX_DSL_LINES_PER_DEVICE)" \
 	--with-channels-per-line="$(IFX_DSL_CHANNELS_PER_LINE)" \
+	--enable-model=full \
+	--disable-dsl-pm-retx-counters \
+	--disable-dsl-pm-retx-thresholds \
+	--disable-adsl-mib-support \
+	--disable-adsl-trace \
 	--disable-dsl-delt-static \
 	--disable-adsl-led \
-	--enable-dsl-ceoc \
-	--enable-dsl-pm \
-	--enable-dsl-pm-total \
-	--enable-dsl-pm-history \
-	--enable-dsl-pm-showtime \
-	--enable-dsl-pm-channel-counters \
-	--enable-dsl-pm-datapath-counters \
-	--enable-dsl-pm-line-counters \
-	--enable-dsl-pm-channel-thresholds \
-	--enable-dsl-pm-datapath-thresholds \
-	--enable-dsl-pm-line-thresholds \
-	--enable-dsl-pm-optional-parameters \
 	--enable-linux-26 \
 	--enable-kernelbuild="$(LINUX_DIR)" \
 	ARCH=$(LINUX_KARCH)