diff mbox series

[4/4] tegra: trimslice: enable USB HID driver

Message ID 20240515170439.692296-5-tmn505@terefe.re
State Accepted
Delegated to: Hauke Mehrtens
Headers show
Series tegra: assorted fixes | expand

Commit Message

Tomasz Maciej Nowak May 15, 2024, 5:02 p.m. UTC
From: Tomasz Maciej Nowak <tmn505@gmail.com>

Without serial or network access the only option for initial
configuration, is a attached display with USB keyboard, but the keyboard
driver needs to be installed first. So enable keyboard driver by default
to avoid this issue.

Signed-off-by: Tomasz Maciej Nowak <tmn505@gmail.com>
---
 target/linux/tegra/image/Makefile | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/target/linux/tegra/image/Makefile b/target/linux/tegra/image/Makefile
index 609cf5dd38f9..da0b3813bb2f 100644
--- a/target/linux/tegra/image/Makefile
+++ b/target/linux/tegra/image/Makefile
@@ -44,7 +44,7 @@  define Device/compulab_trimslice
   DEVICE_MODEL := TrimSlice
   DEVICE_DTS := tegra20-trimslice
   DEVICE_PACKAGES := kmod-leds-gpio kmod-r8169 kmod-rt2800-usb \
-	kmod-rtc-em3027 kmod-usb-storage wpad-basic-mbedtls
+	kmod-rtc-em3027 kmod-usb-hid kmod-usb-storage wpad-basic-mbedtls
   UBOOT := trimslice-mmc
 endef
 TARGET_DEVICES += compulab_trimslice