diff mbox series

kernel: kmod-phy-smsc: add dependency on crc16

Message ID 20240328170311.13915-1-tmn505@terefe.re
State Superseded
Headers show
Series kernel: kmod-phy-smsc: add dependency on crc16 | expand

Commit Message

Tomasz Maciej Nowak March 28, 2024, 5:02 p.m. UTC
From: Tomasz Maciej Nowak <tmn505@gmail.com>

Introduced WoL feature needs CRC16 support.

Signed-off-by: Tomasz Maciej Nowak <tmn505@gmail.com>
---
 package/kernel/linux/modules/netdevices.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Robert Marko March 29, 2024, 8:57 a.m. UTC | #1
On Thu, 28 Mar 2024 at 18:03, Tomasz Maciej Nowak <tmn505@terefe.re> wrote:
>
> From: Tomasz Maciej Nowak <tmn505@gmail.com>
>
> Introduced WoL feature needs CRC16 support.
>
> Signed-off-by: Tomasz Maciej Nowak <tmn505@gmail.com>
> ---
>  package/kernel/linux/modules/netdevices.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/package/kernel/linux/modules/netdevices.mk b/package/kernel/linux/modules/netdevices.mk
> index af1d8b485e00..724f35df74a2 100644
> --- a/package/kernel/linux/modules/netdevices.mk
> +++ b/package/kernel/linux/modules/netdevices.mk
> @@ -363,7 +363,7 @@ define KernelPackage/phy-smsc
>     SUBMENU:=$(NETWORK_DEVICES_MENU)
>     TITLE:=SMSC PHY driver
>     KCONFIG:=CONFIG_SMSC_PHY
> -   DEPENDS:=+kmod-libphy
> +   DEPENDS:=+kmod-libphy +!LINUX_5_15||!LINUX_6_1:kmod-lib-crc16
I would prefer depending on 6.6 for the kmod, not the other way around.

Regards,
Robert

>     FILES:=$(LINUX_DIR)/drivers/net/phy/smsc.ko
>     AUTOLOAD:=$(call AutoProbe,smsc)
>  endef
> --
> 2.44.0
>
>
> _______________________________________________
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://lists.openwrt.org/mailman/listinfo/openwrt-devel
Tomasz Maciej Nowak March 29, 2024, 2:12 p.m. UTC | #2
W dniu 29.03.2024 o 09:57, Robert Marko pisze:
> On Thu, 28 Mar 2024 at 18:03, Tomasz Maciej Nowak <tmn505@terefe.re> wrote:
>>
>> From: Tomasz Maciej Nowak <tmn505@gmail.com>
>>
>> Introduced WoL feature needs CRC16 support.
>>
>> Signed-off-by: Tomasz Maciej Nowak <tmn505@gmail.com>
>> ---
>>  package/kernel/linux/modules/netdevices.mk | 2 +-
>>  1 file changed, 1 insertion(+), 1 deletion(-)
>>
>> diff --git a/package/kernel/linux/modules/netdevices.mk b/package/kernel/linux/modules/netdevices.mk
>> index af1d8b485e00..724f35df74a2 100644
>> --- a/package/kernel/linux/modules/netdevices.mk
>> +++ b/package/kernel/linux/modules/netdevices.mk
>> @@ -363,7 +363,7 @@ define KernelPackage/phy-smsc
>>     SUBMENU:=$(NETWORK_DEVICES_MENU)
>>     TITLE:=SMSC PHY driver
>>     KCONFIG:=CONFIG_SMSC_PHY
>> -   DEPENDS:=+kmod-libphy
>> +   DEPENDS:=+kmod-libphy +!LINUX_5_15||!LINUX_6_1:kmod-lib-crc16
> I would prefer depending on 6.6 for the kmod, not the other way around.

I do prefer this version, otherwise if new major version is introduced and we
still will have three kernel versions, like at the moment, someone adding support
for it would need to add it to dependency list of this module. This would
naturally increase diffstat meaning more lines to review, while in this variant
other kernel version should naturally go away when it's dropped.

Nonetheless, v2 sent.
 
> 
> Regards,
> Robert

Regards
Elliott Mitchell March 29, 2024, 5:44 p.m. UTC | #3
On Fri, Mar 29, 2024 at 09:57:04AM +0100, Robert Marko wrote:
> On Thu, 28 Mar 2024 at 18:03, Tomasz Maciej Nowak <tmn505@terefe.re> wrote:
> >
> > From: Tomasz Maciej Nowak <tmn505@gmail.com>
> >
> > Introduced WoL feature needs CRC16 support.
> >
> > Signed-off-by: Tomasz Maciej Nowak <tmn505@gmail.com>
> > ---
> >  package/kernel/linux/modules/netdevices.mk | 2 +-
> >  1 file changed, 1 insertion(+), 1 deletion(-)
> >
> > diff --git a/package/kernel/linux/modules/netdevices.mk b/package/kernel/linux/modules/netdevices.mk
> > index af1d8b485e00..724f35df74a2 100644
> > --- a/package/kernel/linux/modules/netdevices.mk
> > +++ b/package/kernel/linux/modules/netdevices.mk
> > @@ -363,7 +363,7 @@ define KernelPackage/phy-smsc
> >     SUBMENU:=$(NETWORK_DEVICES_MENU)
> >     TITLE:=SMSC PHY driver
> >     KCONFIG:=CONFIG_SMSC_PHY
> > -   DEPENDS:=+kmod-libphy
> > +   DEPENDS:=+kmod-libphy +!LINUX_5_15||!LINUX_6_1:kmod-lib-crc16

> I would prefer depending on 6.6 for the kmod, not the other way around.

I am *very* strongly of the opposite opinion.  Issue is detecting 5.15
and 6.1 is a stable state.  At a future point when 6.10/6.11.6.12/7.0/7.1
are added, no additional maintenance is required if 5.15 and 6.1 are
detected.  Whereas if 6.6 is detected, this *must* be adjusted when the
next kernel version shows up.

The one advantage is by *forcing* maintenance sooner, the construct is
likely to be removed sooner.  Ultimately turns into an issue of which is
more concerning, having this hang around longer, versus making this an
urgent issue in the near future.
diff mbox series

Patch

diff --git a/package/kernel/linux/modules/netdevices.mk b/package/kernel/linux/modules/netdevices.mk
index af1d8b485e00..724f35df74a2 100644
--- a/package/kernel/linux/modules/netdevices.mk
+++ b/package/kernel/linux/modules/netdevices.mk
@@ -363,7 +363,7 @@  define KernelPackage/phy-smsc
    SUBMENU:=$(NETWORK_DEVICES_MENU)
    TITLE:=SMSC PHY driver
    KCONFIG:=CONFIG_SMSC_PHY
-   DEPENDS:=+kmod-libphy
+   DEPENDS:=+kmod-libphy +!LINUX_5_15||!LINUX_6_1:kmod-lib-crc16
    FILES:=$(LINUX_DIR)/drivers/net/phy/smsc.ko
    AUTOLOAD:=$(call AutoProbe,smsc)
 endef