diff mbox series

image: build dtb with host compiler for image builder

Message ID 20240227181321.114954-1-tmn505@terefe.re
State New
Headers show
Series image: build dtb with host compiler for image builder | expand

Commit Message

Tomasz Maciej Nowak Feb. 27, 2024, 6:13 p.m. UTC
From: Tomasz Maciej Nowak <tmn505@gmail.com>

Device tree blobs are arch agnostic, so we don't need to cross compile
them.

Signed-off-by: Tomasz Maciej Nowak <tmn505@gmail.com>
---
 include/image.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/include/image.mk b/include/image.mk
index 4b6acbe1aad6..3a92fb0c8cab 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -180,7 +180,7 @@  endef
 # $(3) extra CPP flags
 # $(4) extra DTC flags
 define Image/BuildDTB/sub
-	$(TARGET_CROSS)cpp -nostdinc -x assembler-with-cpp \
+	$(if IB, , $(TARGET_CROSS))cpp -nostdinc -x assembler-with-cpp \
 		$(DTS_CPPFLAGS) \
 		-I$(DTS_DIR) \
 		-I$(DTS_DIR)/include \