diff mbox series

realtek: fix Netgear GS110TPP OEM install

Message ID 20240217140340.2489993-1-bjorn@mork.no
State Accepted
Delegated to: Sander Vanheule
Headers show
Series realtek: fix Netgear GS110TPP OEM install | expand

Commit Message

Bjørn Mork Feb. 17, 2024, 2:03 p.m. UTC
Recent OEM firmware versions test the version number embedded in the uimage
"name" header field. The exact restricton is unknown, but "7.0.8.4" seems
to be the lowest number accepted on a GS110TPPv1 which already has that
version or higher.

A "9.9.9.9" version is accepted as valid by the GS110TPPv1 OEM firmware,
and considered both unique enough to identify an OpenWrt image and
moderately future proof against OEM version bumps.

This change is also boot tested on a GS108Tv3 with

 "BOOT Loader Version 1.0.0.2 (2018-08-31 17:05:26 UTC)"

to verify that it doesn't break boot on older hardware.

Link: https://forum.openwrt.org/t/netgear-gs108tv3-gs110tpv3-gs110tpp-switch-support/72510/58
Signed-off-by: Bjørn Mork <bjorn@mork.no>
---
 target/linux/realtek/image/rtl838x.mk | 1 +
 1 file changed, 1 insertion(+)

Comments

Sander Vanheule Feb. 18, 2024, 9 a.m. UTC | #1
Hi Bjørn,

On Sat, 2024-02-17 at 15:03 +0100, Bjørn Mork wrote:
> Recent OEM firmware versions test the version number embedded in the uimage
> "name" header field. The exact restricton is unknown, but "7.0.8.4" seems
> to be the lowest number accepted on a GS110TPPv1 which already has that
> version or higher.
> 
> A "9.9.9.9" version is accepted as valid by the GS110TPPv1 OEM firmware,
> and considered both unique enough to identify an OpenWrt image and
> moderately future proof against OEM version bumps.
> 
> This change is also boot tested on a GS108Tv3 with
> 
>  "BOOT Loader Version 1.0.0.2 (2018-08-31 17:05:26 UTC)"
> 
> to verify that it doesn't break boot on older hardware.
> 
> Link:
> https://forum.openwrt.org/t/netgear-gs108tv3-gs110tpv3-gs110tpp-switch-support/72510/58
> Signed-off-by: Bjørn Mork <bjorn@mork.no>
> ---

Thanks for helping out with this. I've merged the patch to main and backported it to the
23.05 branch.

Best,
Sander
diff mbox series

Patch

diff --git a/target/linux/realtek/image/rtl838x.mk b/target/linux/realtek/image/rtl838x.mk
index 60249ff2fdb4..19a40f1f61ba 100644
--- a/target/linux/realtek/image/rtl838x.mk
+++ b/target/linux/realtek/image/rtl838x.mk
@@ -168,6 +168,7 @@  define Device/netgear_nge
   SOC := rtl8380
   IMAGE_SIZE := 14848k
   UIMAGE_MAGIC := 0x4e474520
+  UIMAGE_NAME := 9.9.9.9
   DEVICE_VENDOR := NETGEAR
 endef