diff mbox series

[2/2] qoriq: pad rootfs with zeros so that sysupgrade -n resets the overlayfs

Message ID 20231201214949.2333622-2-russell@personaltelco.net
State Accepted, archived
Headers show
Series [1/2] qoriq: add missing compat_version to allow sysupgrade to save old config | expand

Commit Message

Russell Senior Dec. 1, 2023, 9:48 p.m. UTC
Presently, sysupgrade -n does *not* reset the overlayfs, retaining unwanted filesystem
contents. Adding PADDING=1 in front of gen_image_generic.sh in image/Makefile ensures
that the overlayfs is recreated on firstboot.

Signed-off-by: Russell Senior <russell@personaltelco.net>
---
 target/linux/qoriq/image/Makefile | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/target/linux/qoriq/image/Makefile b/target/linux/qoriq/image/Makefile
index ec46e4d543..69fea238b5 100644
--- a/target/linux/qoriq/image/Makefile
+++ b/target/linux/qoriq/image/Makefile
@@ -13,7 +13,7 @@  define Build/sdcard-img
                 $(foreach dtb,$(DEVICE_DTS),$(CP) $(KDIR)/image-$(dtb).dtb $@.boot), \
                 $(CP) $(KDIR)/image-/*.dtb $@.boot)
 
-        $(SCRIPT_DIR)/gen_image_generic.sh \
+        PADDING=1 $(SCRIPT_DIR)/gen_image_generic.sh \
                 $@ \
                 $(CONFIG_TARGET_KERNEL_PARTSIZE) $@.boot \
                 $(CONFIG_TARGET_ROOTFS_PARTSIZE) $(IMAGE_ROOTFS) \