diff mbox series

build: replace SourceName with PKG_NAME compile unit name

Message ID 20230908120008.66739-1-fe@dev.tdt.de
State Superseded
Headers show
Series build: replace SourceName with PKG_NAME compile unit name | expand

Commit Message

Florian Eckert Sept. 8, 2023, noon UTC
Currently, the same information is stored at the Packages.manifest in
the 'Package:' variable and also additionally in the 'SourceName:' variable.

So we have for Packages.manifest for strongswan-charon-cmd:
```
Package: strongswan-charon-cmd
Version: 5.9.11-1

SourceName: strongswan-charon-cmd
License: GPL-2.0-or-later
Section: net
```

This is not correct. Several installable packages are built from the same
strongswan source. Therefore it makes more sense that the source name is
really the source name. In this case the it is 'strongswan'.

After this change the Packages.manifest for strongswan-charon-cmd:
```
Package: strongswan-charon-cmd
Version: 5.9.11-1

SourceName: strongswan
License: GPL-2.0-or-later
Section: net
```

In summary. The 'Package' name is the name of the package to be installed
on the target system. The 'SourceName' is the compile unit from which the
package was build from. This must be the same for all installable
packages built from the same compile unit. This commit fixes that.

Signed-off-by: Florian Eckert <fe@dev.tdt.de>
---
 include/package-ipkg.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index aeb9ed746a..f4cbe59246 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -225,7 +225,7 @@  $$(call addfield,Depends,$$(Package/$(1)/DEPENDS)
 )$$(call addfield,Provides,$$(call mergelist,$$(filter-out $(1)$$(ABIV_$(1)),$(PROVIDES)$$(if $$(ABIV_$(1)), $(1) $(foreach provide,$(PROVIDES),$(provide)$$(ABIV_$(1))))))
 )$$(call addfield,Alternatives,$$(call mergelist,$(ALTERNATIVES))
 )$$(call addfield,Source,$(SOURCE)
-)$$(call addfield,SourceName,$(1)
+)$$(call addfield,SourceName,$(PKG_NAME)
 )$$(call addfield,License,$(LICENSE)
 )$$(call addfield,LicenseFiles,$(LICENSE_FILES)
 )$$(call addfield,Section,$(SECTION)