diff mbox series

[22.03] ath79: image: allow changing kernel option in mkubntimage

Message ID 20230816182845.7705-1-tmn505@terefe.re
State Accepted
Delegated to: Hauke Mehrtens
Headers show
Series [22.03] ath79: image: allow changing kernel option in mkubntimage | expand

Commit Message

Tomasz Maciej Nowak Aug. 16, 2023, 6:28 p.m. UTC
From: Tomasz Maciej Nowak <tmn505@gmail.com>

Backport didn't include changes to mkubntimage invocation, which allowed
to pass arguments. This in result produces broken routerstation factory
images, which have kernel embedded as kernel partition instead of LZMA
loader.

Fixes: #13260
Fixes: 8e09f9ffc3cc ("ath79: switch some RedBoot based devices to OKLI loader")
Signed-off-by: Tomasz Maciej Nowak <tmn505@gmail.com>
---
 target/linux/ath79/image/common-ubnt.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/target/linux/ath79/image/common-ubnt.mk b/target/linux/ath79/image/common-ubnt.mk
index 625f0b4f3f12..76d6de000ba6 100644
--- a/target/linux/ath79/image/common-ubnt.mk
+++ b/target/linux/ath79/image/common-ubnt.mk
@@ -10,7 +10,7 @@  UBNT_REVISION := $(VERSION_DIST)-$(REVISION)
 define Build/mkubntimage
 	-$(STAGING_DIR_HOST)/bin/mkfwimage -B $(UBNT_BOARD) \
 		-v $(UBNT_TYPE).$(UBNT_CHIP).v6.0.0-$(VERSION_DIST)-$(REVISION) \
-		-k $(IMAGE_KERNEL) -r $@ -o $@
+		-k $(if $(1),$(1),$(IMAGE_KERNEL)) -r $@ -o $@
 endef
 
 define Build/mkubntimage2