diff mbox series

[2/3] bcm53xx: add support for ASUS RT-AC3100

Message ID 20230810122310.387752-2-arinc.unal@arinc9.com
State Accepted
Headers show
Series [1/3] bcm53xx: backport DT changes for ASUS RT-AC3100 queued for v6.6 | expand

Commit Message

Arınç ÜNAL Aug. 10, 2023, 12:23 p.m. UTC
ASUS RT-AC3100 is ASUS RT-AC88U without the external switch.

OpenWrt forum users effortless and ktmakwana have confirmed that there are
revisions with either 4366b1 or 4366c0 wireless chips.

Therefore, include firmware for 4366b1 along with 4366c0. This way, all
hardware revisions of the router will be supported by having brcmfmac use
the firmware file for the wireless chip it detects.

Signed-off-by: Arınç ÜNAL <arinc.unal@arinc9.com>
---
 target/linux/bcm53xx/image/Makefile | 8 ++++++++
 1 file changed, 8 insertions(+)
diff mbox series

Patch

diff --git a/target/linux/bcm53xx/image/Makefile b/target/linux/bcm53xx/image/Makefile
index b1eb4277b7..5158b432b3 100644
--- a/target/linux/bcm53xx/image/Makefile
+++ b/target/linux/bcm53xx/image/Makefile
@@ -159,6 +159,14 @@  define Device/asus
   IMAGE/trx := append-ubi | trx-nand | asus-trx
 endef
 
+define Device/asus_rt-ac3100
+  $(call Device/asus)
+  DEVICE_MODEL := RT-AC3100
+  DEVICE_PACKAGES := $(BRCMFMAC_4366B1) $(BRCMFMAC_4366C0) $(USB3_PACKAGES)
+  ASUS_PRODUCTID := RT-AC3100
+endef
+TARGET_DEVICES += asus_rt-ac3100
+
 define Device/asus_rt-ac56u
   $(call Device/asus)
   DEVICE_MODEL := RT-AC56U