diff mbox series

build: replace SourceName with PKG_NAME

Message ID 20230725122624.3231282-1-fe@dev.tdt.de
State Superseded
Delegated to: Hauke Mehrtens
Headers show
Series build: replace SourceName with PKG_NAME | expand

Commit Message

Florian Eckert July 25, 2023, 12:26 p.m. UTC
Currently, the same information is stored in the Packages.manifest in
the 'Package:' variable and also additionally in the 'SourceName:' variable.

Packages.manifest for strongswan-charon-cmd (before):

  Package: strongswan-charon-cmd
  Version: 5.9.11-1
  ...
  SourceName: strongswan-charon-cmd
  License: GPL-2.0-or-later
  Section: net

This is not correct. Several install packages are built from the
strongswan source. Therefore it makes more sense that the source name is
really the source name. In this case it is 'strongswan' $PKG_NAME.

Packages.manifest for strongswan-charon-cmd (after):

  Package: strongswan-charon-cmd
  Version: 5.9.11-1
  ...
  SourceName: strongswan
  License: GPL-2.0-or-later
  Section: net

Signed-off-by: Florian Eckert <fe@dev.tdt.de>
---
 include/package-ipkg.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index 3063a86a28..afa2b81eb9 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -179,7 +179,7 @@  $$(call addfield,Depends,$$(Package/$(1)/DEPENDS)
 )$$(call addfield,Provides,$$(call mergelist,$$(filter-out $(1)$$(ABIV_$(1)),$(PROVIDES)$$(if $$(ABIV_$(1)), $(1) $(foreach provide,$(PROVIDES),$(provide)$$(ABIV_$(1))))))
 )$$(call addfield,Alternatives,$$(call mergelist,$(ALTERNATIVES))
 )$$(call addfield,Source,$(SOURCE)
-)$$(call addfield,SourceName,$(1)
+)$$(call addfield,SourceName,$(PKG_NAME)
 )$$(call addfield,License,$(LICENSE)
 )$$(call addfield,LicenseFiles,$(LICENSE_FILES)
 )$$(call addfield,Section,$(SECTION)