diff mbox series

firmware-utils: add required PKG_BUILD_DEPENDS

Message ID 20230601154030.10407-1-zajec5@gmail.com
State Not Applicable
Delegated to: Rafał Miłecki
Headers show
Series firmware-utils: add required PKG_BUILD_DEPENDS | expand

Commit Message

Rafał Miłecki June 1, 2023, 3:40 p.m. UTC
From: Rafał Miłecki <rafal@milecki.pl>

This project provides a lot of independent utils. Most of them don't
depend on SSL (or zlib). Build process however compiles all of them
including those few that require SSL/ZLIB.

To make copmilation step always succeed it's needed to specify build
time dependencies.

Runtime dependencies will be handled per-package (if we ever package one
of those needing SSL/ZLIB).

This fixes:
-- Could NOT find ZLIB (missing: ZLIB_LIBRARY ZLIB_INCLUDE_DIR)
-- Could NOT find OpenSSL, try to set the path to OpenSSL root folder in the system variable OPENSSL_ROOT_DIR (missing: OPENSSL_CRYPTO_LIBRARY OPENSSL_INCLUDE_DIR)
CMake Error at CMakeLists.txt:9 (MESSAGE):
  Unable to find zlib library.

Reported-by: Hauke Mehrtens <hauke@hauke-m.de>
Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
---
 package/utils/firmware-utils/Makefile | 2 ++
 1 file changed, 2 insertions(+)

Comments

Rafał Miłecki July 21, 2023, 5:43 a.m. UTC | #1
On 1.06.2023 17:40, Rafał Miłecki wrote:
> From: Rafał Miłecki <rafal@milecki.pl>
> 
> This project provides a lot of independent utils. Most of them don't
> depend on SSL (or zlib). Build process however compiles all of them
> including those few that require SSL/ZLIB.
> 
> To make copmilation step always succeed it's needed to specify build
> time dependencies.
> 
> Runtime dependencies will be handled per-package (if we ever package one
> of those needing SSL/ZLIB).
> 
> This fixes:
> -- Could NOT find ZLIB (missing: ZLIB_LIBRARY ZLIB_INCLUDE_DIR)
> -- Could NOT find OpenSSL, try to set the path to OpenSSL root folder in the system variable OPENSSL_ROOT_DIR (missing: OPENSSL_CRYPTO_LIBRARY OPENSSL_INCLUDE_DIR)
> CMake Error at CMakeLists.txt:9 (MESSAGE):
>    Unable to find zlib library.

While I like my own commit description a lot ;) this PATCH been
obsoleted by the

commit 6f607ba043cdc996cd113b8dc25b6965dc1d9a41
Author: Tianling Shen <cnsztl@immortalwrt.org>
Date:   Thu Jun 1 17:35:16 2023 +0800

     firmware-utils: add missing build dependencies
diff mbox series

Patch

diff --git a/package/utils/firmware-utils/Makefile b/package/utils/firmware-utils/Makefile
index f49cca01bb..2f77d001ff 100644
--- a/package/utils/firmware-utils/Makefile
+++ b/package/utils/firmware-utils/Makefile
@@ -11,6 +11,8 @@  PKG_SOURCE_DATE:=2023-05-18
 PKG_SOURCE_VERSION:=02cdbc6a4d61605c008efef09162f772f553fcde
 PKG_MIRROR_HASH:=f5188fc38bb03ddbcc34763ff049597e2d8af98c0854910dc87f10e5927096e2
 
+PKG_BUILD_DEPENDS:=openssl zlib
+
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/cmake.mk