diff mbox series

[PATCH-22.03,04/10] ipq40xx: chromium: Enable kmod-ramoops by default

Message ID 20230407132348.75330-4-openwrt@aiyionpri.me
State Rejected
Delegated to: Petr Štetiar
Headers show
Series [PATCH-22.03,01/10] ipq40xx: Support Chromium OS image-type creation | expand

Commit Message

Jan-Niklas Burfeind April 7, 2023, 1:23 p.m. UTC
From: Brian Norris <computersforpeace@gmail.com>

Chromium devices (like Google WiFi) have ramoops memory reserved by the
bootloader. Let's enable the ramoops kernel module by default, so we get
better crash logging.

Signed-off-by: Brian Norris <computersforpeace@gmail.com>
Signed-off-by: Jan-Niklas Burfeind <git@aiyionpri.me>
(updated makefile after missing drop commit)
---
 target/linux/ipq40xx/image/chromium.mk | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/target/linux/ipq40xx/image/chromium.mk b/target/linux/ipq40xx/image/chromium.mk
index 2c8457dcfb..e17398929e 100644
--- a/target/linux/ipq40xx/image/chromium.mk
+++ b/target/linux/ipq40xx/image/chromium.mk
@@ -30,7 +30,11 @@  define Device/google_wifi
 	KERNEL_NAME := zImage
 	IMAGES += factory.bin
 	IMAGE/factory.bin := cros-gpt | append-kernel-part | append-rootfs
+	# Note: Chromium/Depthcharge-based bootloaders insert a reserved-memory
+	# ramoops node into the Device Tree automatically, so we can use
+	# kmod-ramoops.
 	DEVICE_PACKAGES := ipq-wifi-google_wifi partx-utils mkf2fs e2fsprogs \
-			   kmod-fs-ext4 kmod-fs-f2fs kmod-google-firmware
+			   kmod-fs-ext4 kmod-fs-f2fs kmod-google-firmware \
+			   kmod-ramoops
 endef
 TARGET_DEVICES += google_wifi