diff mbox series

[3/3] ath79: combine UniFi AC dual firmware-partitions

Message ID 20221226213642.17463-3-mail@david-bauer.net
State Deferred
Delegated to: David Bauer
Headers show
Series [1/3] ath79: combine OCEDO dual firmware-partitions | expand

Commit Message

David Bauer Dec. 26, 2022, 9:36 p.m. UTC
In order to maximize the available space on UniFi AC boards using a
dual-image partition layout, combine the two OS partitions into a single
partition.

This allows users to access more usable space for additional packages.

Don't limit the usable image size to the size of a single OS partition.
The initial installation has to be done with an older version of OpenWrt
in case the generated image exceeds the space of a single kernel
partition in the future.

Signed-off-by: David Bauer <mail@david-bauer.net>
---
 target/linux/ath79/dts/qca9563_ubnt_unifiac.dtsi | 9 ++-------
 target/linux/ath79/image/generic-ubnt.mk         | 2 +-
 2 files changed, 3 insertions(+), 8 deletions(-)
diff mbox series

Patch

diff --git a/target/linux/ath79/dts/qca9563_ubnt_unifiac.dtsi b/target/linux/ath79/dts/qca9563_ubnt_unifiac.dtsi
index 2e407c3486..6704ec983b 100644
--- a/target/linux/ath79/dts/qca9563_ubnt_unifiac.dtsi
+++ b/target/linux/ath79/dts/qca9563_ubnt_unifiac.dtsi
@@ -69,17 +69,12 @@ 
 			};
 
 			partition@70000 {
+				/* Combine kernel0 & kernel1 */
 				label = "firmware";
-				reg = <0x070000 0x790000>;
+				reg = <0x070000 0xf20000>;
 				compatible = "denx,uimage";
 			};
 
-			partition@800000 {
-				label = "kernel1";
-				reg = <0x800000 0x790000>;
-				read-only;
-			};
-
 			partition@f90000 {
 				label = "bs";
 				reg = <0xf90000 0x020000>;
diff --git a/target/linux/ath79/image/generic-ubnt.mk b/target/linux/ath79/image/generic-ubnt.mk
index bed043c3a7..8eeaa8de3e 100644
--- a/target/linux/ath79/image/generic-ubnt.mk
+++ b/target/linux/ath79/image/generic-ubnt.mk
@@ -229,7 +229,7 @@  TARGET_DEVICES += ubnt_unifi-ap-lr
 define Device/ubnt_unifiac
   DEVICE_VENDOR := Ubiquiti
   SOC := qca9563
-  IMAGE_SIZE := 7744k
+  IMAGE_SIZE := 15488k
   DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca988x-ct
 endef