diff mbox series

[1/3] ath79: combine OCEDO dual firmware-partitions

Message ID 20221226213642.17463-1-mail@david-bauer.net
State Deferred
Delegated to: David Bauer
Headers show
Series [1/3] ath79: combine OCEDO dual firmware-partitions | expand

Commit Message

David Bauer Dec. 26, 2022, 9:36 p.m. UTC
In order to maximize the available space on OCEDO boards using a
dual-image partition layout, combine the two OS partitions into a single
partition.

This allows users to access more usable space for additional packages.

Don't limit the usable image size to the size of a single OS partition.
The initial installation has to be done with an older version of OpenWrt
in case the generated image exceeds the space of a single OS
partition in the future.

Signed-off-by: David Bauer <mail@david-bauer.net>
---
 target/linux/ath79/dts/ar9344_ocedo_raccoon.dts | 9 ++-------
 target/linux/ath79/dts/qca9558_ocedo_koala.dts  | 9 ++-------
 target/linux/ath79/dts/qca9558_ocedo_ursus.dts  | 9 ++-------
 target/linux/ath79/image/generic.mk             | 6 +++---
 4 files changed, 9 insertions(+), 24 deletions(-)
diff mbox series

Patch

diff --git a/target/linux/ath79/dts/ar9344_ocedo_raccoon.dts b/target/linux/ath79/dts/ar9344_ocedo_raccoon.dts
index 8678315a44..11205413f4 100644
--- a/target/linux/ath79/dts/ar9344_ocedo_raccoon.dts
+++ b/target/linux/ath79/dts/ar9344_ocedo_raccoon.dts
@@ -91,15 +91,10 @@ 
 			};
 
 			partition@50000 {
+				/* Dual-Flash layout combined */
 				compatible = "denx,uimage";
 				label = "firmware";
-				reg = <0x050000 0x740000>;
-			};
-
-			partition@790000 {
-				label = "vendor";
-				reg = <0x790000 0x740000>;
-				read-only;
+				reg = <0x050000 0xe80000>;
 			};
 
 			partition@ed0000 {
diff --git a/target/linux/ath79/dts/qca9558_ocedo_koala.dts b/target/linux/ath79/dts/qca9558_ocedo_koala.dts
index 8441e5c9a3..85fd43699e 100644
--- a/target/linux/ath79/dts/qca9558_ocedo_koala.dts
+++ b/target/linux/ath79/dts/qca9558_ocedo_koala.dts
@@ -84,15 +84,10 @@ 
 			};
 
 			partition@50000 {
+				/* Dual-Flash layout combined */
 				compatible = "denx,uimage";
 				label = "firmware";
-				reg = <0x050000 0x740000>;
-			};
-
-			partition@790000 {
-				label = "vendor";
-				reg = <0x790000 0x740000>;
-				read-only;
+				reg = <0x050000 0xe80000>;
 			};
 
 			partition@ed0000 {
diff --git a/target/linux/ath79/dts/qca9558_ocedo_ursus.dts b/target/linux/ath79/dts/qca9558_ocedo_ursus.dts
index e99059df04..be958d19a0 100644
--- a/target/linux/ath79/dts/qca9558_ocedo_ursus.dts
+++ b/target/linux/ath79/dts/qca9558_ocedo_ursus.dts
@@ -55,15 +55,10 @@ 
 			};
 
 			partition@50000 {
+				/* Dual-Flash layout combined */
 				compatible = "denx,uimage";
 				label = "firmware";
-				reg = <0x050000 0x740000>;
-			};
-
-			partition@790000 {
-				label = "vendor";
-				reg = <0x790000 0x740000>;
-				read-only;
+				reg = <0x050000 0xe80000>;
 			};
 
 			partition@ed0000 {
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index b2e1d70403..7b237b0b6c 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -1884,7 +1884,7 @@  define Device/ocedo_koala
   DEVICE_MODEL := Koala
   DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca988x-ct
   SUPPORTED_DEVICES += koala
-  IMAGE_SIZE := 7424k
+  IMAGE_SIZE := 14848k
 endef
 TARGET_DEVICES += ocedo_koala
 
@@ -1892,7 +1892,7 @@  define Device/ocedo_raccoon
   SOC := ar9344
   DEVICE_VENDOR := Ocedo
   DEVICE_MODEL := Raccoon
-  IMAGE_SIZE := 7424k
+  IMAGE_SIZE := 14848k
 endef
 TARGET_DEVICES += ocedo_raccoon
 
@@ -1901,7 +1901,7 @@  define Device/ocedo_ursus
   DEVICE_VENDOR := Ocedo
   DEVICE_MODEL := Ursus
   DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca988x-ct
-  IMAGE_SIZE := 7424k
+  IMAGE_SIZE := 14848k
 endef
 TARGET_DEVICES += ocedo_ursus