diff mbox series

ipq40xx: pakedge_wr-1: convert to DSA

Message ID 20221003125915.6912-1-tmn505@terefe.re
State Accepted
Headers show
Series ipq40xx: pakedge_wr-1: convert to DSA | expand

Commit Message

Tomasz Maciej Nowak Oct. 3, 2022, 12:59 p.m. UTC
From: Tomasz Maciej Nowak <tmn505@gmail.com>

And enable the device.

Signed-off-by: Tomasz Maciej Nowak <tmn505@gmail.com>
---
 .../ipq40xx/base-files/etc/board.d/02_network |  1 +
 .../arch/arm/boot/dts/qcom-ipq4018-wr-1.dts   | 37 +++++++++++++++++++
 target/linux/ipq40xx/image/generic.mk         |  3 +-
 3 files changed, 39 insertions(+), 2 deletions(-)

Comments

Robert Marko Oct. 5, 2022, 4:21 p.m. UTC | #1
On Mon, 3 Oct 2022 at 15:00, Tomasz Maciej Nowak <tmn505@terefe.re> wrote:
>
> From: Tomasz Maciej Nowak <tmn505@gmail.com>
>
> And enable the device.
>
> Signed-off-by: Tomasz Maciej Nowak <tmn505@gmail.com>

LGTM, so:
Reviewed-by: Robert Marko <robimarko@gmail.com>
> ---
>  .../ipq40xx/base-files/etc/board.d/02_network |  1 +
>  .../arch/arm/boot/dts/qcom-ipq4018-wr-1.dts   | 37 +++++++++++++++++++
>  target/linux/ipq40xx/image/generic.mk         |  3 +-
>  3 files changed, 39 insertions(+), 2 deletions(-)
>
> diff --git a/target/linux/ipq40xx/base-files/etc/board.d/02_network b/target/linux/ipq40xx/base-files/etc/board.d/02_network
> index d9a162b10d42..163dcdcbc681 100644
> --- a/target/linux/ipq40xx/base-files/etc/board.d/02_network
> +++ b/target/linux/ipq40xx/base-files/etc/board.d/02_network
> @@ -21,6 +21,7 @@ ipq40xx_setup_interfaces()
>         mikrotik,hap-ac3|\
>         p2w,r619ac-64m|\
>         p2w,r619ac-128m|\
> +       pakedge,wr-1|\
>         zyxel,nbg6617)
>                 ucidef_set_interfaces_lan_wan "lan1 lan2 lan3 lan4" "wan"
>                 ;;
> diff --git a/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-wr-1.dts b/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-wr-1.dts
> index 317fe26e2e9a..16951da47fc0 100644
> --- a/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-wr-1.dts
> +++ b/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-wr-1.dts
> @@ -11,6 +11,7 @@
>         compatible = "pakedge,wr-1";
>
>         aliases {
> +               label-mac-device = &gmac;
>                 led-boot = &led_power;
>                 led-failsafe = &led_power;
>                 led-running = &led_power;
> @@ -177,6 +178,10 @@
>         status = "okay";
>  };
>
> +&gmac {
> +       status = "okay";
> +};
> +
>  &mdio {
>         status = "okay";
>  };
> @@ -185,6 +190,38 @@
>         status = "okay";
>  };
>
> +&switch {
> +       status = "okay";
> +};
> +
> +&swport1 {
> +       status = "okay";
> +
> +       label = "lan4";
> +};
> +
> +&swport2 {
> +       status = "okay";
> +
> +       label = "lan3";
> +};
> +
> +&swport3 {
> +       status = "okay";
> +
> +       label = "lan2";
> +};
> +
> +&swport4 {
> +       status = "okay";
> +
> +       label = "lan1";
> +};
> +
> +&swport5 {
> +       status = "okay";
> +};
> +
>  &tlmm {
>         key_pins: key_pinmux {
>                 mux {
> diff --git a/target/linux/ipq40xx/image/generic.mk b/target/linux/ipq40xx/image/generic.mk
> index 69ec42c26657..3c1cf6744882 100644
> --- a/target/linux/ipq40xx/image/generic.mk
> +++ b/target/linux/ipq40xx/image/generic.mk
> @@ -938,8 +938,7 @@ define Device/pakedge_wr-1
>         IMAGE_SIZE := 31232k
>         IMAGE/sysupgrade.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | append-metadata
>  endef
> -# Missing DSA Setup
> -#TARGET_DEVICES += pakedge_wr-1
> +TARGET_DEVICES += pakedge_wr-1
>
>  define Device/plasmacloud_pa1200
>         $(call Device/FitImageLzma)
> --
> 2.37.3
>
>
> _______________________________________________
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://lists.openwrt.org/mailman/listinfo/openwrt-devel
Christian Marangi Oct. 5, 2022, 5:19 p.m. UTC | #2
On Mon, Oct 03, 2022 at 02:59:15PM +0200, Tomasz Maciej Nowak wrote:
> From: Tomasz Maciej Nowak <tmn505@gmail.com>
> 
> And enable the device.
> 
> Signed-off-by: Tomasz Maciej Nowak <tmn505@gmail.com>

Hi, merged with ee38573093563a11569afd98495f7a7a85e9a02f with minor
changes to the commit description.

Thanks!

> ---
>  .../ipq40xx/base-files/etc/board.d/02_network |  1 +
>  .../arch/arm/boot/dts/qcom-ipq4018-wr-1.dts   | 37 +++++++++++++++++++
>  target/linux/ipq40xx/image/generic.mk         |  3 +-
>  3 files changed, 39 insertions(+), 2 deletions(-)
> 
> diff --git a/target/linux/ipq40xx/base-files/etc/board.d/02_network b/target/linux/ipq40xx/base-files/etc/board.d/02_network
> index d9a162b10d42..163dcdcbc681 100644
> --- a/target/linux/ipq40xx/base-files/etc/board.d/02_network
> +++ b/target/linux/ipq40xx/base-files/etc/board.d/02_network
> @@ -21,6 +21,7 @@ ipq40xx_setup_interfaces()
>  	mikrotik,hap-ac3|\
>  	p2w,r619ac-64m|\
>  	p2w,r619ac-128m|\
> +	pakedge,wr-1|\
>  	zyxel,nbg6617)
>  		ucidef_set_interfaces_lan_wan "lan1 lan2 lan3 lan4" "wan"
>  		;;
> diff --git a/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-wr-1.dts b/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-wr-1.dts
> index 317fe26e2e9a..16951da47fc0 100644
> --- a/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-wr-1.dts
> +++ b/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-wr-1.dts
> @@ -11,6 +11,7 @@
>  	compatible = "pakedge,wr-1";
>  
>  	aliases {
> +		label-mac-device = &gmac;
>  		led-boot = &led_power;
>  		led-failsafe = &led_power;
>  		led-running = &led_power;
> @@ -177,6 +178,10 @@
>  	status = "okay";
>  };
>  
> +&gmac {
> +	status = "okay";
> +};
> +
>  &mdio {
>  	status = "okay";
>  };
> @@ -185,6 +190,38 @@
>  	status = "okay";
>  };
>  
> +&switch {
> +	status = "okay";
> +};
> +
> +&swport1 {
> +	status = "okay";
> +
> +	label = "lan4";
> +};
> +
> +&swport2 {
> +	status = "okay";
> +
> +	label = "lan3";
> +};
> +
> +&swport3 {
> +	status = "okay";
> +
> +	label = "lan2";
> +};
> +
> +&swport4 {
> +	status = "okay";
> +
> +	label = "lan1";
> +};
> +
> +&swport5 {
> +	status = "okay";
> +};
> +
>  &tlmm {
>  	key_pins: key_pinmux {
>  		mux {
> diff --git a/target/linux/ipq40xx/image/generic.mk b/target/linux/ipq40xx/image/generic.mk
> index 69ec42c26657..3c1cf6744882 100644
> --- a/target/linux/ipq40xx/image/generic.mk
> +++ b/target/linux/ipq40xx/image/generic.mk
> @@ -938,8 +938,7 @@ define Device/pakedge_wr-1
>  	IMAGE_SIZE := 31232k
>  	IMAGE/sysupgrade.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | append-metadata
>  endef
> -# Missing DSA Setup
> -#TARGET_DEVICES += pakedge_wr-1
> +TARGET_DEVICES += pakedge_wr-1
>  
>  define Device/plasmacloud_pa1200
>  	$(call Device/FitImageLzma)
> -- 
> 2.37.3
> 
> 
> _______________________________________________
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://lists.openwrt.org/mailman/listinfo/openwrt-devel
diff mbox series

Patch

diff --git a/target/linux/ipq40xx/base-files/etc/board.d/02_network b/target/linux/ipq40xx/base-files/etc/board.d/02_network
index d9a162b10d42..163dcdcbc681 100644
--- a/target/linux/ipq40xx/base-files/etc/board.d/02_network
+++ b/target/linux/ipq40xx/base-files/etc/board.d/02_network
@@ -21,6 +21,7 @@  ipq40xx_setup_interfaces()
 	mikrotik,hap-ac3|\
 	p2w,r619ac-64m|\
 	p2w,r619ac-128m|\
+	pakedge,wr-1|\
 	zyxel,nbg6617)
 		ucidef_set_interfaces_lan_wan "lan1 lan2 lan3 lan4" "wan"
 		;;
diff --git a/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-wr-1.dts b/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-wr-1.dts
index 317fe26e2e9a..16951da47fc0 100644
--- a/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-wr-1.dts
+++ b/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-wr-1.dts
@@ -11,6 +11,7 @@ 
 	compatible = "pakedge,wr-1";
 
 	aliases {
+		label-mac-device = &gmac;
 		led-boot = &led_power;
 		led-failsafe = &led_power;
 		led-running = &led_power;
@@ -177,6 +178,10 @@ 
 	status = "okay";
 };
 
+&gmac {
+	status = "okay";
+};
+
 &mdio {
 	status = "okay";
 };
@@ -185,6 +190,38 @@ 
 	status = "okay";
 };
 
+&switch {
+	status = "okay";
+};
+
+&swport1 {
+	status = "okay";
+
+	label = "lan4";
+};
+
+&swport2 {
+	status = "okay";
+
+	label = "lan3";
+};
+
+&swport3 {
+	status = "okay";
+
+	label = "lan2";
+};
+
+&swport4 {
+	status = "okay";
+
+	label = "lan1";
+};
+
+&swport5 {
+	status = "okay";
+};
+
 &tlmm {
 	key_pins: key_pinmux {
 		mux {
diff --git a/target/linux/ipq40xx/image/generic.mk b/target/linux/ipq40xx/image/generic.mk
index 69ec42c26657..3c1cf6744882 100644
--- a/target/linux/ipq40xx/image/generic.mk
+++ b/target/linux/ipq40xx/image/generic.mk
@@ -938,8 +938,7 @@  define Device/pakedge_wr-1
 	IMAGE_SIZE := 31232k
 	IMAGE/sysupgrade.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | append-metadata
 endef
-# Missing DSA Setup
-#TARGET_DEVICES += pakedge_wr-1
+TARGET_DEVICES += pakedge_wr-1
 
 define Device/plasmacloud_pa1200
 	$(call Device/FitImageLzma)