diff mbox series

kernel: load FAT filesystem drivers before mount_root

Message ID 20220829142218.13371-1-tmn505@terefe.re
State Accepted
Delegated to: Hauke Mehrtens
Headers show
Series kernel: load FAT filesystem drivers before mount_root | expand

Commit Message

Tomasz Maciej Nowak Aug. 29, 2022, 2:22 p.m. UTC
From: Tomasz Maciej Nowak <tmn505@gmail.com>

Devices using GPT usually have FAT filesystem on boot partition and
that's where the intermediary backup of system configuration is stored
on sysupgrade. Automatic restoring of OpenWrt configuration after
sysupgrade will be inhibited if the driver is not loaded and file system
type is not specified in mount command.

Signed-off-by: Tomasz Maciej Nowak <tmn505@gmail.com>
---
 package/kernel/linux/modules/fs.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/package/kernel/linux/modules/fs.mk b/package/kernel/linux/modules/fs.mk
index 0e4c0c091a5a..3ad458286f45 100644
--- a/package/kernel/linux/modules/fs.mk
+++ b/package/kernel/linux/modules/fs.mk
@@ -601,7 +601,7 @@  define KernelPackage/fs-vfat
   FILES:= \
 	$(LINUX_DIR)/fs/fat/fat.ko \
 	$(LINUX_DIR)/fs/fat/vfat.ko
-  AUTOLOAD:=$(call AutoLoad,30,fat vfat)
+  AUTOLOAD:=$(call AutoLoad,30,fat vfat,1)
   $(call AddDepends/nls,cp437 iso8859-1 utf8)
 endef