diff mbox series

uboot-fritz4040: build FritzBox 7520 variant

Message ID 20220715055915.4660-1-a.heider@gmail.com
State Accepted
Headers show
Series uboot-fritz4040: build FritzBox 7520 variant | expand

Commit Message

Andre Heider July 15, 2022, 5:59 a.m. UTC
Support was added as variant of 7530 (DEVICE_ALT0_*) in:
cb6f4be1 "ipq40xx: add support for FRITZ!Box 7520"

u-boot has a distinct config for it [0], built it.

[0] https://github.com/chunkeey/FritzBox-4040-UBOOT/pull/6

Signed-off-by: Andre Heider <a.heider@gmail.com>
---
 package/boot/uboot-fritz4040/Makefile | 7 ++++++-
 1 file changed, 6 insertions(+), 1 deletion(-)

Comments

Andre Heider Sept. 27, 2022, 11:35 a.m. UTC | #1
Gentle Ping!

On 15/07/2022 07:59, Andre Heider wrote:
> Support was added as variant of 7530 (DEVICE_ALT0_*) in:
> cb6f4be1 "ipq40xx: add support for FRITZ!Box 7520"
> 
> u-boot has a distinct config for it [0], built it.
> 
> [0] https://github.com/chunkeey/FritzBox-4040-UBOOT/pull/6
> 
> Signed-off-by: Andre Heider <a.heider@gmail.com>
> ---
>   package/boot/uboot-fritz4040/Makefile | 7 ++++++-
>   1 file changed, 6 insertions(+), 1 deletion(-)
> 
> diff --git a/package/boot/uboot-fritz4040/Makefile b/package/boot/uboot-fritz4040/Makefile
> index 3aa08081bf..e3ff69d0e4 100644
> --- a/package/boot/uboot-fritz4040/Makefile
> +++ b/package/boot/uboot-fritz4040/Makefile
> @@ -41,6 +41,11 @@ define U-Boot/fritz4040
>     BUILD_DEVICES:=avm_fritzbox-4040
>   endef
>   
> +define U-Boot/fritz7520
> +  NAME:=FritzBox 7520
> +  BUILD_DEVICES:=avm_fritzbox-7530
> +endef
> +
>   define U-Boot/fritz7530
>     NAME:=FritzBox 7530
>     BUILD_DEVICES:=avm_fritzbox-7530
> @@ -72,6 +77,6 @@ define Package/u-boot/install
>   	$(INSTALL_BIN) $(PKG_BUILD_DIR)/upload-to-f4040.sh $(1)/
>   endef
>   
> -UBOOT_TARGETS := fritz1200 fritz3000 fritz4040 fritz7530
> +UBOOT_TARGETS := fritz1200 fritz3000 fritz4040 fritz7520 fritz7530
>   
>   $(eval $(call BuildPackage/U-Boot))
Martin Blumenstingl Sept. 27, 2022, 7:09 p.m. UTC | #2
The sender domain has a DMARC Reject/Quarantine policy which disallows
sending mailing list messages using the original "From" header.

To mitigate this problem, the original message has been wrapped
automatically by the mailing list software.
On Fri, Jul 15, 2022 at 8:02 AM Andre Heider <a.heider@gmail.com> wrote:
>
> Support was added as variant of 7530 (DEVICE_ALT0_*) in:
> cb6f4be1 "ipq40xx: add support for FRITZ!Box 7520"
>
> u-boot has a distinct config for it [0], built it.
>
> [0] https://github.com/chunkeey/FritzBox-4040-UBOOT/pull/6
>
> Signed-off-by: Andre Heider <a.heider@gmail.com>
Thanks for the patch! I got a cheap 7520 and flashed OpenWrt on it
using this patch. Everything works fine as far as I can tell, so:
Tested-by: Martin Blumenstingl <martin.blumenstingl@googlemail.com>


Best regards,
Martin
Andre Heider Oct. 20, 2022, 1:09 p.m. UTC | #3
Anyone? Bueller?

On 27/09/2022 13:35, Andre Heider wrote:
> Gentle Ping!
> 
> On 15/07/2022 07:59, Andre Heider wrote:
>> Support was added as variant of 7530 (DEVICE_ALT0_*) in:
>> cb6f4be1 "ipq40xx: add support for FRITZ!Box 7520"
>>
>> u-boot has a distinct config for it [0], built it.
>>
>> [0] https://github.com/chunkeey/FritzBox-4040-UBOOT/pull/6
>>
>> Signed-off-by: Andre Heider <a.heider@gmail.com>
>> ---
>>   package/boot/uboot-fritz4040/Makefile | 7 ++++++-
>>   1 file changed, 6 insertions(+), 1 deletion(-)
>>
>> diff --git a/package/boot/uboot-fritz4040/Makefile 
>> b/package/boot/uboot-fritz4040/Makefile
>> index 3aa08081bf..e3ff69d0e4 100644
>> --- a/package/boot/uboot-fritz4040/Makefile
>> +++ b/package/boot/uboot-fritz4040/Makefile
>> @@ -41,6 +41,11 @@ define U-Boot/fritz4040
>>     BUILD_DEVICES:=avm_fritzbox-4040
>>   endef
>> +define U-Boot/fritz7520
>> +  NAME:=FritzBox 7520
>> +  BUILD_DEVICES:=avm_fritzbox-7530
>> +endef
>> +
>>   define U-Boot/fritz7530
>>     NAME:=FritzBox 7530
>>     BUILD_DEVICES:=avm_fritzbox-7530
>> @@ -72,6 +77,6 @@ define Package/u-boot/install
>>       $(INSTALL_BIN) $(PKG_BUILD_DIR)/upload-to-f4040.sh $(1)/
>>   endef
>> -UBOOT_TARGETS := fritz1200 fritz3000 fritz4040 fritz7530
>> +UBOOT_TARGETS := fritz1200 fritz3000 fritz4040 fritz7520 fritz7530
>>   $(eval $(call BuildPackage/U-Boot))
>
Christian Marangi Oct. 20, 2022, 3:40 p.m. UTC | #4
Merged in master with commit 9f27c33e4ede180ee6d0ad359d12f4849bd342f2.

Thanks.
Christian Marangi Oct. 20, 2022, 3:40 p.m. UTC | #5
Merged.
Thank you!
Christian Marangi Oct. 20, 2022, 3:44 p.m. UTC | #6
On Thu, Oct 20, 2022 at 05:40:37PM +0200, Christian Marangi wrote:
> Merged in master with commit 9f27c33e4ede180ee6d0ad359d12f4849bd342f2.
> 
> Thanks.
> 
> 

Sorry had to rebase... real commit is edbf9f156f85c90c899a576aff8a9f8aa506d4a5
Andre Heider Oct. 21, 2022, 7:52 a.m. UTC | #7
On 20/10/2022 17:44, Christian Marangi wrote:
> On Thu, Oct 20, 2022 at 05:40:37PM +0200, Christian Marangi wrote:
>> Merged in master with commit 9f27c33e4ede180ee6d0ad359d12f4849bd342f2.
>>
>> Thanks.
>>
>>
> 
> Sorry had to rebase... real commit is edbf9f156f85c90c899a576aff8a9f8aa506d4a5

Nice, thanks!
diff mbox series

Patch

diff --git a/package/boot/uboot-fritz4040/Makefile b/package/boot/uboot-fritz4040/Makefile
index 3aa08081bf..e3ff69d0e4 100644
--- a/package/boot/uboot-fritz4040/Makefile
+++ b/package/boot/uboot-fritz4040/Makefile
@@ -41,6 +41,11 @@  define U-Boot/fritz4040
   BUILD_DEVICES:=avm_fritzbox-4040
 endef
 
+define U-Boot/fritz7520
+  NAME:=FritzBox 7520
+  BUILD_DEVICES:=avm_fritzbox-7530
+endef
+
 define U-Boot/fritz7530
   NAME:=FritzBox 7530
   BUILD_DEVICES:=avm_fritzbox-7530
@@ -72,6 +77,6 @@  define Package/u-boot/install
 	$(INSTALL_BIN) $(PKG_BUILD_DIR)/upload-to-f4040.sh $(1)/
 endef
 
-UBOOT_TARGETS := fritz1200 fritz3000 fritz4040 fritz7530
+UBOOT_TARGETS := fritz1200 fritz3000 fritz4040 fritz7520 fritz7530
 
 $(eval $(call BuildPackage/U-Boot))