diff mbox series

[22.03,4/4] ath79: bsap18x0: pad rootfs image

Message ID 20220704122306.6263-4-tmn505@terefe.re
State Accepted, archived
Headers show
Series [22.03,1/4] ath79: switch some RedBoot based devices to OKLI loader | expand

Commit Message

Tomasz Maciej Nowak July 4, 2022, 12:23 p.m. UTC
From: Tomasz Maciej Nowak <tmn505@gmail.com>

This image is supposed to be written with help of bootloader to the
flash, but as it stands, it's not aligned to block size and RedBoot will
happily create non-aligned partition size in FIS directory. This could
lead to kernel to mark the partition as read-only, therefore pad the
image to block erase size boundary.

Signed-off-by: Tomasz Maciej Nowak <tmn505@gmail.com>
(cherry picked from commit 9decd2a8436d2bb6b5f436268c92a6e6728486ce)
---
 target/linux/ath79/image/generic.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 2b81690654e6..2d4d1e5c91b8 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -208,7 +208,7 @@  define Device/adtran_bsap1880
   IMAGE_SIZE := 11200k
   IMAGES += kernel.bin rootfs.bin
   IMAGE/kernel.bin := append-kernel
-  IMAGE/rootfs.bin := append-rootfs | pad-rootfs
+  IMAGE/rootfs.bin := append-rootfs | pad-rootfs | pad-to $$(BLOCKSIZE)
   IMAGE/sysupgrade.bin := append-rootfs | pad-rootfs | \
 	check-size | sysupgrade-tar rootfs=$$$$@ | append-metadata
 endef