diff mbox series

libmnl: fix build when bash is not located at /bin/bash

Message ID 20220621143342.90040-1-mark@mentovai.com
State Superseded
Headers show
Series libmnl: fix build when bash is not located at /bin/bash | expand

Commit Message

Mark Mentovai June 21, 2022, 2:38 p.m. UTC
From: Mark Mentovai <mark@moxienet.com>

This fixes the libmnl build on macOS, which ships with an outdated bash
at /bin/bash. During the OpenWrt build, a modern host bash is built and
made available at staging_dir/host/bin/bash, which is present before
/bin/bash in the build's PATH.

This is similar to 8f7ce3aa6dda, presently appearing at
package/kernel/mac80211/patches/build/001-fix_build.patch.

Signed-off-by: Mark Mentovai <mark@mentovai.com>
---
 package/libs/libmnl/patches/001-fix_build.patch | 11 +++++++++++
 1 file changed, 11 insertions(+)
 create mode 100644 package/libs/libmnl/patches/001-fix_build.patch

Comments

Hauke Mehrtens July 10, 2022, 10:58 p.m. UTC | #1
On 6/21/22 16:38, Mark Mentovai wrote:
> From: Mark Mentovai <mark@moxienet.com>
> 
> This fixes the libmnl build on macOS, which ships with an outdated bash
> at /bin/bash. During the OpenWrt build, a modern host bash is built and
> made available at staging_dir/host/bin/bash, which is present before
> /bin/bash in the build's PATH.
> 
> This is similar to 8f7ce3aa6dda, presently appearing at
> package/kernel/mac80211/patches/build/001-fix_build.patch.
> 
> Signed-off-by: Mark Mentovai <mark@mentovai.com>

The author email address in the From field and the Signed-off-by line do 
not match.

The rest of the patch looks ok.

Hauke
Mark Mentovai July 10, 2022, 11:41 p.m. UTC | #2
Hauke Mehrtens wrote:
> On 6/21/22 16:38, Mark Mentovai wrote:
>> From: Mark Mentovai <mark@moxienet.com>
>> 
>> This fixes the libmnl build on macOS, which ships with an outdated bash
>> at /bin/bash. During the OpenWrt build, a modern host bash is built and
>> made available at staging_dir/host/bin/bash, which is present before
>> /bin/bash in the build's PATH.
>> 
>> This is similar to 8f7ce3aa6dda, presently appearing at
>> package/kernel/mac80211/patches/build/001-fix_build.patch.
>> 
>> Signed-off-by: Mark Mentovai <mark@mentovai.com>
>
> The author email address in the From field and the Signed-off-by line do not 
> match.
>
> The rest of the patch looks ok.

That’s git-send-email trying to make a fool of me. I’ll resend as v2.
diff mbox series

Patch

diff --git a/package/libs/libmnl/patches/001-fix_build.patch b/package/libs/libmnl/patches/001-fix_build.patch
new file mode 100644
index 000000000000..030020abacbe
--- /dev/null
+++ b/package/libs/libmnl/patches/001-fix_build.patch
@@ -0,0 +1,11 @@ 
+--- a/doxygen/Makefile.am
++++ b/doxygen/Makefile.am
+@@ -21,7 +21,7 @@
+ # The command has to be a single line so the functions work
+ # and so `make` gives all lines to `bash -c`
+ # (hence ";\" at the end of every line but the last).
+-	/bin/bash -p -c 'declare -A renamed_page;\
++	bash -p -c 'declare -A renamed_page;\
+ main(){ set -e; cd man/man3; rm -f _*;\
+   count_real_pages;\
+   rename_real_pages;\