diff mbox series

[2/8] libselinux: update to version 3.4

Message ID 20220519185418.168937-3-dominick.grift@defensec.nl
State New
Headers show
Series [1/8] libsepol: update to version 3.4 | expand

Commit Message

Dominick Grift May 19, 2022, 6:54 p.m. UTC
libselinux depends on pcre2 instead of pcre as of version 3.4

0a8c177d Update VERSIONs to 3.4 for release.
822ad96c libselinux: update man page of setfilecon(3) family about context parameter
0c407c3f libselinux/utils: print errno on failure
88d43a8d libselinux: preserve errno in selinux_log()
8266fd94 libselinux: free memory in error branch
7e979b56 libselinux: restorecon: pin file to avoid TOCTOU issues
aaa49aca libselinux: restorecon: forward error if not ENOENT
657420d6 libselinux: restorecon: misc tweaks
a782abf2 libselinux: emulate O_PATH support in fgetfilecon/fsetfilecon
9df28c24 Update VERSIONs to 3.4-rc3 for release.
0b691d1a selinux_restorecon: introduce SELINUX_RESTORECON_COUNT_ERRORS
2a167d11 Update VERSIONs to 3.4-rc2 for release.
e1761979 libselinux: correctly hash specfiles larger than 4G
b9a4d13a libselinux: free memory on selabel_open(3) failure
63df12fe libselinux: correct parameter type in selabel_open(3)
0aa974a4 libselinux: limit has buffer size
1020a5a2 libselinux/utils: check for valid contexts to improve error causes
73562de8 Update VERSIONs to 3.4-rc1 for release.
c1a8da6e libselinux: Close leaked FILEs
4bab3ecc libselinux: Strip spaces before values in config
e0da140d libselinux: use PCRE2 by default
4bafb8eb libselinux: Fix selinux_restorecon_parallel symbol version
02f302fc selinux_restorecon: introduce selinux_restorecon_parallel(3)
a578d1ce selinux_restorecon: add a global mutex to synchronize progress output
78bdce9c libselinux: make is_context_customizable() thread-safe
a3516ec6 libselinux: make selinux_log() thread-safe
46427054 selinux_restorecon: protect file_spec list with a mutex
43dc50fc selinux_restorecon: simplify fl_head allocation by using calloc()
abe410aa label_file: fix a data race
85982d83 libselinux: use valid address to silence glibc 2.34 warnings

Signed-off-by: Dominick Grift <dominick.grift@defensec.nl>
---
 package/libs/libselinux/Makefile | 14 +++++++-------
 1 file changed, 7 insertions(+), 7 deletions(-)
diff mbox series

Patch

diff --git a/package/libs/libselinux/Makefile b/package/libs/libselinux/Makefile
index 6bda72b5de..9a485157b8 100644
--- a/package/libs/libselinux/Makefile
+++ b/package/libs/libselinux/Makefile
@@ -6,19 +6,19 @@ 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libselinux
-PKG_VERSION:=3.3
-PKG_RELEASE:=2
+PKG_VERSION:=3.4
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://github.com/SELinuxProject/selinux/releases/download/$(PKG_VERSION)
-PKG_HASH:=acfdee27633d2496508c28727c3d41d3748076f66d42fccde2e6b9f3463a7057
-HOST_BUILD_DEPENDS:=libsepol/host pcre/host
+PKG_HASH:=77c294a927e6795c2e98f74b5c3adde9c8839690e9255b767c5fca6acff9b779
+HOST_BUILD_DEPENDS:=libsepol/host pcre2/host
 
 PKG_LICENSE:=libselinux-1.0
 PKG_LICENSE_FILES:=LICENSE
 PKG_MAINTAINER:=Thomas Petazzoni <thomas.petazzoni@bootlin.com>
 
-HOST_BUILD_DEPENDS:=libsepol/host musl-fts/host pcre/host
+HOST_BUILD_DEPENDS:=libsepol/host musl-fts/host pcre2/host
 
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/host-build.mk
@@ -71,7 +71,7 @@  define Package/libselinux
   $(call Package/libselinux/Default)
   SECTION:=libs
   CATEGORY:=Libraries
-  DEPENDS:=+libsepol +libpcre +USE_MUSL:musl-fts
+  DEPENDS:=+libsepol +libpcre2 +USE_MUSL:musl-fts
 endef
 
 define Package/libselinux/description
@@ -103,7 +103,7 @@  endef
 $(foreach a,$(LIBSELINUX_UTILS),$(eval $(call GenUtilPkg,libselinux-$(a),$(a))))
 
 # Needed to link libselinux utilities, which link against
-# libselinux.so, which indirectly depends on libpcre.so, installed in
+# libselinux.so, which indirectly depends on libpcre2.so, installed in
 # $(STAGING_DIR_HOSTPKG).
 HOST_LDFLAGS += -Wl,-rpath="$(STAGING_DIR_HOSTPKG)/lib"