diff mbox series

ltq-atm/ltq-ptm: avoid unnecessary build dependencies

Message ID 20220425194350.1221966-1-jan@3e8.eu
State Accepted
Delegated to: Daniel Golle
Headers show
Series ltq-atm/ltq-ptm: avoid unnecessary build dependencies | expand

Commit Message

Jan Hoffmann April 25, 2022, 7:43 p.m. UTC
Right now, both ltq-adsl-mei and ltq-vdsl-mei are always built, even
when they aren't necessary for the selected variant. This can cause the
build to fail, for example ltq-vdsl-mei doesn't build successfully here
on xway target due to the vectoring callback.

Make these dependencies conditional on the specific package variants,
so they are only built when actually needed.

Signed-off-by: Jan Hoffmann <jan@3e8.eu>
---
 package/kernel/lantiq/ltq-atm/Makefile | 13 +++++++++----
 package/kernel/lantiq/ltq-ptm/Makefile |  4 ++--
 2 files changed, 11 insertions(+), 6 deletions(-)

Comments

Martin Blumenstingl April 29, 2022, 6:12 p.m. UTC | #1
The sender domain has a DMARC Reject/Quarantine policy which disallows
sending mailing list messages using the original "From" header.

To mitigate this problem, the original message has been wrapped
automatically by the mailing list software.
On Mon, Apr 25, 2022 at 9:47 PM Jan Hoffmann <jan@3e8.eu> wrote:
>
> Right now, both ltq-adsl-mei and ltq-vdsl-mei are always built, even
> when they aren't necessary for the selected variant. This can cause the
> build to fail, for example ltq-vdsl-mei doesn't build successfully here
> on xway target due to the vectoring callback.
>
> Make these dependencies conditional on the specific package variants,
> so they are only built when actually needed.
>
> Signed-off-by: Jan Hoffmann <jan@3e8.eu>
Tested-by: Martin Blumenstingl <martin.blumenstingl@googlemail.com>

This fixes a build issue on my local system when building the xway
subtarget with Linux 5.15.
Thank you Jan for identifying and fixing this!
diff mbox series

Patch

diff --git a/package/kernel/lantiq/ltq-atm/Makefile b/package/kernel/lantiq/ltq-atm/Makefile
index f675269ca335..b81f3bb29382 100644
--- a/package/kernel/lantiq/ltq-atm/Makefile
+++ b/package/kernel/lantiq/ltq-atm/Makefile
@@ -22,13 +22,18 @@  define KernelPackage/ltq-atm-template
   URL:=http://www.lantiq.com/
   VARIANT:=$(1)
   DEPENDS:=@$(2) +kmod-atm +br2684ctl
+ifeq ($(1),vr9)
+  DEPENDS+= +PACKAGE_kmod-ltq-atm-$(1):kmod-ltq-vdsl-vr9-mei
+else
+  DEPENDS+= +PACKAGE_kmod-ltq-atm-$(1):kmod-ltq-adsl-$(1)-mei
+endif
   FILES:=$(PKG_BUILD_DIR)/ltq_atm_$(1).ko
 endef
 
-KernelPackage/ltq-atm-danube=$(call KernelPackage/ltq-atm-template,danube,(TARGET_lantiq_xway||TARGET_lantiq_xway_legacy) +kmod-ltq-adsl-danube-mei)
-KernelPackage/ltq-atm-ar9=$(call KernelPackage/ltq-atm-template,ar9,TARGET_lantiq_xway +kmod-ltq-adsl-ar9-mei)
-KernelPackage/ltq-atm-ase=$(call KernelPackage/ltq-atm-template,ase,TARGET_lantiq_ase +kmod-ltq-adsl-ase-mei)
-KernelPackage/ltq-atm-vr9=$(call KernelPackage/ltq-atm-template,vr9,TARGET_lantiq_xrx200 +kmod-ltq-vdsl-vr9-mei)
+KernelPackage/ltq-atm-danube=$(call KernelPackage/ltq-atm-template,danube,(TARGET_lantiq_xway||TARGET_lantiq_xway_legacy))
+KernelPackage/ltq-atm-ar9=$(call KernelPackage/ltq-atm-template,ar9,TARGET_lantiq_xway)
+KernelPackage/ltq-atm-ase=$(call KernelPackage/ltq-atm-template,ase,TARGET_lantiq_ase)
+KernelPackage/ltq-atm-vr9=$(call KernelPackage/ltq-atm-template,vr9,TARGET_lantiq_xrx200)
 
 define Build/Configure
 endef
diff --git a/package/kernel/lantiq/ltq-ptm/Makefile b/package/kernel/lantiq/ltq-ptm/Makefile
index 33a23d6853fc..b726cb1560d3 100644
--- a/package/kernel/lantiq/ltq-ptm/Makefile
+++ b/package/kernel/lantiq/ltq-ptm/Makefile
@@ -24,9 +24,9 @@  define KernelPackage/ltq-ptm-template
   VARIANT:=$(1)
   DEPENDS:=@TARGET_lantiq_$(2)
 ifeq ($(1),vr9)
-  DEPENDS+= +kmod-ltq-vdsl-vr9-mei
+  DEPENDS+= +PACKAGE_kmod-ltq-ptm-$(1):kmod-ltq-vdsl-vr9-mei
 else
-  DEPENDS+= +kmod-ltq-adsl-$(1)-mei
+  DEPENDS+= +PACKAGE_kmod-ltq-ptm-$(1):kmod-ltq-adsl-$(1)-mei
 endif
 ifeq ($(1),ase)
   DEPENDS+=@BROKEN