diff mbox series

[7/7] lantiq: add renesas USB3 support

Message ID 20220202125010.A9E9768AFE@verein.lst.de
State New
Headers show
Series lantiq: initial support for x490 Fritzboxes | expand

Commit Message

Torsten Duwe Feb. 2, 2022, 10:39 a.m. UTC
Enable the USB_XHCI_PCI_RENESAS config option on lantiq and note the
usb3 dependency. The XHCI host controller requires a firmware blob,
see https://forum.openwrt.org/t/2071

Signed-off-by: Torsten Duwe <duwe@lst.de>
---
 package/kernel/linux/modules/usb.mk | 1 +
 target/linux/lantiq/config-5.10     | 2 ++
 2 files changed, 3 insertions(+)

Comments

Florian Eckert Feb. 2, 2022, 1:59 p.m. UTC | #1
On 2022-02-02 11:39, Torsten Duwe wrote:
> Enable the USB_XHCI_PCI_RENESAS config option on lantiq and note the
> usb3 dependency. The XHCI host controller requires a firmware blob,
> see https://forum.openwrt.org/t/2071
> 
> Signed-off-by: Torsten Duwe <duwe@lst.de>
> ---
>  package/kernel/linux/modules/usb.mk | 1 +
>  target/linux/lantiq/config-5.10     | 2 ++
>  2 files changed, 3 insertions(+)
> 
> diff --git a/package/kernel/linux/modules/usb.mk
> b/package/kernel/linux/modules/usb.mk
> index f74c02a99f..72bdce4bd8 100644
> --- a/package/kernel/linux/modules/usb.mk
> +++ b/package/kernel/linux/modules/usb.mk
> @@ -1713,6 +1713,7 @@ define KernelPackage/usb3
>  	+TARGET_bcm53xx:kmod-phy-bcm-ns-usb3 \
>  	+TARGET_ramips_mt7621:kmod-usb-xhci-mtk \
>  	+(TARGET_apm821xx_nand&&LINUX_5_10):kmod-usb-xhci-pci-renesas \
> +	+TARGET_lantiq:kmod-usb-xhci-pci-renesas \
>  	+TARGET_mvebu_cortexa9:kmod-usb-xhci-pci-renesas
>    KCONFIG:= \
>  	CONFIG_USB_PCI=y \
> diff --git a/target/linux/lantiq/config-5.10 
> b/target/linux/lantiq/config-5.10
> index a830689e23..9e7874bd5d 100644
> --- a/target/linux/lantiq/config-5.10
> +++ b/target/linux/lantiq/config-5.10
> @@ -220,5 +220,7 @@ CONFIG_SYS_SUPPORTS_VPE_LOADER=y
>  CONFIG_TARGET_ISA_REV=2
>  CONFIG_TICK_CPU_ACCOUNTING=y
>  CONFIG_TINY_SRCU=y
> +CONFIG_USB_XHCI_PCI=y
> +CONFIG_USB_XHCI_PCI_RENESAS=y

That would switch on the driver for all lantiq SOC.
Doesn't that only make sense for the xrx200?

>  CONFIG_USE_OF=y
>  CONFIG_WATCHDOG_CORE=y
diff mbox series

Patch

diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index f74c02a99f..72bdce4bd8 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -1713,6 +1713,7 @@  define KernelPackage/usb3
 	+TARGET_bcm53xx:kmod-phy-bcm-ns-usb3 \
 	+TARGET_ramips_mt7621:kmod-usb-xhci-mtk \
 	+(TARGET_apm821xx_nand&&LINUX_5_10):kmod-usb-xhci-pci-renesas \
+	+TARGET_lantiq:kmod-usb-xhci-pci-renesas \
 	+TARGET_mvebu_cortexa9:kmod-usb-xhci-pci-renesas
   KCONFIG:= \
 	CONFIG_USB_PCI=y \
diff --git a/target/linux/lantiq/config-5.10 b/target/linux/lantiq/config-5.10
index a830689e23..9e7874bd5d 100644
--- a/target/linux/lantiq/config-5.10
+++ b/target/linux/lantiq/config-5.10
@@ -220,5 +220,7 @@  CONFIG_SYS_SUPPORTS_VPE_LOADER=y
 CONFIG_TARGET_ISA_REV=2
 CONFIG_TICK_CPU_ACCOUNTING=y
 CONFIG_TINY_SRCU=y
+CONFIG_USB_XHCI_PCI=y
+CONFIG_USB_XHCI_PCI_RENESAS=y
 CONFIG_USE_OF=y
 CONFIG_WATCHDOG_CORE=y