diff mbox series

ipq40xx: 5.10: refresh config

Message ID 20211104115324.355504-1-robert.marko@sartura.hr
State Accepted, archived
Headers show
Series ipq40xx: 5.10: refresh config | expand

Commit Message

Robert Marko Nov. 4, 2021, 11:53 a.m. UTC
It looks like CONFIG_BLK_CMDLINE_PARSER was forgotten during the Orbi
device merge.
So lets refresh the config with it.

Signed-off-by: Robert Marko <robert.marko@sartura.hr>
---
 target/linux/ipq40xx/config-5.10 | 1 +
 1 file changed, 1 insertion(+)

Comments

Christian Lamparter Nov. 4, 2021, 3:15 p.m. UTC | #1
On 04/11/2021 12:53, Robert Marko wrote:
> It looks like CONFIG_BLK_CMDLINE_PARSER was forgotten during the Orbi
> device merge.
> So lets refresh the config with it.

Hmm, is it missing for 5.4 as well?! The generic 5.4 config doesn't
enable it either.

linux/generic/config-5.4:547:# CONFIG_BLK_CMDLINE_PARSER is not set

And Davide's PR just enables CONFIG_CMDLINE_PARTITION
<https://github.com/openwrt/openwrt/pull/3469/commits/ec55610f9e6dcec73612aa84b19271706b4cbfbf>

Does this mean that Davide Fioravanti PR never worked?

For the future:
|commit 2164877c7f373e14e55fca20b7c4a9c436fe4462
|Author: Christoph Hellwig <hch@lst.de>
|Date:   Wed Jul 28 07:37:56 2021 +0200
|
|   block: remove cmdline-parser.c
|
|   cmdline-parser.c is only used by the cmdline faux partition format,
|   so merge the code into that and avoid an indirect call.
|
|   Signed-off-by: Christoph Hellwig <hch@lst.de>
|   Link: https://lore.kernel.org/r/20210728053756.409654-1-hch@lst.de
|   Signed-off-by: Jens Axboe <axboe@kernel.dk>
So, CONFIG_BLK_CMDLINE_PARSER will be gone with the 5.15 lts :)

> 
> Signed-off-by: Robert Marko <robert.marko@sartura.hr>
> ---
>   target/linux/ipq40xx/config-5.10 | 1 +
>   1 file changed, 1 insertion(+)
> 
> diff --git a/target/linux/ipq40xx/config-5.10 b/target/linux/ipq40xx/config-5.10
> index 16baa99f4d..779c86fc95 100644
> --- a/target/linux/ipq40xx/config-5.10
> +++ b/target/linux/ipq40xx/config-5.10
> @@ -47,6 +47,7 @@ CONFIG_AT803X_PHY=y
>   CONFIG_AUTO_ZRELADDR=y
>   CONFIG_BCH=y
>   CONFIG_BINFMT_FLAT_ARGVP_ENVP_ON_STACK=y
> +CONFIG_BLK_CMDLINE_PARSER=y
>   CONFIG_BLK_DEV_LOOP=y
>   CONFIG_BLK_MQ_PCI=y
>   CONFIG_BOUNCE=y
>
Robert Marko Nov. 4, 2021, 3:17 p.m. UTC | #2
On Thu, Nov 4, 2021 at 4:15 PM Christian Lamparter <chunkeey@gmail.com> wrote:
>
> On 04/11/2021 12:53, Robert Marko wrote:
> > It looks like CONFIG_BLK_CMDLINE_PARSER was forgotten during the Orbi
> > device merge.
> > So lets refresh the config with it.
>
> Hmm, is it missing for 5.4 as well?! The generic 5.4 config doesn't
> enable it either.

Honestly, I haven't checked 5.4 I stumbled upon this when enabling the
DSA driver combo.

>
> linux/generic/config-5.4:547:# CONFIG_BLK_CMDLINE_PARSER is not set
>
> And Davide's PR just enables CONFIG_CMDLINE_PARTITION
> <https://github.com/openwrt/openwrt/pull/3469/commits/ec55610f9e6dcec73612aa84b19271706b4cbfbf>
>
> Does this mean that Davide Fioravanti PR never worked?
Since I don't have the board I honestly don't know, it's possible that
it was pulled in by the other symbol.

Regards,
Robert
>
> For the future:
> |commit 2164877c7f373e14e55fca20b7c4a9c436fe4462
> |Author: Christoph Hellwig <hch@lst.de>
> |Date:   Wed Jul 28 07:37:56 2021 +0200
> |
> |   block: remove cmdline-parser.c
> |
> |   cmdline-parser.c is only used by the cmdline faux partition format,
> |   so merge the code into that and avoid an indirect call.
> |
> |   Signed-off-by: Christoph Hellwig <hch@lst.de>
> |   Link: https://lore.kernel.org/r/20210728053756.409654-1-hch@lst.de
> |   Signed-off-by: Jens Axboe <axboe@kernel.dk>
> So, CONFIG_BLK_CMDLINE_PARSER will be gone with the 5.15 lts :)
>
> >
> > Signed-off-by: Robert Marko <robert.marko@sartura.hr>
> > ---
> >   target/linux/ipq40xx/config-5.10 | 1 +
> >   1 file changed, 1 insertion(+)
> >
> > diff --git a/target/linux/ipq40xx/config-5.10 b/target/linux/ipq40xx/config-5.10
> > index 16baa99f4d..779c86fc95 100644
> > --- a/target/linux/ipq40xx/config-5.10
> > +++ b/target/linux/ipq40xx/config-5.10
> > @@ -47,6 +47,7 @@ CONFIG_AT803X_PHY=y
> >   CONFIG_AUTO_ZRELADDR=y
> >   CONFIG_BCH=y
> >   CONFIG_BINFMT_FLAT_ARGVP_ENVP_ON_STACK=y
> > +CONFIG_BLK_CMDLINE_PARSER=y
> >   CONFIG_BLK_DEV_LOOP=y
> >   CONFIG_BLK_MQ_PCI=y
> >   CONFIG_BOUNCE=y
> >
>
Christian Lamparter Nov. 6, 2021, 11:26 p.m. UTC | #3
On 04/11/2021 16:17, Robert Marko wrote:
> On Thu, Nov 4, 2021 at 4:15 PM Christian Lamparter <chunkeey@gmail.com> wrote:
>>
>> On 04/11/2021 12:53, Robert Marko wrote:
>>> It looks like CONFIG_BLK_CMDLINE_PARSER was forgotten during the Orbi
>>> device merge.
>>> So lets refresh the config with it.
>>
>> Hmm, is it missing for 5.4 as well?! The generic 5.4 config doesn't
>> enable it either.
> 
> Honestly, I haven't checked 5.4 I stumbled upon this when enabling the
> DSA driver combo.

CONFIG_CMDLINE_PARTITION selects CONFIG_BLK_CMDLINE_PARSER.
So that CONFIG_BLK_CMDLINE_PARSER is added during by the refresh, since
it ends up enabled in the generated .config, while it's disabled in the
generic 5.4/5.10 and it's not in config-filter. So no breakage.

(No, I didn't bother with refreshing ipq40xx's 5.4 config.
I found something else when looking in ipq40xx/Makefile:

KERNEL_PATCHVER:=5.10
KERNEL_TESTING_PATCHVER:=5.10

o)

Cheers,
Christian
Robert Marko Nov. 6, 2021, 11:50 p.m. UTC | #4
On Sun, Nov 7, 2021 at 12:26 AM Christian Lamparter <chunkeey@gmail.com> wrote:
>
> On 04/11/2021 16:17, Robert Marko wrote:
> > On Thu, Nov 4, 2021 at 4:15 PM Christian Lamparter <chunkeey@gmail.com> wrote:
> >>
> >> On 04/11/2021 12:53, Robert Marko wrote:
> >>> It looks like CONFIG_BLK_CMDLINE_PARSER was forgotten during the Orbi
> >>> device merge.
> >>> So lets refresh the config with it.
> >>
> >> Hmm, is it missing for 5.4 as well?! The generic 5.4 config doesn't
> >> enable it either.
> >
> > Honestly, I haven't checked 5.4 I stumbled upon this when enabling the
> > DSA driver combo.
>
> CONFIG_CMDLINE_PARTITION selects CONFIG_BLK_CMDLINE_PARSER.
> So that CONFIG_BLK_CMDLINE_PARSER is added during by the refresh, since
> it ends up enabled in the generated .config, while it's disabled in the
> generic 5.4/5.10 and it's not in config-filter. So no breakage.

Ok, its good that it was working fine before the refresh as well.
>
> (No, I didn't bother with refreshing ipq40xx's 5.4 config.
> I found something else when looking in ipq40xx/Makefile:
>
> KERNEL_PATCHVER:=5.10
> KERNEL_TESTING_PATCHVER:=5.10

This was previously a point of discussion, don't remember it leaning
in any direction.
Personally, I don't like keeping KERNEL_TESTING_PATCHVER if it's equal
to the default one.

Regards,
Robert
>
> o)
>
> Cheers,
> Christian
diff mbox series

Patch

diff --git a/target/linux/ipq40xx/config-5.10 b/target/linux/ipq40xx/config-5.10
index 16baa99f4d..779c86fc95 100644
--- a/target/linux/ipq40xx/config-5.10
+++ b/target/linux/ipq40xx/config-5.10
@@ -47,6 +47,7 @@  CONFIG_AT803X_PHY=y
 CONFIG_AUTO_ZRELADDR=y
 CONFIG_BCH=y
 CONFIG_BINFMT_FLAT_ARGVP_ENVP_ON_STACK=y
+CONFIG_BLK_CMDLINE_PARSER=y
 CONFIG_BLK_DEV_LOOP=y
 CONFIG_BLK_MQ_PCI=y
 CONFIG_BOUNCE=y