diff mbox series

bcm4908: start work on images for devices using U-Boot

Message ID 20211103171205.17787-1-zajec5@gmail.com
State Accepted
Delegated to: Rafał Miłecki
Headers show
Series bcm4908: start work on images for devices using U-Boot | expand

Commit Message

Rafał Miłecki Nov. 3, 2021, 5:12 p.m. UTC
From: Rafał Miłecki <rafal@milecki.pl>

New BCM4908 family based routers will use U-Boot bootloader. That will
require using a totally different firmware format. Kernel has to be put
in a FIT image.

OpenWrt has some helpers for generating .its files but they don't fit
BCM4908 requirements and there is no simple way of extending any of
them. The best solution seems to be storing an .its template.

BCM4908 bootfs may:
1. contain extra binaries (other than kernel & DTB)
2. include multiple DTB files
3. store device specific U-Boot configurations with custom properties

Such setups are too complex to generate using shell script. Raw .its
file on the other hand seems quire clean & reasonable.

Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
---
 target/linux/bcm4908/image/Makefile           | 11 ++++++++
 target/linux/bcm4908/image/bootfs-generic.its | 25 +++++++++++++++++++
 2 files changed, 36 insertions(+)
 create mode 100644 target/linux/bcm4908/image/bootfs-generic.its
diff mbox series

Patch

diff --git a/target/linux/bcm4908/image/Makefile b/target/linux/bcm4908/image/Makefile
index 426db4c5a6..929e626e0e 100644
--- a/target/linux/bcm4908/image/Makefile
+++ b/target/linux/bcm4908/image/Makefile
@@ -6,6 +6,17 @@  include $(INCLUDE_DIR)/image.mk
 DEVICE_VARS += ASUS_PRODUCTID ASUS_BUILD_NO ASUS_FW_REV ASUS_EXT_NO
 DEVICE_VARS += NETGEAR_BOARD_ID NETGEAR_REGION
 
+define Image/Prepare
+	cp bootfs-generic.its $(KDIR)/
+endef
+
+define Build/bootfs
+	cat $@ | $(STAGING_DIR_HOST)/bin/lzma e -eos -si -so > $@.tmp
+	mv $@.tmp $@
+	sed -i "s=\$${kernel}=$@=" $(KDIR)/bootfs-generic.its
+	PATH=$(LINUX_DIR)/scripts/dtc:$(PATH) mkimage -f $(KDIR)/bootfs-generic.its $(KDIR)/bootfs-generic.itb
+endef
+
 define Build/bcm4908asus
 	$(STAGING_DIR_HOST)/bin/bcm4908asus create -i $@ \
 		-p $(ASUS_PRODUCTID) -b $(ASUS_BUILD_NO) -f $(ASUS_FW_REV) \
diff --git a/target/linux/bcm4908/image/bootfs-generic.its b/target/linux/bcm4908/image/bootfs-generic.its
new file mode 100644
index 0000000000..d2f19ed752
--- /dev/null
+++ b/target/linux/bcm4908/image/bootfs-generic.its
@@ -0,0 +1,25 @@ 
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+/dts-v1/;
+
+/ {
+	description = "OpenWrt bootfs image";
+	#address-cells = <1>;
+
+	images {
+		kernel {
+			description = "Linux kernel";
+			data = /incbin/("${kernel}");
+			type = "kernel";
+			os = "linux";
+			arch = "arm64";
+			compression = "lzma";
+			load = <0x80000>;
+			entry = <0x80000>;
+
+			hash-1 {
+				algo = "sha256";
+			};
+		};
+	};
+};