diff mbox series

[01/14] imx6: image: fix Gateworks Ventana boot script filename

Message ID 20211013204706.16362-2-pepe2k@gmail.com
State Accepted, archived
Delegated to: Piotr Dymacz
Headers show
Series imx6 conversion into arch-specific subtargets | expand

Commit Message

Piotr Dymacz Oct. 13, 2021, 8:46 p.m. UTC
U-Boot for the Gateworks Ventana includes filename of the boot script in
the default/embedded environment (see 'include/configs/gw_ventana.h' in
the U-Boot sources).

This restores the old boot script filename ('6x_bootscript-ventana'),
making Ventana boards boot again.

Fixes: 8dba71dd33 ("imx6: image: drop BOOT_SCRIPT and fix DEVICE_NAME")
Reported-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
---
 target/linux/imx6/image/Makefile                                | 2 +-
 .../image/{bootscript-gateworks_ventana => bootscript-ventana}  | 0
 2 files changed, 1 insertion(+), 1 deletion(-)
 rename target/linux/imx6/image/{bootscript-gateworks_ventana => bootscript-ventana} (100%)
diff mbox series

Patch

diff --git a/target/linux/imx6/image/Makefile b/target/linux/imx6/image/Makefile
index 948694381e..5f8e5f1c04 100644
--- a/target/linux/imx6/image/Makefile
+++ b/target/linux/imx6/image/Makefile
@@ -124,7 +124,7 @@  define Device/gateworks_ventana
   DEVICE_VENDOR := Gateworks
   DEVICE_MODEL := Ventana family
   DEVICE_VARIANT := normal NAND flash
-  DEVICE_NAME := gateworks_ventana
+  DEVICE_NAME := ventana
   DEVICE_DTS:= \
 	imx6dl-gw51xx \
 	imx6dl-gw52xx \
diff --git a/target/linux/imx6/image/bootscript-gateworks_ventana b/target/linux/imx6/image/bootscript-ventana
similarity index 100%
rename from target/linux/imx6/image/bootscript-gateworks_ventana
rename to target/linux/imx6/image/bootscript-ventana