diff mbox series

[10/14] uboot-imx: set BUILD_SUBTARGET to 'cortexa9'

Message ID 20211013204706.16362-11-pepe2k@gmail.com
State Accepted, archived
Delegated to: Piotr Dymacz
Headers show
Series imx6 conversion into arch-specific subtargets | expand

Commit Message

Piotr Dymacz Oct. 13, 2021, 8:47 p.m. UTC
All currently supported devices belong to the imx/cortexa9 subtarget.

Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
---
 package/boot/uboot-imx/Makefile | 3 +++
 1 file changed, 3 insertions(+)
diff mbox series

Patch

diff --git a/package/boot/uboot-imx/Makefile b/package/boot/uboot-imx/Makefile
index 9ca4d55a1c..2faa48bd73 100644
--- a/package/boot/uboot-imx/Makefile
+++ b/package/boot/uboot-imx/Makefile
@@ -24,6 +24,7 @@  define U-Boot/apalis_imx6
   NAME:=Toradex Apalis
   UBOOT_IMAGE:=SPL u-boot.img u-boot-with-spl.imx
   UBOOT_MAKE_FLAGS:=SPL u-boot.img u-boot-with-spl.imx
+  BUILD_SUBTARGET:=cortexa9
   BUILD_DEVICES:=toradex_apalis
 endef
 
@@ -31,11 +32,13 @@  define U-Boot/mx6cuboxi
   NAME:=SolidRun Cubox-i boards
   UBOOT_IMAGE:=SPL u-boot.img
   UBOOT_MAKE_FLAGS:=SPL u-boot.img
+  BUILD_SUBTARGET:=cortexa9
   BUILD_DEVICES:=solidrun_cubox-i
 endef
 
 define U-Boot/wandboard
   NAME:=Wandboard Dual Lite/Quad/Solo
+  BUILD_SUBTARGET:=cortexa9
   BUILD_DEVICES:=wandboard_dual
 endef